Intel® NUCs
Support for Intel® NUC products
12144 Discussions

NUC8i7HVK GUI elements make video playback in fullscreen choppy (frame drops)



To be fair, this is a very special problem and request and don't expect a solution by "basic treoubleshooting".

I am hoping to find someone with similiar experience, maybe a solution or confirmation that this is broken by design.

I purchased the system just for one main purpose: as powerful Media center for videoplayback. And hilarious here, it fails.

To the issue:

  • For some reason, videoplaybacks get choppy and frames drop, when elements gets displayed
  • For example the navigation bar in MPC-HC
  • or when subtitles are displayed in the official Netflix App
  • Check the Attachement video to get the point

Things I already tried:

  • I have the systems since a good year, so I tried all official and current drivers
  • I also tried the current drivers for Intel and AMD GPU which are not official for this NUC
  • I have tried the back and fron HDMI port, same issue
  • I have disabled hardware accelarion in LAV video decoder
  • I have set force Netflix/MPC-HC to a GPU (Intel -> energy saving mode, AMD -> maximum performance mode) -> with Intel, the issue is even worse
  • I started with Windows 1809 with same issue, 1903, 1909 and now 2004 -> it doesn't matter, all the same
  • I have set general energy profile mode to maximum performance

This is not a specific software issue:

  • completely independent software players do have the issue (Netflix, MPC-HC)

Why I think this a NUC8i7HVK NUC issue:

  • I have so many system around my, starting from a crappy N270 Atom system, til 8086K GTX980Ti  system, Sandy Bridge systems, Haswell systems, sometimes with NVIDIA GPU, some are integrated Intel GPU, Laptops, Desktops....
  • they are all the same way configured as this Intel NUC
  • not a single one system do have this issue. This issue is only with this NUC

So... I have no idea where it might come from. Maybe an AMD issue? (I don't have that much AMD experience) Maybe this special CPU-GPU combination?

The system itself is very powerful, fast and games runs very smooth. It's only this nasty frame drops with the videos, but it's very important it's just impossible to enjoy Netflix.

I have attached you SSU file, but expect full of unsupported drivers, but as I said, it's independed from drivers.

I appreciate any hint to a working solution.

0 Kudos
41 Replies

MKune1, Thank you for posting in the Intel® Communities Support.

According to the SSU report, the BIOS version installed on the Intel® NUC Kit NUC8i7HVK is version 0060, but the latest BIOS version on Intel®'s web site is 0059, where did you get that BIOS version from?

Did you try different HDMI cables, maybe a high-quality cable?

For testing purposes, do you have the option to use the Mini-DP port or the Thunderbolt 3 port?

Also, on the SSU report it says that the Intel® Graphics driver version installed is and there is a newer one, so please install first the Radeon™ RX Vega M graphics driver version 20.2.2 and then Intel® Graphics driver version

Any questions, please let me know.


Albert R.

Intel Customer Support Technician

A Contingent Worker at Intel


Hi Alberto,

as I already mentioned (but I expected this...) the issue has nothing to do with the state of driver. I added the SSU, because you will ask anyway. But sure I will answer the question.

I got the BIOS 0060 from your Intel downloadpage. I know it is pulled back, because some users have some boot issues with specific SSD drives of some brands. I use a Samsung drive, so I am not affected by this bug, so BIOS 0060 is fine for me.

Since I use this system over a year, I can confirm the same issue exist also with BIOS 0059.

Yes, I tried different HDMI cables. The issue is the same. I tried also another Computer on the TV and HDMI cable, there are no frame drops when GUI elemts displayed.

You know, you don't recommend newer drivers, you recommend older drivers.

Since every driverstate release was tried before, I can confirm, the issue also exist with previous drivers and the latest official drivers for the NUC NUC8i7HVK.

If you watch the video carefully, you will notice that the frame drops only appear when the GUI elements have to be loaded. I am rapidly forcing it by moving the mouse into navigation bar in and out to make it visible. It's like, the PC is unable to handle it for no reason. But even my Atom N270 2008 Netbook is able to handle this. So I think this is a bug in hardware or driver.

Community Manager


I tested my Hades Canyon unit running Windows* 10 with the latest update, AMD* Vega Graphics Driver version 20.4.1, screen resolution set to 1920x1080 and refresh rate to 60Hz and I tested Netflix* running from the PC Application and also running from Microsoft* Edge browser and I have no issues at all.

In the video that you provided before "choppy.mp4" I see that the video control options are not the same as in Netflix*, can you please confirm this is Netflix?

taken from "choppy.mp4" videotaken from "choppy.mp4" video

Netflix Screenshot:


Here is some additional information about the system I am using:




Ronny G


Hi Ronny,

thank you for testing.

"can you please confirm this is Netflix?" -> No, this is not Netflix. This is MPC-HC+madVR (with a dark mode navigation bar).

I prefer demonstrating the issue with MPC-HC+madVR, because you can quickly show and hide the navigation bar (or option bar). And the OSD does prove that rendering times rise up during that moment and Frame drops are the result.

On Netflix or "Movies & TV" you always have to wait about 3 seconds until the navigation bar vanish (or subtitles appear) AND the movie should be preferable in a camera movement, otherwise you won't notice.

Also your screenshot not showing Netflix in fullscreen mode. Please set into fullscreen:


Also posting a Screenshot to a problem of timing problem can't prove if something is working or not...

Can you set your TV/monitor to 23Hz? Two reasons: Breaking Bad is 23.976fps content, due lower refresh rate, the issue much better noticable.

Please watch carefully my latest choppy6.mp4 videofile. I tried to show much more detailed when the issue occur, what the madVR is showing meanwhile and when Netflix do have the trouble.

Is the monitor/TV connected to HDMI?

Meanwhile, I tested another computer monitor and HDMTI cable, 1920x1080, 59Hz. There I was able to check with different color ranges, fullRGB 4:4:4, limitedRGB, YCbCr444, but at the end, the issue is the same.



Hi MKune1, Thank you very much for providing that information.

We will do further research on this matter, as soon as I get any updates I will post all the details on this thread.


Albert R.

Intel Customer Support Technician

A Contingent Worker at Intel


Hi Albert,


thats okay. Thank you for taking care.

I created this thread mainly to look for other NUC8i7HVK users who can confirm this issue (and maybe know something to fix it...).

Since the systems are from hardwareside similiar, it should be possible to confirm/deny or reproduce.

I additional have a NUC D34010WYK without the issue. So the main difference is of course the AMD GPU. So I suspect something in Windows OS <-> AMD hardware/driver.

So I additional created a Thread at AMD and voila, a user with AMD RX 580 posted in Thread to confirm to have the same issue.

Super User Retired Employee

The difference is that, as things stand, the AMD RX 580 user will get a fix but we HN/HV users won't.

Just saying,



Ha, yes... Intel promised the 5 years support and AMD provided the GPU technology and so they are in the "No, you!" battle. Nah, jk, they just leave the customer alone.

(You can confirm the issue?)

But I don't care, because I just force the driver installation and just pick the Radio RX Vega graphics card which sounds like mostly RX Vega M GH and so I am on latest 20.4.2 WHQL without running into Error 182. I can't notice any downside or degraded performance to the last official one. See attached Screenshot.

Sooo.... if AMD is able to fix it (if it is an AMD issue...) I might can benefit from. But the symptoms are so much immersed into the Windows GUI (having the task-manager in front of the full screen video already fix it, but then you see... the task-manager), it could maybe also fixed by Microsoft. Maybe it's worth to create a ticket there as well.

Super User Retired Employee

No, I cannot confirm; I am as much in the dark on this one as anyone else. Rumor has it that Intel pulled the plug on this processor and AMD retaliated by withdrawing support. Intel is known for having no patience and pulling the plug on these kinds of "experiments" quickly (way too quickly, IMHO).

Hacking a solution together like this only works for as long as there is not an incompatibility between the AMD solutions. If the pettiness that AMD is displaying with this retaliation were to continue, I can see an incompatibility miraculously appearing sooner rather than later.


Super User

Hi @MKune1 ,

1. The latest Adrenaline driver which is working without problems fro me is the version 19.12.1

2. Please uninstall the version 20.4.2, reboot your NUC and try version 19.12.1. You done so many tests already, try this one.





Hi LeonWaksman,


Okay… I think it’s the third time to say, that I have the system since a good year and I since then I used every single driver with all the same issue. But I am really looking forward for a solution or fix.


I installed the outdated 19.12.1 driver again (run Display Driver Uninstaller before) and resulted in exakt same issue.

So please stop now riding on the driver state about an unfixed issue and take more serious. It’s really demanding if you don’t trust into the words of users.

I have attached you a prove that I installed 19.12.1 with exakt the same issue.


Meanwhile, I have new information to detail the source of the issue. In MPC-HC, we luckily can try a lot oft hings and the issue ocurs in combination with madVR.

madVR is a video render and can provide us a lot of informations.


But before I start, you can change the video renderer in madVR, like EVR-CP or MPC Video-Renderer.

If you change, start a Video in full screen and smash Alt to display In and Out the GUI, the video is absolutely smooth.

If you set Hardware decoding in LAV video to DXVA2 or D3D11 or just software renderer -> all are fine. So I can say, the issue has nothing to do with hardware videodecoding. I don’t use hardware decoding anyway.


As already observed, it has something to do with the (Windows) GUI.


And now back to madVR:

Here you can set under general settings to say „use Direct3D 11 for presentation (Windows 7 and newer)“. If set, presentation is obviously in D3D11. If you uncheck, it will be D3D9.

  • The issue is in presentationmode D3D11 and D3D9 (new path)

Now watch the new attached demonstrationclip choppy4. I have uncheck the „use Direct3D 11“ to make use of D3D9 (new path). When I press Alt, it is changing between fulscreen windowed and windowed. The system struggle, rendering time rise up and droped and repeated frames starts. The playback is garbage (0:25).


But here ist he thing: As the option says Windows 7 or newer, when you set the compatibilitymode for MPC-HC to Windows Vista, madVR will now use „D3D9 (old path)“ and presenting Gui In and Out is absolutly fine and stable. No more frame drops between fullscreen windowed and windowed (1:41).


Back to the D3D11 and D3D9 (new path) mode without the Vista trick. When you open task-manager and force it to be always in front, the video is also smooth when pressing Alt (0:55).


So here is what I think. With any Windows GUI element and Overlay, Windows 10 is somehow hardware accelerate the GUI with the help of DirectX (not sure if WDDM is based on?). As soon, no more GUI element is displayed, Windows GUI is going to somehwat sleepmode to save power and the GPU can’t handle the moment when the GUI needs to be enabled again during playback of a video.

It's the case for Netflix (App), MPC-HC with madVR and even the testvideo in the settings of Windows 10.


So what it does mean for Netflix or the testvideo in Windows 10 settings? Unfortunately it’s a dumb App without providing any options informations. I think the GUI is handled by the GPU the same way as madVR in D3D11 or D3D9 (new path).

The issue sounds very familiar to that thread:


But there are some key differences:

  • All comments are mostly a year old, because it seems it is/was a Bug of 1903 and fixed by a cumulative update
  • only Netflix with subtitles are mentioned, not the GUI, not any other videplayer
  • seems like NVIDIA users were affected


but the symptoms sounds exactly the same. There is even a working solution for Netflix I also tested and can confirm to work:

  1. Tablet mode can be activated by pressing the notifications button on the bottom right. The Tablet Mode button is on the top left of the quick action tiles
  2. To get fullscreen video in tablet mode, right click on the taskbar and go to taskbar settings
  3. Turn on "automatically hide the taskbar in tablet mode" setting
  4. Then expand the Netflix video you are playing in the app as such:

But again, this is only a workaround to "fake fullscreen" and keep the Windows GUI present in background.

As soon I have time, I will post this result also to my AMD thread.

Any tip and trys are still appreciated. And since AMD provided the technology, Intel is doing the Support for the NUC so don't be shy to ask things and collect informations as well.


Super User

Hi @MKune1 ,

1. Sorry for bother you with my suggestion for downgrading the AMD driver. Just wanted to help you. Although you did mentioned that you have your NUC for 1 year, I wasn't sure that you have checked this driver version (it wasn't in the Intel Download Center at no time). Just wrote you that I'm using this driver and haven't see any problems with video. FYI, I'm customer/user like you are and I'm not working for Intel. Could be that your NUC has some hardware failure and need to be replaced (it is still covered by warranty)?

2. Now, I'll will not bother you any more, hopping that you will have better support from Intel engineering.





HI LeonWaksman,

oh you didn't bother me. I know you aren't an Intel engineer. It's a legit request to say to try an official driver for the system. I know it's not a good start to demonstrate an issue with an inofficial driver I understand very well. In my daily work, it's also my task to analyze wrong OS usage and configuration, before we can say, we have a real issue here.

There was like 2 AMD drivers on Intel Download page with rebranding, before they advised to use directly from AMD. Before they did, it was already possible to install the AMD drivers itself. So yes, I had a lot of drivers before

So yes, it is my duty to show that the issue is also with a previous, official driver for the system, because at the end I want to get the issue serious. So here it is. A new SSU and video showing the same issue.

I will try to get more information which feature of OS/GPU/AMD is the reason for the issue. I still wonder whats the difference between "D3D9 (new path)" and "D3D9 (old path)". Maybe someone in Doom9 can tell, I will ask.

Unfortunately I can't test one of the miniDP port. I only have normal DP2DP cables. Or external GPU via Thunderbolt it would be perfect to isolate to the AMD GPU or not.

Since the issue should be easy to reproduce with the Netflix App, it's the task of Intel engineers to investigate and come up with a solution.

I don't think something is broken on my system. It works absolutely stable and fast. Never had any BSOD or crash. Just perfect... unless this really nasty bug.

So swaping the system would end in the same issue (newer hardware revision anyone?). So I think it's more like broken as designed and would end into refund.


Community Manager

Hi @MKune1,

I read the whole post, very detailed information but can I ask you for something else?

Can you provide me with a short video of the same issue when running Netflix*? I would also need to know the display resolution and even the movie name that you are playing and any other detail I should be aware for issue duplication.

I apologize for asking you for more details, I can easily tell that you have been putting a lot of effort into this but duplicating the issue is the best way to bring it over to the product team.


Ronny G


Hi Ronny,

the example I show in choppy.mp4 is Breaking Bad with enabled subtitltes. and set into fullscreen.

The resolution is 1920x1080. It is more noticable, when you set in 23Hz (most movies are 23.976fps anyway). You will have the frame drop also in 59/60Hz, but less noticable, because it's refreshing faster.

Anmerkung 2020-08-04 085808.png

I have named especially Netflix, because it is most annoyingly when subtitles are displayed.

You can also use the preinstalled "Movie & TV" App from Microsoft. Start a videofile, set it into fullscreen, wait when navigation bar disappear -> stutter, move mouse again to display navigation bar -> stutter.

It's also unrelated to tested videofile. It can be fullHD, 23.976fps, h.265 10-bit or h2.64 8-bit, hardwareacceleartion, it doesn't matter. It all comes down to the Videoplayer Overlay and Windows GUI. I mean, just putting the task-manager in front of video "fix" the issue (see choppy4.mp4).

I have created a new video to make a little more clear:


  • 0:05-0:13 -> Videoplayer in window -> all fine
  • 0:15-0:20 -> Now in fullscreen -> all fine until 0:20
  • 0:20-0:31 -> navigation bar display out (so only video) -> stuttering when subtitle display or vanish
  • 0:31-0:44 -> I move the mouse to keep navigation bar displayed -> no more issue with subtitltes
  • 1:10-1:30 -> Movie & TV App preinstalled -> just wait when navigation fade out -> stutter, I mouse move to get navigation bar back -> stutter
  • 1:42-2:00 -> again MPC-HC with madVR -> As soon as I start pressing Alt, rendering times rise up and frame drops are the result
  • 2:06-2:20 -> I repeat the test, this time with task-manager in front (the Windows GUI is always active) -> and no more issue

In BIOS I have also disabled IGD. Now only Radeon Vega M GH is under graphics adapter and the issue is the same. So for me, one more hint, that the issue is related to AMD graphics solution.

And one more information: The audio is the whole time fine. No cracking, no stuttering, it's only a video/display issue.



MKune1, I share all of your issues with choppy playback in fullscreen with MPC-HC and madvr. It's related to the 20 series of Adrenalin drivers. The last version 19 which the superuser here promotes didn't share this bug. We can only hope that Intel and AMD sort their business out and start support this graphics card again.

As far as your Netflix problem is concerned, I don't think it's related to this particular system. I think it's related to an existing bug in Windows that creates frame skipping and choppiness when the overlay system is utilized to display subtitles in UWP apps like Netflix. I had this problem on laptops and desktops last year. Read this reddit thread: 

Edit: Sorry, didn't see that you had already found the reddit thread. Coincidentally, I'm the one on that thread who posted the Tablet Mode trick that you copied and pasted. It's a small world. FWIW, my devices haven't had this bug for a while now since numerous Windows updates; I'm currently on Version 2004 of windows 10. I don't think that there's anything special about my setups on various devices that would spare me this bug currently.



Thank you for confirming my issue!

But I want to know: you have the NUC, too? Or only a equivalent AMD GPU? And you still have the issue with MPC-HC+madVR? And it's weird, that the Windows Vista compatibilitymode workaround the issue.

'superuser' is just a title, I think you mean LeonWalksman

As you can see, I tried his recommended driver and proved with a video for my case, it did not solve the issue.

Since I have the NUC (starting with Windows version 1809), I have this annoying problem. So yes, the reddit thread is concentrated on Netflix and on a fixed 1903 issue.

But my result is exactly the same as in this thread. So thank you for the Netflix workaround. It's really important or otherwise I don't see a bright future for this NUC. This NUC is meant to be my HTPC.

UWP seems to be an important additional hint here. Because except MPC-HC, the tested software is somehow UWP: Netflix App, Movies & TV, the testvideo in Windows settings, Edge Legacy (Netflix)

So I tested now Netflix in Firefox. And... it's working in fullscreen with subtitles and no stuttering. Interesting...

In my case, I also have several systems around me. Selfbuild (NVIDIA), another old NUC, Laptops and only this system have the issue.


Yes. I have the NUC8i7HVK, just like you. I've read around the madVR DOOM forums and I can't seem to find anyone else experiencing this with madvr and mpc-hc since around april/may when I started experiencing it. So, I believe it's related to the 20 series of the adrenalin drivers for the NUC8i7HVK and that I'm not seeing information about this in those forums because of the relatively small userbase for the NUC8 (perhaps?).


I did see that you've experienced this issue rolling back to 19 series of drivers. Not sure why, it hasn't been my experience. Perhaps, the adrenalin series 20 uninstall wasn't as clean as possible? I also noticed that you use auto refresh rate matching in madVR. I don't use that feature on my NUC8 - I use "smooth motion" which is like a motion interpolation. So, perhaps, you noticing the choppiness on the 19 series is related to that feature? And by the 20 series, the bug was present in both lower and higher refresh rates?


My Netflix issues have long gone away. Not to be condescending, but simply try uninstalling the Netflix UWP app and getting the latest version again from the Windows store. Seeing as how you like auto refresh rate, you might enjoy the unofficial Netflix addon on Kodi. It's called CastagnaIT Netflix addon. Kodi has a setting that automatically matches the contents frame rate with your monitor's refresh rate. So, Netflix content will automatically change refresh rates on Windows. Again, it's an "unofficial" addon, but I'm led to believe it's very safe.


Hi PRom0,

I have also asked in madVR thread. Not really for help, but to understand better, what "use Direct3D 11 for presentation (Windows 7 or newer)" means on driver, systemlevel. Because when I set MPC-HC to Vista mode, the OSD shows "D3D9 (old path)" and there is no more issue.

Thats the answer I got from a user:

  • old path is using a back buffer instead of presenting frames in advances.
  • d3d11 adds different feature like rendering in 10 bit.
    it using dx11 instead of dx9.

Related to that information, I limited bit depth to 8-bit, disabled the option of frames in advance, but... it does not workaround the issue. At the end, only the Vista compatibility mode helps (my post is on page 2992 if you want to know).


I used Display Driver Uninstaller in safe mode and doublechecked with DriverStore Explorer that the 20.4.2 was uninstalled fine. After installation 19.12.1 I also checked device manager, that this driver is used. The SSU logfile quadruple prove that driver version 19.12.1 was in use with the same issue.


I have the issue also with Smooth motion and set to 59Hz, but it is less noticable. Can you press Ctrl+J, set movie to full screen and press very fast "Alt" (as I show in videos) and verify, that rendering times stay on low timings and no frame drops occur?

Is you NUC connected to HDMI?

The Netflix Addon for Kodi is something on my long To Do list I hate to start movies, press Ctrl+Shift+Alt+D to find somewhere in tiny writing to fps, to leave the movie again, change manually refresh rate and now additionally do the Tablet Mode trick to have a smoth movie experience.

Once I asked the Netflix Support why no auto refresh rate related to movie content is in the App. They had no idea, what I am talking about, lol. But why should they... when the main business is about watching movies... ^^



I tested 3 systems with MPC-HC and madVR. Fullscreen direct3d11 in madVR. All using latest MPC-HC and madVR. I pressed Alt several times repeatedly to generate the menu bar and shift it between windowed and fullscreen mode.

NUC8i7HVK - Exactly as your results. Multiple frame drops and errors in presentation. Compatibility mode Vista sp2 solves this. NUC is connected via HDMI

NUC5i7RYH - No frame drops w D3D11. Smooth playback at fullscreen. NUC is connected via HDMI

Toshiba satellite laptop - No frame drops w D3D11. Smooth playback at fullscreen


So, i used to do exactly as you do on the Netflix UWP app. CTRL-ATL-SHIFT-D for fps info to then manually change my system. The kodi addon is far superior for automating those steps. It's not as pretty for navigating as the official apps, but if you use the official app's UI to queue up your content it'll be waiting for you in the kodi addon. Very much worth the 15-20 minutes to install and configure.