Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,170 Views

NUC8i7HVK GUI elements make video playback in fullscreen choppy (frame drops)

Hi,

To be fair, this is a very special problem and request and don't expect a solution by "basic treoubleshooting".

I am hoping to find someone with similiar experience, maybe a solution or confirmation that this is broken by design.

I purchased the system just for one main purpose: as powerful Media center for videoplayback. And hilarious here, it fails.

To the issue:

  • For some reason, videoplaybacks get choppy and frames drop, when elements gets displayed
  • For example the navigation bar in MPC-HC
  • or when subtitles are displayed in the official Netflix App
  • Check the Attachement video to get the point

Things I already tried:

  • I have the systems since a good year, so I tried all official and current drivers
  • I also tried the current drivers for Intel and AMD GPU which are not official for this NUC
  • I have tried the back and fron HDMI port, same issue
  • I have disabled hardware accelarion in LAV video decoder
  • I have set force Netflix/MPC-HC to a GPU (Intel -> energy saving mode, AMD -> maximum performance mode) -> with Intel, the issue is even worse
  • I started with Windows 1809 with same issue, 1903, 1909 and now 2004 -> it doesn't matter, all the same
  • I have set general energy profile mode to maximum performance

This is not a specific software issue:

  • completely independent software players do have the issue (Netflix, MPC-HC)

Why I think this a NUC8i7HVK NUC issue:

  • I have so many system around my, starting from a crappy N270 Atom system, til 8086K GTX980Ti  system, Sandy Bridge systems, Haswell systems, sometimes with NVIDIA GPU, some are integrated Intel GPU, Laptops, Desktops....
  • they are all the same way configured as this Intel NUC
  • not a single one system do have this issue. This issue is only with this NUC

So... I have no idea where it might come from. Maybe an AMD issue? (I don't have that much AMD experience) Maybe this special CPU-GPU combination?

The system itself is very powerful, fast and games runs very smooth. It's only this nasty frame drops with the videos, but it's very important it's just impossible to enjoy Netflix.

I have attached you SSU file, but expect full of unsupported drivers, but as I said, it's independed from drivers.

I appreciate any hint to a working solution.

0 Kudos
41 Replies
Highlighted
Novice
412 Views

MKune1,

I tested 3 systems with MPC-HC and madVR. Fullscreen direct3d11 in madVR. All using latest MPC-HC and madVR. I pressed Alt several times repeatedly to generate the menu bar and shift it between windowed and fullscreen mode.

NUC8i7HVK - Exactly as your results. Multiple frame drops and errors in presentation. Compatibility mode Vista sp2 solves this. NUC is connected via HDMI

NUC5i7RYH - No frame drops w D3D11. Smooth playback at fullscreen. NUC is connected via HDMI

Toshiba satellite laptop - No frame drops w D3D11. Smooth playback at fullscreen

 

So, i used to do exactly as you do on the Netflix UWP app. CTRL-ATL-SHIFT-D for fps info to then manually change my system. The kodi addon is far superior for automating those steps. It's not as pretty for navigating as the official apps, but if you use the official app's UI to queue up your content it'll be waiting for you in the kodi addon. Very much worth the 15-20 minutes to install and configure.

0 Kudos
Highlighted
Beginner
404 Views

Thank you for the test and confirming, that the issue in your NUC8i7HVK, too. And you tested with an AMD 19.x release?

 

I manage a lot of systems (not all mine ^^) and can name multiple systems which are all configured the same with MPC-HC and madVR.

 

  • NUC8i7HVK with AMD GPU -> frame drops as this topic is about
  • D34010WYK -> no frame dops
  • ASRock Z390, i7-8086k, GTX980Ti -> no frame drops
  • ASRock Z370, i5-8400, UHD630 -> no frame drops
  • ASRock H97, GT650 -> no frame drops
  • ASRock H87, i5-4570, Intel HD -> no frame drops
  • ThinkPad x201t, i7-620lm, Intel HD -> no frame drops
  • ThinkPad x131e -> no frame drops
  • ThinkPad 13 -> no frame drops
  • Latitude 5400 -> no frame drops
  • OptiPlex 7050 SFF -> no frame drops
  • Asus F551MA (and this is a really bad system) -> no frame drops
  • HP Compaq CQ58 -> no frame drops

But no miniDP to DP cable to test at least this port And no other AMD system.

So, waiting for Ronny...

 

Regards

0 Kudos
Highlighted
Novice
388 Views

I tested using

Adrenalin 20.2.2

Software Version 2020.0228.1832.33370

Driver Version 19.50.19.19-200228a-352369C-RadeonSoftwareAdrenalin2020

 

The other NUC and the laptop both use Intel HD graphics. I too have no other AMD Radeon device.

0 Kudos
Highlighted
Moderator
369 Views

Hi PRom0,

More results: I tried it with the same equivalent system that I mentioned before but this time with Media Player Classic Home Cinema (MPC-HC) which by the way I tried to download from here https://mpc-hc.org/ but couldn't really find it there so I got it from a different source. 

I still see no issues when playing local movies, this movie in particular (see video attached to this post) is using Video Codec (H264) 1920x1072 24fps @ 2150kbps, I played the movie in full-screen mode (the test I did before via Netflix* was also playing in full-screen mode but to take the screenshot I had to go regular screen mode) with the only difference that I am running at 60Hz.

I can run at 25Hz but my display goes "flickering" and even to be able to do that I had to enable "Virtual Super Resolution" and play a little bit with the "Scaling Mode" within the AMD* Graphics Console but that is a different issue. What happens if you set up your system at 60Hz? Do you still experience the same behavior?

By the way, I am running BIOS defaults and I reset my settings on the AMD* Graphics Console to defaults as well.

Please let me know what am I missing for issue duplication and just keep in mind that I would prefer to test anything more current, such as Youtube* or Netflix*, the MPC-HC* is a little outdated.

Thanks,

Ronny G

 

 

 

 

0 Kudos
Highlighted
Beginner
365 Views

Hi Ronny,

pretty sure you forgot to install and set madVR. MPC-HC alone uses Enhances Video Renderer (customer presenter) as DirectShow Video. There is no issue with this renderer.

Also using an Anime for checking the issue is a very bad choise, because Anime contains only sharp stills and drawings get repeated a lot. There is no motion blur.

 

Personally, I use the k-lite codepack and you can configuring during installation, also to use madVR: http://www.codecguide.com/download_k-lite_codec_pack_standard.htm

 

But you can get also the manual way.

Get the current MPC-HC from here: https://github.com/clsid2/mpc-hc/releases

The "homepage" is from original developer who abonnded the project as you noticed.

Grab madVR from here: http://madshi.net/madVR.zip

Extract madVR and run Install.bat with administrator privilegs.

Now start MPC-HC  and go into settings.

and chose madVR as Output. If done done correct, it looks like that:

mpc hc photo.png

(If madVR is not done corretly installed, it will say "madVR **unavailavble**")

Press OK and close MPC-HC again.

Now run a videofile (avoid Anime. Something with smooth motion is better, as I do with 20th Century Fox Logo), press Alt+Enter to go into fullscreen and now also please press Ctrl+J to get the OSD information.

Now repeat the test, record it with the OSD so that we can see rendering times and if frame drops (bottom informations of OSD).

That you can't go for 23Hz is okay, because the issue also happens on 59Hz and 60Hz. I just recommend lower Hz to see it better. So yes, the issue is on 60Hz.

My BIOS is default as well, except that I disabled now Intel GPU, so only AMD GPU, but with the same result.

I played with AMD settings a lot around, but from default settings, to "improvement tricks" or just disable all, nothing does help.

Thank you and regards

0 Kudos
Highlighted
Moderator
347 Views

Hi MKune1,

You are absolutely correct about a few items that I am missing in my system to replicate this issue, thanks for the detailed instruction set and let me run it again and I will get back to you as soon as possible.

Thanks,

Ronny G

0 Kudos
Highlighted
Beginner
328 Views

Hi,

today I was able to get manage a miniDP to DP cable and connect to a PC monitor.

And I can confirm, the issue is also with DP video output. Means in summary, the issue is unrelated to video out connection.

HDMI -> same issue

DP -> same issue

Regards

0 Kudos
Highlighted
Moderator
320 Views

MKune1,

I configured my system following your instructions and I believe I was able to duplicate the issue that you are reporting. 

Please, take a quick look at the video file attached here and let me know your comments.

I am only seeing this behavior when running MPC-HC+madVR , let me run this issue by the escalation team and I will get back to you as soon as possible.

Regards,

Ronny G

 

0 Kudos
Highlighted
Beginner
316 Views

@Ronny_G_Intel 

Yep, that's exactly the issue. Would have been great to see the OSD (Ctrl+J) in the video as well, but I can see the choppy motion when you display the navigation bar.

You can bring the videomotion into real struggle when you just rapidly press "Alt" as fast as you can (displays top optionbar).

As already mention, when you bring mpc-hc64.exe into Vista compatibility mode, the issue is gone (for whatever reason).

And believe me, it is on the Netflix App when navigation bar dis-/appear, Subtitles dis-/appear.

Also the "Movie & TV App" of Windows when navigation bar dis-/appear, or the testvideo in Windows-Settings -> Apps -> Video -> start the testvideo, bring into fullscreen, wait that navigation bar dis-/appear.

If you don't see it, it's probably because of your high refresh rate.

If you might think to start it is a madVR issue, it is not.

Also you can do the same test on any other system with Intel GPU or NVIDIA and you won't have that issue.

Meanwhile I have installed KB4566782 and the issue is the same...

Regards

0 Kudos
Highlighted
Moderator
294 Views

Hi MKune1,

Please try again with this setting set to enable: "enable automatic fullscreen exclusive mode", I did some testing and I no longer experience the issue reported.

 renditionDownload (1).jpg

I would also recommend that you reach out to other support options available if further support is necessary, for instance madVR support via de Bug Tracker: http://bugs.madshi.net/view_all_bug_page.php?project_id=4&dummy=bla/ or perhaps madVR Player Support Community via the AVSForum, this because we have very limited knowledge about this video renderer.

I hope this helps,

Regards,

Ronny G

 

 

0 Kudos
Highlighted
New Contributor III
287 Views

What I would suggest is temporarily disabling the Intel IGP in the BIOS and seeing if that makes any difference?

(I'm aware it's not recommend by Intel to disable the IGP in Windows, but I've not had any issues with doing so on my NUC8i7HVK, nor with manually installing the latest AMD drivers FWIW)


Libera te tutemet ex inferis
0 Kudos
Highlighted
Super User Retired Employee
282 Views

IGP is totally isolated from the graphics connectors and cannot use them (they are exclusively owned by the AMD GPU). It is there to support capabilities like transcoding, protected content, etc. If you do not need these capabilities, you can disable IGP; it has nothing to do with the issue.

...S

0 Kudos
Highlighted
Beginner
249 Views

@Ronny_G_Intel 

For some reason, I didn't get any E-Mail notification about replies to the topic anymore, so sorry for late answer. Also I thought the ticket is already at escalation team: "let me run this issue by the escalation team"

I tried the Exclusive Mode and it does not fix the issue. This mode eliminates the GUI to offer "more performance" for crappy systems.

The truth is: Even my Intel Atom N270 Netbook not needs the "performance boost" and has nothing to do with the issue. The old Netbook can display GUI elements during playback without any framedrops.

We are not talking here about performance issue, this is a hardware/driver/Windows issue.

So the result is the same. When I enable the Exclusive Mode and move the mouse to display navigation bar in and out, the playback gets choppy. It is much less noticable as without Exclusive Mode, but noticable and still there (and the OSD doesn't reflect the delay in statistic with Exclusiv Mode).

 

Also, changing settings in madVR does not have any effect in Netflix App or the Movie & TV App of Microsoft.

So why should I open a bug ticket in madVR for Netflix playback issue of a single broken Hardware/driver/Windows system? The issue is reproducable on different playback software, on a supported OS, with supported drivers from just ONE single system, sold and supported by Intel. So I am correct here.

 

Back to the basic: I am not here, because "I am retard and like to display the navigation bar during I watch movies".

I am here, because the system has a serious issue with fullscreen Videoplayback in many Videoplayers (because of some whatever drivertechnology) with the result, that like watching Netflix is not enjoyable when always subtitles will be displayed. Subitltes are very common in movies.

 

I really appreciate you research and to find a way to make videplayback smooth, but please stop focusing on madVR. This was just one more example to demonstrate it in easy way (without needing to wait for subtitles or the 3 second delays of navigation bar of Netflix/Movie & TV App). I already demonstrate in attached videoclips, that the issue is on other playback software. This is no issue just to fix by setting a hook.

 

@powerarmour 

It's already disabled and doesn't make any change...

 

Regards

0 Kudos
Highlighted
Beginner
172 Views

I have installed BIOS 0063 and the issue is the same.

0 Kudos
Highlighted
Moderator
139 Views

Hi MKune1,

I understand your frustration with this situation and also with the support options I gave you before but unfortunately, our resources are limited and we may not be able to fix every single "bug/compatibility" issue reported by customers. I hope that understand that we try to make our platforms very compatible but there could be issues with particular software and also with hardware.

There is one more thing that we can try (please keep in mind that I am not promising any fix) I tried to replicate this issue with Netflix* but I wasn't able to detect any problem. Can you please send me a short video (like you did before) of this very same situation but when running Netflix and please include the instructions for issue replication.

Regards,

Ronny G

 

 

0 Kudos
Highlighted
Beginner
128 Views

Hi Ronny,

I know that you do in first instance sort out User usage errors and what they can do. I do the same job at Dell, asking customer for logfiles, checking driverstates and ways to reproduce the issue.

So if there is an odd behaviour, we reproduce in our lab, all information will go to our L3 REC to find a solution in development department.

So if you say "you don't fix  bug issues reported by customers", you don't have a QL to collaborate the issue? Where do I need to go then to escalate the issue? The system is even sold for business: https://www.intel.com/content/www/us/en/products/boards-kits/nuc/mini-pcs/nuc8i7hnkqc.html

What is the solution for me? I paid exactly 763.87 Euro (+ SSD and Memory), to have a powerful, future prove system to enjoy videocontent, maybe in 4K, maybe it will decode AV1 in 4K pretty sweet, who knows, only to find out, it's failing in GUI transitions, making Netflix (and other players) videocontent not enjoyable and every Android USB Stick will handle Netflix better than this system...

Let's focus on the issue and of course I will answer your question and provide a new video. Because I know customers who don't answer the qestion are annoying

I have uploaded you a new video. You see how my system is connected (but as already said, it is unrelated to HDMI and DP).

  1. I start the PC
  2. I set monitor refresh rate to 23Hz, because my example Breaking Bad is 23.976fps content
  3. I start Netflix (from Microsoft Store), I search for Breaking Bad
  4. I start any episode, I enable subtitles (04:53)
  5. I set to fullscreen (05:18)
  6. I look for a part with subtitles and we need to wait until navigation vanish (always takes about 3 seconds)
  7. After nevaigation bar vanished, the issue starts here (06:18-09:46)
  8. Now I start the Tablet mode trick (10:50) -> it is unrelated to the issue, but shows how the present Windows GUI workaround the issue
  9. Because of the trick, no more frame drops (14:45)
  10. In 15:24 I do show you, why it is no choppy anymore, because of the tablet mode, there is this little bar of the taskbar. This few Windows pixels are enough to bypass the issue

I know, the video is much longer as you wanted, but I want to make sure to understand the issue and how to reproduce.

If you can't see in my video, I extra uploaded a slowmotion moment of the issue. Please notice, that my recordings are 60fps, the content is 23.976fps.

If you still can't notice, you can also download VirtualDub2 , drag and drop my video in and go frame by frame with the arrow keys to the moments where subtitle transitions (without navigation bar) does happen: https://sourceforge.net/projects/vdfiltermod/files/VirtualDub%20pack/version%2020/VirtualDub2_44282....

 

Now since you say, you don't have the issue with Netflix. Please provide me the same information and do a prove video. I want to check it.

I would like to see the system and how you start Netflix and how Netflix is set to fullscreen and subtitles are enabled. Wait for the moment when navigation bar vanish. This is the moment.

If you are right and everything is smooth at your end, please tell me your system configuration and driver state so that I will try to reproduce it.

This evening, I will install the next cumulative update related to patchday. I will notify if it will/will not solve the issue.

I wonder when AMD release the next WHQL driver...

Regards,

Moritz

 

EDIT: I have installed KB4571756 (Build 19041.508) and the issue is the same.

0 Kudos
Highlighted
Moderator
83 Views

Hi MKune1,

I was able to replicate the initial reported issue when using MPC-HC*  + MadVR* but I cant replicate when running Netflix*.

  1. I start the PC
  2. I set the monitor refresh rate to 23Hz but my monitors run better at 60Hz doesn't matter what they are playing, the fps and the refresh rate are two separate things. FPS is how many frames your gaming computer is generating, and the refresh rate is how many times the monitor is refreshing the image on the screen. The refresh rate does not affect the frame rate output generated by the GPU. In other words, if playing anything that is 23.976fps on your system a 60hz monitor will update its screen 60 times. My system does better at 60Hz
  3. I start Netflix* app, I search for Breaking Bad
  4. I tried to look for the same episode in your video, subtitles enabled
  5. I set it to fullscreen 
  6. I played around with the mouse to bring up the navigation bar and going back to full screen.

I do see the specific issue that you are point out in your video, please take a quick look at the video that I am attaching.

Now that this report is with Netflix* I searched the Internet and found several references to this report from customers using very different hardware: Intel, AMD* and NVIDIA* Graphics. Some customers are also reporting the issue may be generated by Windows updates.

See for instance the following URLs:

https://answers.microsoft.com/en-us/windows/forum/all/netflix-stuttering-bug-on-windows-10-1903-full...

https://www.reddit.com/r/netflix/comments/btncfv/subtitles_make_the_video_lag/

https://www.nvidia.com/en-us/geforce/forums/game-ready-drivers/13/301280/netflix-small-stutters-on-f...

I understand your position and would really like to offer a quick fix for this issue but I dont have any at this point. Allow me a few days to run this case again by the product escalation team and I will get back to you.

Regards,

Ronny G

0 Kudos
Highlighted
Beginner
66 Views

Hi Ronny,

thank you for the video. As I can see, you have the exact same issue.

You are a little hasty when try to reproduce the issue, because I didn't say to move the mouse during the time when subtitles are active, because the are no frame drops when navigation bar is active and subtitles change. As long something of the GUI is active, there is no stuttering.

There is only stuttering during the transition between no GUI and 'something' of the GUI (like subtitles and navigation bar or of a program of Windows itself [task-manager...]).

I have explained so many times here and should be finally clear...

But it doesn't matter, because I have found two moments at the beginning and ending of your test where you clearly can see.

You record in 30fps (other then me in 60fps). It makes a ltittle more difficult to see. Since you can't see it, I have extract the moment and slowed down again where you clearly can see the transitions.

Please notice the hand movement of Jesse (right guy with yellow jacket).

The moment when "Krazy-8 está a un nivel superior." subitltes appear, you have the little stuttering as I showed so many multiple times here.

Of course you don't see any stuttering in the rest of the video, because you always keep the GUI active by having subtitltes and when the subtitles change, you have the navigation bar active. So of course there is no stuttering.

There is one more stuttering at the very end of your video, because there is again not naviagation bar active when the subtitle change.

I have attached that moment as well in slowmotion. You clearly can see, the the 'hand up' movement of Walter White is interrupted at the moment when "... guiado por intereses mutuos, no?" appear.

 

Other users are invited to comment if they see the stuttering or not in Ronnys example at the moment I pointed.

 

Now you are doing the same mistake again and pointing to Netflix. Why are you doing that!?!? Did you notice that all the posts are over a year old? Btw. I have mentioned this that there were an issue already on 25th July. This was a Bug in 1903, fixed with an update. But I run Windows 2004 (Build 19041.508). There is no comment at all that the issue is with the current version.

And before you start again with "this must be then a Codec/Windows whatever issue" then, please read my comment again from 05th August where I have tested 12 other system, which are not a NUC8i7HVK and have no issues at all.

 

It's only with the NUC8i7HVK (and maybe also the little sister) and as I can see now, it's not only me.

 

Why it is so difficult for you (or other Intel staff) to admit a system issue? All perfect at Intel?

I am not looking for a quick fix here. I am looking for a concession that we have a hardware/driver bug here and that the issue will be handled from the developer team and bring out a fix at some time of the supported time of system. I am looking for someone to have a deeper look whats going on the system during the issue to develope a fix.

If you refuse, I am looking for another solution for a compensation of a broken system.

Please understand why I get a little upset here, but hope it is clear now.

Regards

0 Kudos
Highlighted
Beginner
64 Views

Okay, since you say this must be a bug in madVR and Netflix then, let's repeat the test with the Windows settings testvideo. I have told so many times, that the bug is there as well.

I have attached again. The way how I set up my system, set to fullscreen, start the video, wait that navigation bar vanish and move mouse again -> stuttering. Hz was set to 59Hz. Video is recorded with 60fps.

Again, I have uploaded a slowmotion version to that specific point.

What will be the advise here? Create a bug ticket now to madVR, Netflix and Microsoft, because they are all buggy, even if the issue is only with the NUC8i7HVK? Really??

Regards

0 Kudos
Highlighted
Moderator
39 Views

Hi MKune1,

I would recommend that you reach out to our Intel Customer Support Service via phone and please provide the Intel Representative with the following case number 04743226. I am placing the necessary internal notes to have this issue escalated once to get in contact with us.

Here is our "contact us" information: https://www.intel.com/content/www/us/en/support/contact-support.html#@8, please make sure that you have selected your region so you will see your pertinent local information.

 

Regards,

Ronny G 

0 Kudos