Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
6,329 Views

NUC8i7HVK - What is the best fan control settings?

Hey guys, just got my Hades Canyon yesterday and I find some werid behaviour about the fan and temperature.

For example, when it's on idle state, the fan is very quiet that I barely can hear. but as soon as I open a software or even open a folder, the fan kicks in and it's very audible.

I open up XTU and find out the CPU temperature would go stright up to 70C - 80C, and drop down to normal temp(40C-50C) rapidly. So the CPU basiclly jump up and down in a large range.

I checked the default cooling options in BIOS, find that minimum temp is about 60 (can't remember exact number), so everytime the cpu goes up above that temp, the fan would kick in with high speed. Is there any time-based options for fan setting? for example if the CPU temp goes above 60C, can I set the fan to speed up only if the CPU temp stays above 60C for 5 seconds or 10 seconds, so the fan won't speed up unnecessarily?

I know for now the best solution may be change the minimum temperature to about 70-80C to avoid some fan kicking in, but a time-based settings would be cool.

anyone can share some good cooling settings for Hades Canyon? thanks

0 Kudos
18 Replies
Highlighted
Community Manager
881 Views

Hello walnuzh,

 

 

I understand that you are currently looking for the best fan control settings.

 

 

In this case, as I can see, the fan for you is pretty loud. Since this is the case, the option I would recommend is to use the "Quite" option. I would like to also mention, that the maximum temperature allowed by the processor is 100C, you can use that as reference in order to set the minimum temperature.

 

 

I was also checking for you and see if there was a way to change the "time" that the fan stays on. However, I was not able to find a way to so, I apologize if this presents any inconvenience. Something else I could recommend is for you to keep checking this thread and see if other community users provide their recommendation for the fan settings.

 

 

I hope this helps.

 

 

 

Regards,

 

David V
0 Kudos
Highlighted
Beginner
881 Views

Thanks David, I will try some settings and see.

0 Kudos
Highlighted
Novice
881 Views

Hello walnuzh,

You could try a custom fan profile:

Minimum Duty Cycle: 30

Lowest CPU Temperature: 78

Duty Cycle increasement: 2

0 Kudos
Highlighted
Community Manager
881 Views

Hello walnuzh,

 

 

I am following up with your case and see that we have not heard back from you.

 

 

Were you able to find the best fan configuration for you?

 

 

If you need more assistance do not hesitate to reply.

 

 

 

Regards,

 

David V
0 Kudos
Highlighted
Community Manager
881 Views

Still working out best setting to stop the strange spin up fans for no real reason. Temp going from 65° to 66° should not kick fans up from 500 rpm to 1,500 and hold at 1,500 for over 60 seconds even when temps are showing 50°, so something hinky is going on in the Bios.

0 Kudos
Highlighted
Beginner
881 Views

thanks David, I tried some settings and now it wokrs well I think. at noraml usage the I can barely hear the fan. I forgot what settings I use. I will check later and share it here.

0 Kudos
Highlighted
Super User Retired Employee
881 Views

Alan,

These are not good settings. I will explain why...

  1. The Minimum Duty Cycle should not be set below the nominal settings for the blowers. This is typically 25% (sorry, I cannot get my unit open far enough to get at the model number and look up the actual settings for these blowers). Setting the Minimum Duty Cycle to any setting below this level can result in erratic fan operation. As the blowers struggle to maintain spin, they can produce all sorts of odd acoustic responses. If they stall completely, they are not going to start spinning again until the duty cycle reaches a level that can maintain it. The problem is that, because the duty cycle is incrementing slowly, it may not spin up at all before the processor overheats.
  2. You have set the Minimum Temperature for the processor to 75, meaning that there is roughly a 25 degree range before the processor starts throttling. The problem is that the Duty Cycle Increment is only set to 2%, which means that the blowers will never achieve more than 60% duty cycle. This is not enough to prevent the processor from heating up to the point of throttling and beyond.
  3. The blower controller may implement a level of protection against temperature overrun. If it does, there will be some specific temperature above which the blowers will be automatically overridden to 100% duty cycle. If the temperature oscillates between this override temperature and lower temperatures, this will result in the blowers making arbitrarily large increases and decreases in speed. Amongst other things, this will be *very* annoying.

Bottom line, your system likely sounds great while it is relatively idle (though you may see some acoustic issues as the blowers struggle to spin). When you make it busy, however - and especially when it remains busy for extended periods of time - it is definitely going to overheat, running at temperatures that are going to cause thermal degradation over time, and processor throttling is going to occur.

...S

Highlighted
Community Manager
881 Views

Ok cool and thanks Scott has been quite a while since I have had a High-end system and at the moment it is in low power usage only will Set to 25% with a 70° Temp and a Increment of 3 so fans should hit at least 90% of max speed. and see how that goes.

So now I have massive fan speed at Boot lasting for 1 to 2 minuets before speed slowly drops down to just under 500 rpm after 4 to 5 minuets it just dose not make a lot of sense for it to do this.

0 Kudos
Highlighted
Community Manager
881 Views

(sorry, I cannot get my unit open far enough to get at the model number and look up the actual settings for these blowers).

Utube can be useful some times remembered the Simply NUC Video so here ya go hope this helps sill looking for info on.

0 Kudos
Highlighted
Super User Retired Employee
881 Views

Not necessarily. That fan is not showing up in Delta's database (but oddly enough is in HP database???). It may be picture of fan used only in pre-production units. I will ask development team what fan is in production units (and regardless, they may have datasheet for the fan used).

...S

0 Kudos
Highlighted
Community Manager
881 Views

Not necessarily. That fan is not showing up in Delta's database (but oddly enough is in HP database???). It may be picture of fan used only in pre-production units. I will ask development team what fan is in production units (and regardless, they may have datasheet for the fan used).

I found the same just some minor data like voltage and Amp and you will like this apparently it runs at 28db so is a very very quiet fan Well it is true when it is running at less than half speed or off

0 Kudos
Highlighted
New Contributor II
881 Views

I've set a min cpu temp of 40c, a min duty cycle of 30% and an increment of 2%/c.

Yet, I also experience my fans jumping from imperceptible to very loud, and then taking over a minute to slowly come back down, despite the cpu temp almost immediately having returned to normal.

I can't tell if my custom fan control settings in the BIOS actually do anything?

I can tell you that having to put up with two minutes of significant fan noise after every 2 second spike in CPU usage is really annoying.

This is further compounded due to the fan /thread/125484 resonating.

0 Kudos
Highlighted
Super User Retired Employee
881 Views

With the settings that you defined above, the duty cycle will reach 100% at 75c and remain there for all temperatures above that. 75c is a little low; I personally think that the point for reaching 100% duty cycle should be at 85c. Adjusting your minimum CPU temperature up to 50c would accomplish this.

I would also note that you are setting a very shallow slope on your control curve. The advantage of this shallow slope is that small changes in temperature do not result in large changes in duty cycle. The disadvantage of this shallow slope is that the duty cycle can be a little unstable, potentially oscillating (albeit slowly) over a larger temperature range. With the resonation issue that has been reported, this could mean that the duty cycle remains in the range causing the resonation for longer periods of time.

I totally agree; the fact that the current generations of processors are more temperature-volatile cannot be ignored. They need to implement a temperature smoothing feature to temper these spikes (pun intended). I will recommend this to the development team...

...S

0 Kudos
Highlighted
Community Manager
881 Views

The spiking is not to bad but the fact that it takes the fans up to 2 minuets to slow back down is Have seen mine spike to 75 or 80 deg and fan ramps up like it should temp drops to 55 deg and fan just keeps on going at 2500rpm for at least 60 to 120 seconds temp can be back down to 40deg by the time the fan stats to slow up At the moment I have it set to Default Balanced setting in the Bios

0 Kudos
Highlighted
New Contributor II
881 Views

Scott, it's broken.

As Alan says, the ramp down doesn't follow the settings.

My CPU temperature quickly returns back to where it was (45c), but my fan does not, and not for minutes after.

If the settings were actually followed, the fan speed should come down precisely with the temperature.

I've dropped my custom settings and returned to "balanced" just to shut it up - but I'd rather have more aggressive cooling, if it actually followed the settings.

0 Kudos
Highlighted
Super User Retired Employee
881 Views

I believe that that is a different issue. I have a (unconfirmed) theory that, even though it is not included in the fan speed control (FSC) configuration parameters, the FSC feature is implementing an all-on setting. This is a feature that was supported in older FSC parts. It ensures that, regardless of the FSC curve configured, the fan/blower is overridden to full speed if the temperature rises above some certain critical threshold. As it was implemented in older FSC parts, this feature has a dwell that would hold the fan/blower on at full speed for some amount of time after the temperature falls below the threshold (and yes, it might be measured in minutes). This dwell was to ensure that, if the processor quickly heated back up again, the fan/blower wouldn't be annoying folks by cycling back and forth from full speed to lower speed. If course, in a solution where higher blower speeds are very noticeable, it is annoying anyway (you can't win for losing).

I will see if I can verify that they are implementing such a feature...

...S

0 Kudos
Highlighted
Valued Contributor I
881 Views

I had this exact same issue from May - June (this year) with the BIOS cooling set to "Balanced."

It was so bad, I was using a secondary cooling fan sitting underneath the NUC and forcing cool air @1200 RPM and the fans would still kick on and not follow any cooling plan I recognized.

I tried 038, 040, and 044 without success, until I tried something that I hadn't done.

About two weeks after updating to BIOS 044, I decided to "load defaults" in BIOS. The problem went away, completely. It was a night-and-day difference.

I don't use any advanced cooling settings as the now "default" Balanced cooling works well, and without any secondary cooling.

Not sure if this will help, but it's my story, and I'm sticking to it.

Highlighted
Community Manager
881 Views

Yep that is what I have done but is annoying as it should be possible to set this your self and not have it go bonkers with fan over ramp Hell some setting are very bad, I tried one and as soon as it booted up fans ramped up to max and stayed there till I signed in to windows and it still took well over a minuet to slow back down.

So Intel really need to look at the Cooling settings in the Bios as setting it manually is not really possible if you want a nice quiet unit. Every Manual setting I have tried has resulted in un wanted Fan noise for no good reason CPU temp is under 50c and fans are going flat out Intel pleas pleas fix this in a Bios update.

0 Kudos