Community
cancel
Showing results for 
Search instead for 
Did you mean: 
EWeig
Beginner
1,109 Views

NUC8i7HVK boot issues

OMG. Got a Hades Canyon last week to use with a Vive, and its all kinds of messed up at the moment.

 

Worked fine a few days ago when I set it up.

I put in (2) x 8 GB RAM modules and 512GB Samsung 970 Pro m.2

 

After first boot and Windows 10 install I added current Intel and Radeon Graphics drivers as well as the LAN and Wifi packages.

 

Had played a few games of Beat Saber and other VR the other day, but when I went to fire it up today all hell broke loose.

 

First I caught a glimpse of some BSOD message and then it went dark. I tried on a couple of different monitors to see if the cabling or the monitor was at issue and I eventually got a picture, kind of. It was all garbled, with a bunch of vertical stripes, like the resolution wasn't right. (This was via an HDMI to DVI adapter.)

 

When I plugged in a small HDMI TV I finally got a picture, but loads of stuff was missing. Steam was mostly gone, no Beat Saber, no Chrome etc. It had apparently reverted Windows back to an earlier point, and before I updated the drivers I'm guessing which explains why only the HDMI TV would work at that point.

 

I reinstalled all the drivers, Steam, etc and a few hours later it was acting up again.

 

I went to do a restart via the shutdown menu and it just didn't. A few presses of the power button on the front of the NUC got it back up. Following an Intel troubleshooting guide I went into BIOS and reset it to defaults. (Maybe something I did with boot order while installing Windows caused a problem?)

 

After it booted that time, I selected restart once more and it just went black again. No signal at the monitor, Skull IS lit up, but no red LED to indicate any drive activity.

 

I've heard of some overheating issues with the storage, but this particular Samsung module seems to be highly rated and popular for this machine.

 

Can someone please help me? This thing was expensive and I'm getting a bit upset.

 

 

 

Update/edit:

 

Got the BSOD again a few times and it kept saying the same thing:

System Service Exception,

What Failed: atikmdag.sys

 

 

 

System says both video drivers are current/best.

 

Intel 25.20.100.6444,

Radeon 24.20.11026.2001

 

BIOS isn't newest though, HNKBLi70.86A.0049.2018.0801.1601

 

I am wondering if the HDMI to DVI adapter I'm using is at fault, and I'm starting to wonder if it matters which video device is plugged into which HDMI port?

 

May be a coincidence, but it seems to be happier if the monitor I'm using is plugged into the front port and the Vive linkbox on the back? (Opposite of the way I want them.)?

 

If the DVI is somehow at fault, it wont matter as much soon when I get a dedicated TV for the setup, but it does feel like I'm grasping at straws here.

 

 

0 Kudos
7 Replies
EWeig
Beginner
251 Views

I let it sit a while and then held down the power button to see if the leds changed color. (To get to a power button menu? Haven't ever seen that come up I think.)

 

This time it just shut off after a couple seconds. When I turned it back on....Blue Screen of Death.

 

BSOD message(s):

 

Stop code: SYSTEM _SERVICE_EXCEPTION

What failed: atikmdag.sys

 

 

I hope this is a clue that can lead to a solution....

LeonWaksman
Super User
251 Views

Hello @EWeig​ ,

  1. In order to get Power Button Menu please do not wait for LED changing color from blue to amber (as described in TPS), because it will not (it is bug). You will not hear three short beeps neither (also bug). After depressing Power Button, count 1001, 1002, 1003, 1004 and release Power Button. Your NUC should boot into Power Button Menu.
  2. In addition to Graphic and Network Drivers you have already installed, I suggest, that you should as a minimum, install the Chipset Driver https://downloadcenter.intel.com/download/28217/Intel-Chipset-Device-Software-for-Windows-10-64-bit-... and Management Engine Driver https://downloadcenter.intel.com/download/28215/Intel-Management-Engine-Consumer-Driver-for-Windows-...
  3. I suggest that updating you computer with all other drivers and the latest bios will have positive result of your NUC performance https://downloadcenter.intel.com/product/126143/Intel-NUC-Kit-NUC8i7HVK

 

Leon

 

 

 

EWeig
Beginner
251 Views

I really appreciate the help, you are my first response across a couple forums besides a suggestion to look into the RAM. (Which has since tested flawlessly.)

 

 

I have more details posted on a thread on Reddit, please read that as well if you would be so kind. Lots of details with steps I took and observations made of changes.

 

(I just signed up for the Intel forums last night and I can not consistently access them or log in.)

 

https://www.reddit.com/r/intelnuc/comments/ap5bft/nuc8i7hvk_boot_issues_and_bsod/

 

The most confusing thing to me is that all my tests so far pretty consistently show that the machine seems to want the display plugged into the front and the Vive into the rear port. I don’t think it should make a difference, but it does to my wire management plans for sure.

 

 

I saw that there is a complete driver package, should I just go ahead and download that and run all of them? 

I think some aren’t relevant to my usage but I’m guessing ones I don’t need won’t hurt anything?

 

And my impression is the best path for the Bios update is to download the recovery version (.bio) and update from WITHIN bios? I’ve read a couple posts about the updater from inside Windows not working or causing more problems.

 

Thanks so much,

 

-Eric

LeonWaksman
Super User
251 Views

  1. To verify that your RAM is O.K. is good advice. However the test performed with MemTest86 not always is good enough. Since you have two memory modules, please try to work with one memory module only at time.
  2. Yes, you can download the all zipped driver package and install all the latest drivers. Please start with the Chipset driver and then Management Engine driver. Reboot the NUC. Next, please install all the other drivers (sequence of installation is not important). You may reboot your NUC only once, after the last driver is installed.
  3. For bios update, please use the .bio file (saved on USB stick fully formatted to FAT32). You may use the F7 key to start bios update https://www.intel.com/content/www/us/en/support/articles/000005850/mini-pcs.html or even better Bios Recovery with F4 from Power button Menu https://www.intel.com/content/www/us/en/support/articles/000005532/mini-pcs.html . Of course, Bios recovery with Yellow Security Jumper removed is working too. I've never tried to update bios from within bios, but seem to me that the other methods, I've mentioned above are preferable.

Hope this will help

Leon

 

 

EWeig
Beginner
251 Views

I've talked to tech support at Intel twice today and did some updates and more troubleshooting.

 

First of all, I worked only with the Vive and a small Samsung TV today. (Taking the variable of DVI monitors out of the picture for now.)

 

I updated from Bios version 49 to 53, one at a time.

 

Also ran the Chipset and Management Engine drivers as requested.

 

 

The boot issues did not change.

 

I have found that if I put the TV's cable on the PC alone, all is well using EITHER HDMI port. If the Vive is also connected, the system behaves properly ONLY if the Vive is on the rear port and TV on the front one.

 

The 2nd Intel tech put me on hold to talk to an engineer, and came back to explain that the HDMI ports actually have a priority order. The problem is that that priority is exactly the way I WANT to use it, but my machine is showing the opposite behavior for some reason.

 

Yup, the Vive should go on the front and display on the rear port. Makes sense doesn't it? (TV connection behind with power cables to hide and the front ports used for accessories that might not be left connected all the time...)

 

Mine will only boot properly if I have them the other way. And I also eventually realized it isn't exactly failing to boot, just not displaying the picture. (Meaning, if I start it with the Vive in front I will not get an image on the monitor. If I pull the Vive plug out and then move the TV cable from the rear to the front the login screen will usually pop right up.)

 

 

Anyone have any ideas how the ports could have got their priorities swapped?

 

Doesn't appear to be any related bios setting, and the ports appear to have hard connections to the motherboard. (No potential cables/plugs that could have been accidentally switched at time of assembly.)

MRoss5200
New Contributor III
251 Views

Are you using drivers only from downloadcenter.intel.com? DO NOT use AMD Radeon drivers from the AMD web site. They are not keyed correctly for the Hades Canyon NUC. The BSoD you are seeing is definitely from the AMD GFx drivers. Uninstall the current AMD drivers and use the Radeon driver installer from downloadcenter.intel.com

 

https://downloadcenter.intel.com/download/28194/Radeon-RX-Vega-M-Graphics-Driver-for-Windows-10-64-b...

 

You might want to download the whole HN/HV driver pack and install each of these to make sure you have the latest official drivers from Intel.

EWeig
Beginner
251 Views

Some of this has been sorted out but not all.

 

The refusal to boot/display with the VIve on the front HDMI appears to be caused by the boot order of the graphics ports. The front HDMI port is scanned before the rear one so the main monitor does need to be on the rear HDMI. I just had to re-arrange my wiring to deal with that.

 

However, I am apparently still having one of the other issues. (Thought they were tied to the same cause, I guess that isn't the case.)

 

When I turned the machine on today after a couple days of not using it I immediately noticed I was missing a lot of files. It had rolled back to a restore point again, so I can only assume the issue with the BSOD is still there even though I didn't see the screen.

 

I did install the newest driver Radeon from the INTEL site. In fact, I"m on a new partition now with a fresh install of Windows 10 home and I am updated to the 53 Bios. I am wondering if there is something wrong with the newest driver and should I try an older revision of it?

 

I have business use planned for this machine (and more of the same later) so I can't afford to have files just vanish occasionally on startups.

 

 

Again, this time I did not SEE a BSOD but for one reason or another the system rolled back to a restore point. There was a description of "Windows Module Installer" right about when I turned it on tonight.

 

 

I think I'm going to run the memtest on the RAM again tonight while I sleep, with more passes and I read that maybe there's an additional test I can enable that wasn't run by default before....

 

[edit - well, I guess 4 passes is the limit on the Freeware version. I'm going to see if I can find anything else to check the RAM with....]

Reply