Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
12544 Discussions

NUC8i7HVK - "A bootable device has not been detected."


Had my hades canyon since relase.. I have 3 ssds, one with macos running at full potential no issues AT ALL, another one running Ubuntu 20.04 no issues AT ALL, BUT, the one with windows 10 will just not boot.. it keeps giving me the A BOOTEABLE DEVICE HAS NOT BEEN DETECTED, despite being shown in the boot menu as windows boot manager.

I have the LATEST bios [HNKBLi70.86A] , the windows install is fresh with no other devices or ssd installed in the system with LATEST windows version and USB stick was created with the WINDOWS MEDIA CREATION TOOL

The tool and the ssd works PERFECTLY FINE in another computer no problems AT ALL installing and running windows from that ssd.

I tried installing olders windows 10 versions and even windows 8.1 and NOTHING, same problems with ALL windows versions.

One thing I have noticed was that IF I boot with an UBUNTU live usb stick and go for the efibootmgr, it will show that the entry Boot0000 is windows boot manager and is set to default BUT heres the thing, the boot order says 0000,0001,0000 the 0001 is of course the usb stick and if I execute sudo efibootmgr -o 0 to set it as the only boot device the boot order will change to 0000 .. that is what was expected..

After that I reboot and IF i enter to the biosboot menu it will show ONLY 1 windows boot manager entry out of the regular 2 it shows.. if I try to boot that way it will boot to windows no problems.. BUT if restart the machine it will give me the A BOOTEABLE DEVICE HAS NOT BEEN DETECTED.. AGAIN.

SO I have to go to UBUTUN AGAIN and when I run the efibootmgr it will show the boot order 0000,0001,0000 the double 0000 entry is the double entry i see in the bios boot meny and I think thats the issue.. there is no infromation on how to fix this and it only happens in windows...




0 Kudos
2 Replies
Super User

Try to clean some old entries (Linux) from the EFI : Method 1   Method 2






remove all usb devices prior to power on device. (i know how it sounds... but i am fighting this issue for month now)
hook them back when system will boot.
there is a bug in 0063 bios, that in rare ocasions (in my case matcatz rat4 mouse is doing that problem)
or downgrade to 0059 using bios recovery method.