Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Employee
203 Views

NUC8i7beh refuses to list 4K refresh rates above 30 Hz to new TV with HDMI2.1 ports, i.e. TV supports 4K@60.

It seems to be a driver issue as when I try to rollback drivers, I get into a loop between the 3 latest drivers: .7584, .7262, .7108

 

Plus, I have a NUC7i5 with 1.5 year old driver that shows 4K@60 Hz on the save TV. Not sure how to solve this except wipe drive and start over.

0 Kudos
9 Replies
Highlighted
Super User
10 Views

  1. Uninstall the currently install the driver and reboot your NUC.
  2. Check that in Device Manager you see Microsoft Basic Graphics Driver. If not, repeat para. 1.
  3. Install the latest driver ver. 26.20.100.7529 https://downloadcenter.intel.com/download/29230/Intel-Graphics-Windows-10-DCH-Drivers-for-Intel-NUC
  4. Your Windows 10 64 bit should be updated to version 1909.

 

Leon

 

0 Kudos
Highlighted
Employee
10 Views

I wiped the drive and installed windows 10 again and updated to 1909. I updated to latest graphics driver that was .7529. I made some progress in that the 4K@60 modes were listed when NUC was connected to 4K monitor. But when I tried to display via HDMI port on LG OLED65C9P TV, I would see the NUC initial booting screen and then things would go blank. Again, a NUC7i5BNH using a 1.5 year old driver (.6025) works great. I saw a similar post where someone had to use the usb-c port to get this to work. I tried to revert back to older driver from 04/19 to see if that helped and that did not.

 

There is some fatal flaw with NUC8i7beh vs NUC7i5BNH when talking to LG OLED65C9P TV from HDMI port. Any ideas??

 

 

 

Highlighted
Super User Retired Employee
10 Views

That is usually an indication that the cables are not of sufficient quality.

 

My first rule for cables: if they came with a monitor/TV, they are crap; throw them in the trash. My second rule for cables: keep them as short as you can. My third rule for cables (and just about everything else): you get what you pay for.

 

The BE and BN NUCs are both capable of supporting 4K@60Hz on the HDMI connector. I am doing so. In fact, I even have a 4K KVM connecting a PC and three (BE, BN and DN) NUCs to a single (Samsung) 4K TV and they all still run at 4K@60Hz.

 

...S

0 Kudos
Highlighted
Employee
10 Views

I tried some "good" cable from our lab and they still didn't work. But, I ordered some 48 GB/s cables from monoprice. So, these appear to be about the best I can buy. They arrive tonight and I'll try.

0 Kudos
Highlighted
Employee
10 Views

Also, as I mentioned earlier, an older NUC with older driver shows fine on the same TV with same cable. I'm sure it's possible the older NUC HDMI I/O buffers were overdesigned and newer NUC is worse (but still in spec) making cable deficiencies apparent.

0 Kudos
Highlighted
New Contributor III
10 Views

"Also, as I mentioned earlier, an older NUC with older driver shows fine on the same TV with same cable. I'm sure it's possible the older NUC HDMI I/O buffers were overdesigned and newer NUC is worse (but still in spec) making cable deficiencies apparent."

 

Well then it's simple. If the OLD NUC works with the same Cable as the new NUC fails with, then the problem is with the new NUC........

Settings, BIOS or Driver Or Hardware? Have you got a third NUC you can plug in on the same cable just to double check?

 

You have already eliminated The TV and The cable(using the OLD NUC)......

The NEW NUC should also fail on another 4K TV using the same cable if you can test that. And if you have the latest drivers, HDMI firmware updated you have a sick NUC.

0 Kudos
Highlighted
Moderator
10 Views

Hello EAspe,

 

Thank you for posting on the Intel® communities.  

 

Do you still need assistance?

 

If you still need assistance, please provide the following information:

 

1. Intel® System Support Utility (Intel® SSU) 

  • Intel® SSU Download link 
  • Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View". 
  • Click on the menu where it says "Summary" to change to "Detailed View". 
  • To save your scan, click on "Next", then "Save". 

 

2. Intel® Graphics Command Center report.

  • Open Intel® Graphics Command Center.
  • Click on support.
  • Click on the tab System Diagnostic.
  • Generate report.
  • Save the file.
  • Upload the file to the thread.

 

3.DXDIAG 

  • Go to Start > Run or Windows Key + R. 
  • On the Run prompt, type "dxdiag" then click OK. 
  • On the DirectX Diagnostic Tool window, click on Save All Information. 
  • Browse to a folder, type in a filename then click Save. 

 

 

Please generate the graphics report with the monitor/TV connected.

 

Questions:

  • Just to make sure, are you trying to set up the resolution to 4096x2160 @60Hz?
  • Were you experiencing this issue before or did it happen after the drivers were updated to the latest versions?

 

Best regards,

 

Adrian M.

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
Highlighted
Employee
10 Views

I not sure of the source of the problem. But it was not cables. When I completely reinstalled windows 10, the problem went away. So, there seems to be some problem with graphic driver installs. But, I no longer have the issue.

0 Kudos
Highlighted
Moderator
10 Views

Hello EAspe,

 

Thank you for your response.

 

I am glad to know you were able to get it working.

 

Best regards,

 

Adrian M.

Intel Customer Support Technician

A Contingent Worker at Intel

 

0 Kudos