Intel® NUCs
Support for Intel® NUC products
11770 Discussions

NUC8iBEK ethernet driver fails

SerComm
Beginner
858 Views

Hi there,

we tried to build a lab-server for internal use. therefore we installed a windows server 2019 datacenter on the nuc (specs see attachments)

when installig the ethernet driver downloades from the intel-sownload center it fails on install.

first we checked if the os is supported, ups, it did not.

is there any solution to get the internal nic running under the server os?

meanwhile we connected an external usb-nic wich works fine.

Attachments: screenshot of system device manager and Log-file from Intel support tool

would be glad for any suggestions. thanks

Labels (1)
0 Kudos
8 Replies
David_G_Intel
Moderator
813 Views

Hello @SerComm 

  

Thank you for posting on the Intel️® communities. 

 

Intel® only provides drivers for the supported operating systems. In this case, Windows Server 2019* is not listed as a supported OS for this NUC. You can find more information in our article: Supported Operating Systems for Intel® NUC Products

You can try the Intel® Network Adapter Driver for Windows Server 2019* as an alternative:

If the driver doesn't resolve the problem, you'll need to use the inbox drivers from Windows.

 

Regards, 

David G 

Intel Customer Support Technician 

 

SerComm
Beginner
788 Views

Thanks for your reply,

we searched the microsoft platform for usable drivers for the Intel-NUC8iBEK but we could not find anything nor the driver which you told us to try alternativ works.

Thanks so far.

n_scott_pearson
Super User Retired Employee
781 Views

Links work for me - and there is a driver download at the other end.

Just saying,

...S

SerComm
Beginner
775 Views

Thanks, but it is not the link which will not work. It is the driver....

Same Message as before like  "No Intel NIC found on the system..." when executing....

 

n_scott_pearson
Super User Retired Employee
766 Views

Hhmmm, have you checked to ensure that the device is not disabled is BIOS Setup?

...S

David_G_Intel
Moderator
752 Views

Hello @SerComm 

  

Were you able to check the previous post? 

Let us know if you still need assistance.

 

Regards, 

David G 

Intel Customer Support Technician


SerComm
Beginner
748 Views

Hi David,

sorry for the missing answer. Yes, we have checked this, but all peripherals were active.

I attached a screenshot from the device-manager. There are several devices which are not recocgnized, the ethernet controller, the wlan and bluetooth device and so on.

We did not need them on that lab system, so our workaround is to use an external USB-Ethernet-Adapter which works fine for us, so we do not need to invest much time in solving the problem. Thanks for your support.

Andy

David_G_Intel
Moderator
731 Views

Hello @SerComm 

  

Thank you for the update, we will close the case now. If you need any additional information, please submit a new question as this thread will no longer be monitored.

 

Regards, 

David G 

Intel Customer Support Technician


Reply