Intel® NUCs
Support for Intel® NUC products

No display/signal

Forkinhades
Beginner
292 Views
Got my new NUC8i7HNK.
Installed the 2x8g ddr4 ram
Installed the 240g HD
Turned on, but no display signals.
Any help please tech people
0 Kudos
5 Replies
LeonWaksman
Super User
288 Views

1. Your NUC should be connected to PC monitor, rather than to TV. Do you see any LED activity?

2. Reset again the two SO DIMM (i.e. remove and reinstall again).

3. If the above not help, try to power ON your NUC in minimum hardware configuration. Remove the SSD and leave only one SO DIMM at time. You should see the Intel NUC logo and when clicking on F2, you should be able to enter BIOS settings.

4. If still you don't see any video output, please give the P/N of the SO DIMM you have.

 

Leon

 

 

 

Forkinhades
Beginner
281 Views
Maria_R_Intel
Moderator
246 Views

Hello Forkinhades,


Thank you for posting on the Intel* Community!


I was checking your thread and I would like to know if the advice from User Leon helped you, please let me know in case you need further help.


Best regards, 

Maria R.  

Intel Customer Support Technician 


Forkinhades
Beginner
245 Views
Tried all suggestions, but to no avail. After a chat with customer services, 'they have taken it back.'
So hopefully will get a working unit back.
Maria_R_Intel
Moderator
221 Views

Hello Forkinhades,


I'm sorry to hear that, I hope you receive your new unit soon!


In this case, the best is to continue the support with customer service. We will proceed to close this thread.


If you need any additional information, please submit a new question as this thread will no longer be monitored.

 

Best regards,

Maria R.

Intel Customer Support Technician


Reply