Intel® NUCs
Support for Intel® NUC products
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11994 Discussions

Not able to enter bios (8i3BEH)

MNord3
Beginner
743 Views

Hi

 

Just bought a Intel NUC 8i3BEH. But I have trouble right away.. :(

I am not able to enter bios. When I press F2 I just get at blank / black screen. All othe menus seems to work except enter bios. I have upgraded bios to lastest (66). I have tried connecting to another tv with other hdmi cable. I have tried removing ssd. I have below memory installed. They are not validated as other bigger Corsair memorys. Could that be the problem?

 

https://www.corsair.com/eu/en/Categories/Products/Memory/Vengeance%C2%AE-Series-8GB-%282x4GB%29-DDR4...

 

http://compatibleproducts.intel.com/ProductDetails?activeModule=Intel%C2%AE%20NUC#

 

\Masonit

0 Kudos
2 Replies
LeonWaksman
Super User
145 Views
  1. Please try to connect to other computer monitor, rather to TV.
  2. You may try to recover your bios (rather than update), using recovery method with the yellow security jumper removed.
  • Prepare USB stick fully formatted to FAT32 with Bios file BE0066.bio https://downloadcenter.intel.com/download/28638/BIOS-Update-BECFL357-86A-?product=126150 . Format your USB with Quick Format option unchecked. Do not format your USB in MAC (OS) or Linux machine. Use Windows.
  • Disconnect the power adapter and remove the bottom panel from your NUC.
  • Remove the Yellow Bios Security Jumper.
  • Insert the USB with the BE0066.bio file.
  • Reconnect the power adapter and power ON the NUC. Wait 30 sec - 2min. The Recovery process will start automatically and will end after 2 -5 minutes.
  • When bios recovery is completed, switch the power OFF, remove the power adapter and replace the Security Jumper (pins 1-2) . Reinstall the bottom panel.
  • Power your NUC ON.
  • Enter Bios setting by pressing F2 during boot process.
  • Press F9(followed by "Y"), to set Bios to default settings. Press F10 (followed by "Y"), to save the settings and exit to O.S. Let the NUC fully reboot.

 

In case that after connecting your NUC to PC monitor and bios recovery, still after entering bios you will see black screen, you should return your NUC to local supplier for replacement.

 

Leon

Edit:

Your memory looks O.K. You may try even to install Windows. The problem is probably only with the bios display. 

n_scott_pearson
Super User Retired Employee
145 Views

For Visual BIOS to appear, the display must support the 1024x768 resolution. Many TVs do not. This is why Leon is suggesting trying an older monitor (they all support 1024x768).

...S

Reply