Intel® NUCs
Assistance in Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12976 Discussions

Nuc 7i5 Temperature problem


Hi all,


I have a 7i5BNK for one or two years (I do not remember precisely). It was always very quiet, mostly fanless, when the BIOS is set to quiet mode. But from 2-3 months, the fan is always running. I looked to the BIOS, and I noticed that the CPU is now always at 55°C, even totally idle (in the BIOS), and the fan is at 3500. I cleaned the fan with some compressed air spray, but nothing changed.


Here are some screenshot of the bios.




Does someone has an Idea ?


Thank you very much,



0 Kudos
8 Replies
Super User Retired Employee

Your fan speed control configuration is terribly, horribly wrong and responsible for what you are seeing. Do the following:


  1. At power-on or reboot, Use F2 key to enter BIOS Setup (Visual BIOS).
  2. Press F9 (followed by Y) to reset the configuration to BIOS Defaults.
  3. Press F10 (followed by Y) to exit Visual BIOS saving the change.
  4. After reboot, again use F2 to enter BIOS Setup.
  5. Navigate to fan speed control settings and change Fan Control Mode to Quiet.
  6. Make any other changes (UEFI, Boot Order, etc.) that your configuration needs.
  7. Press F10 (followed by Y) to exit Visual BIOS saving the changes.
  8. Test - but not in Visual BIOS; it is simply wrong to do so there.


Hope this helps,





hey n.scott.pearson: no need to be that rude, Laurent's configuration clearly is set to Quiet (check his images). Based on his pics, what did you perceive as "horribly wrong"? 'CPU Fan Head configuration' as shown is not the BIOS Default? Setting to Quiet (as it is) is the only one you stately suggest; what are the "other changes your configuration needs"? Useless reply.


Hi Laurent: I'm having the same overworking lately (check the other topic). Use HWINFO (installed or portable) to monitor the processor's temperature and the fan's RPM


But I'm still baffled of what's causing this Overworking, overheating and -- in my case - shutting down.

Super User Retired Employee

There's nothing rude about my response except in your mind. I said it was wrong and detailed how to fix it. The Minimum Temperature is set to 81c, which allows the temperatures to rise considerably before any fan response will occur. This is NOT the default setting for this parameter when in Quiet mode. It has been changed and is, IMHO, horribly wrong; someone's attempt to make the system quieter than it really should be made. The process I described will reset the BIOS configuration so that choosing Quiet mode will set these parameters properly.




Excellent, Scott, that's a proper answer, with specs. Now we figure what was wrong.


Apparently, Laurent knows how to tamper the BIOS; badly, it seems 😀


Thank you,



Hello LLele,


Were you able to review the recommendations provided? 

If you need further assistance, please let us know. We will be glad to assist you.


Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel


Hi all,


Tank you for your answers.

First of all, I never changed the temperature values into the BIOS.

but I did what you said @n.scott.pearson​ . Here is a photo of the configuration after the step 5, so just after setting the fan control mode to Quiet.


As you can see, the values are the same than the ones I gave before. So that confirm I never changed these values.


You said these settings are "terribly, horribly wrong". Can you give me better values please ?

But I feel this is not the problem. On ubuntu, my sensors say the CPU is currently at 40-41°C the NUC is totally cold, the air out of the fan is not hot, but the fan is not off. How is this possible because it's set in the settings that the fan must be off at 45°C ?


Thank you for your answers.



Super User Retired Employee

Yea, this is what I was afraid of - and I was crossing my fingers that it didn't occur. Fact is, I have not been very happy with the poor choices of settings that Intel has been implementing for the Cool/Quiet configurations.


Let's establish a set of values you can specify in a user-defined configuration...


First of all, let me be unequivocal: I do not recommend using the Fan Off capability. The NUCs are simply not designed to have this fan turned off. When there is only one fan (well, one blower) in the system, it is also responsible for keeping air moving over the surfaces of the board in order to cool all of the other components. While the likelihood is certainly lower while the processor is this cool, it is still possible that other components on (or attached to) the board could be at higher (concerning) temperatures as a result of the work that they are being asked to perform. For example, during file copy operations for large files, the processor is mostly I/O bound and thus remains relatively cool. The SSD, on the other hand, is working hard and heating up. Without sufficient airflow, its temperature could reach concerning levels where, if nothing else, performance throttling has to take place. It's just not worth it to avoid the tiny bit of noise generated. Keep the blower spinning.


Ok, what I am most referring to as being horribly wrong is the range of temperatures over which the blower is taken from its minimum speed to its maximum speed. In the absence of other information, the processor cooling device is required to be at its maximum speed before the temperature reaches its maximum tolerable temperature. In the mobile/embedded class processors used in most NUCs, this maximum tolerable temperature is something at or below the processor's Maximum Junction temperature (a.k.a. Tjmax). In desktop processors, an amount of headroom was established using a Control Temperature (a.k.a. Tcontrol) set some distance below Tjmax. This was typically in the vicinity of 85c. Now, we don't need this much headroom in this case, but I believe we should establish some. Since most processors have a Tjmax of 100c, let's say we use 95c, giving us a 5-degree headroom. Restating, we need to ensure that the blower is at full speed (100% Duty Cycle) above this 95c temperature.


Before I go on, let's talk about the blower itself and your concern with seeing it running at 3600 RPM. Blowers have to take in air and make it turn 90 degrees and blow across the heatsink. It thus takes a higher rotational speed to move the same amount of air as a fan. From a technical standpoint, we refer to this as being less efficient. Unfortunately, in the ultra-small form factor (UCFF), we do not have enough space to use a fan; we are stuck with using blowers. Now, the good news is that blowers are specifically designed (within reason) to be quieter at higher speeds. 3600 RPM is thus not an unreasonable minimum speed for the blower provided the blower is working well acoustically - and if it isn't, get Intel to replace the unit.


Next, we need to establish the temperature range over which we want to have the blower go from its minimum speed (minimum duty cycle) to its maximum speed (100% duty cycle). This range will be specified using three parameters, a minimum temperature, a minimum duty cycle and a per-degree duty cycle increment. Now, you complained about the processor always sitting at 55c. This was occurring because you had the minimum temperature set to 81c, resulting in the blower duty cycle remaining at its minimum duty cycle almost all of the time - the temperature would have to go above 81c before the blower sped up at all - and then it would only increment the duty cycle 2 percent per degree, meaning that it would only have incremented 38 percent (to 83%) before the temperature reached Tjmax. Above this point, processor throttling would have occurred as the processor went to extraordinary steps to protect itself. If, even with throttling occurring, the temperature continued to increase, THERMTRIP would likely soon occur (that's an instant power off of the processor).


Ok, so what are a good set of parameters. Well, it depends on a couple of things. First, it depends upon how hot you want the processor to be when the system is relatively idle. [Aside: In my opinion, sitting at 55 degrees all the time is actually not a bad thing.] Second, we need to think about the rate of duty cycle increment that we want. If the rate is too high (and temperature range is short), then changes in blower speed will be more noticeable. The more noticeable changes in blower speed are, the more irritating it can become – especially when the temperature is oscillating around a particular temperature. If, on the other hand, the rate is too low, in addition to needing a very large temperature range, the average temperature in average processor load situations will be higher (I won’t try to explain this; this response is getting to article length already). Finally, as I said earlier, we want the blower duty cycle to reach 100% at or before our headroom temperature setting. This effectively anchors the temperature range to what we are calling our Tcontrol temperature (namely 95c).


Before we delve into the algorithm, let’s first establish a better Minimum Duty Cycle. According to the datasheet for one of these blowers, the minimum stable duty cycle is 25%. Below this level, problems could occur: the blower could struggle to hold its speed, producing noticeable fluctuation, or it could fail completely (stall). In order to avoid these issues, let’s use a minimum of 30%.


Now, let’s talk about the algorithm. Our input variables are Minimum Duty Cycle (Duty-Min), Maximum Duty Cycle (Duty-Max), Minimum Temperature (Temp-Min) and Maximum Temperature (Temp-Max). Together, these variables define our Duty Cycle Increment (Duty-Inc), The algorithm is simple:


Duty-Inc = Duty-Range / Temp-Range




Duty-Inc = (Duty-Max – Duty-Min) / (Temp-Max – Temp-Min)


We know that Duty-Max is 100% and, in our case, we’ve established that Duty-Min should be 30% and Temp-Max should be 95c. Substituting these values in, our algorithm becomes:


Duty-Inc = 70 / (95 – Temp-Min)


Now, let’s look at two possibilities, a better Cool and a better Quiet...


In a Cool response, we’re willing to put up with a higher average noise level in order to ensure that the processor remains as cool as possible. What this means is we want to utilize a larger temperature range that will start the blower response at a lower temperature. A larger temperature range also means a smaller duty cycle increment and this means less noticeable blower speed changes. Suppose we say that we are happy with temperatures being below 60c at idle. Substituting this value into the algorithm, we calculate a Duty Cycle Increment of 2.


In a Quiet response, we’re willing to let the temperature rise to much higher levels before we implement any response above our minimum duty cycle. Once we do reach this higher level, however, we will have to respond more-aggressively in order to ensure that the processor does not overheat (go above our Tcontrol temperature of 95c). Let’s say that we are willing to allow the system to remain at its quietest until the temperature reaches, say, 75c. Substituting this value into the algorithm, we calculate the need for a Duty Cycle Increment of 3.5. Now, the Duty Cycle Increment value must be an integer. In order to ensure that we have the fan at 100% above our Tcontrol temperature, we must round up to the next integer value, namely a Duty Cycle Increment of 4.


So, there’s our two examples. You can pick from these or similarly establish your own.


Finally, let’s talk about the parameters for the second temperature sensor. The method of making the calculations is the same. I typically recommend that you set the Minimum Duty Cycle to the same value as that for the processor temperature, but that’s up to you. What is important to understand is that, when you establish algorithms for blower response based upon two temperatures, whichever temperature currently requires the higher duty cycle will be what is applied. This is called a hottest-of relationship.


Ok, this response is long and has taken a bunch of hours to put together. I will stop here. Fire away with your questions…



Thank you very much for your very well explained response. I changed some values, as you explained before, and it's a lot better now ! I didn't hear my nuc again in "normal" load.


Thank you !