Community
cancel
Showing results for 
Search instead for 
Did you mean: 
BErik1
Beginner
1,299 Views

Nuc stays on when tv is turned off but powers down when tv is restarted

Hello.

I'm a new proud owner of a nuc7i3bnh.

Bios version 86A (49).

Windows 10 home 64bit.

I will be using the nuc as a media device connected to my tv (lg webos 2014).

When I turn on my tv I want the nuc to start (works fine as specified in nuc bios).

When I turn off my tv I want the nuc to shutdown (does not work, see below).

HDMI cec signals are working great using the lg tv remote. I have a pulse eight adapter inside the nuc. Navigating the windows 10 kodi app works as expected.

This is what happens when I turn my tv off:

Everything is running fine, tv on and nuc also.

I press the tv remote red button.

Tv turns off.

Nuc stays on.

I then start tv again to see what happened by pressing tv remote red button.

Tv turns on.

When I see the windows desktop it only takes a few seconds then the computer automatically shuts down.

It's as if the "shutdown" windows signal is not sent the first time due to timing.

The reason I say this is because if i instead set Kodi to sleep instead of shutdown (when tv turns off) it actually does sleep. But funny enough when I turn the tv back on windows still shuts down.

There are hdmi cec settings in the bios (set to turn on nuc when tv starts, other settings are turned off).

There are hdmi cec settings in kodi (what to do when tv is turned off, set to shutdown windows/pc).

And finally my lg tv has hdmi cec settings (SimpLink, auto-sync power is on).

If I disable the auto-sync power feature of SimpLink the nuc stays on, doesn't sleep or power down.

Due to a lot of cec settings involved perhaps there is a conflict. Hope you guys have some ideas.

Thanks for reading.

Best regards,

Eriksson

0 Kudos
6 Replies
idata
Community Manager
171 Views

Eriksson: Thank you very for joining the Intel® NUC communities. We are sorry to hear the NUC is not working as expected.

 

 

You mentioned the BIOS installed on the NUC is version 0049, there is another version in our web site, 0050, please try to do the update to that version using the F7 method:

 

https://www.intel.com/content/www/us/en/support/boards-and-kits/000005850.html

 

https://downloadcenter.intel.com/download/27057/NUCs-BIOS-Update-BNKBL357-86A- https://downloadcenter.intel.com/download/27057/NUCs-BIOS-Update-BNKBL357-86A-

 

 

We can also try to re-install the latest graphics driver 4729:

 

https://downloadcenter.intel.com/download/26947/Intel-HD-Graphics-Driver-for-Windows-10-for-Intel-NU... https://downloadcenter.intel.com/download/26947/Intel-HD-Graphics-Driver-for-Windows-10-for-Intel-NU...

 

 

What is the model of the memory RAM installed on the NUC? (Size, number of sticks)

 

For testing purposes, do you have the option to test the NUC without the pulse eight adapter?

 

 

Any further questions, please let me know.

 

 

Regards,

 

Alberto R

 

BErik1
Beginner
171 Views

Hello again.

Installed bios update 050.

Installed graphic card drivers 4729.

RAM 1 slot used 8GB (CT8G4SFD8213).

Tested again, same result.

I disabled the pulse-eight adapter in KODI and when I now turn my tv off nothing happens. Nuc still running. This is as expected.

Since Kodi/pulse-eight is out of the equation I activated the cec settings in the bios called 'standby by tv' set to 'power button toggle'. Now when I turn the tv off the nuc should also turn off. But instead it's the same story as before:

Turn tv off with tv remote red button

Nuc still running (hdmi off signal does not reach nuc in time?)

Turn tv back on with tv remote red button

Windows powers off the nuc a few seconds after tv image is shown (more time for hdmi power toggle to reach nuc?)

At this point I disabled the power-sync option in the tv menu (hdmi cec settings) to see if the nuc stops shutting down after tv is restarted. Same result.

Perhaps it is a lg tv power toggle issue. Would this help with a new hdmi cable if so what spec. should the cable have? And do you think I should unplug the pulse-eight entirely from the nuc, not just disable software?

If powering off the nuc using the tv remote can not be resolved due to hdmi-cec compatibility issues I suppose I could have windows 10 automatically power off the nuc after x minutes of inactivity. Still, shame this doesn't work because other from this issue the product is fantastic 10 out of 10.

Thanks for the support.

Best regards,

Eriksson

idata
Community Manager
171 Views

Hi Eriksson: Thank you very much for providing those results. Just to let you know in order to provide the most accurate response we will start a research on this matter.

 

 

If you have the option to get an HDMI 2.0 cable that will be a good thing to do since that is the cable we recommend to use.

Also, if the TV has more HDMI ports, could you please test all of them?

 

And yes, if you have the option to unplug the pulse-eight adapter, please try that and let us know if the problem persists after that.

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

idata
Community Manager
171 Views

Eriksson: I just wanted to check if you were able to test the NUC with an HDMI 2.0 cable and the rest of the ports on the TV?

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

BErik1
Beginner
171 Views

Hello again sorry for the delay.

So when I turned the tv off with the tv remote the computer would stay on until i restarted the tv, then the computer would automatically turn off.

I disabled the settings in windows concerning what happens when the power/sleep button(s) are pressed. After that the computer does not automatically shutdown when the tv is restarted.

This was the solution for me. After this change I can shutdown the computer using the tv remote from within Kodi.

Thanks for your assistance.

Best regards,

Eriksson

idata
Community Manager
171 Views

Hi Eriksson: You are welcome. Perfect, it is great to hear that the problem was resolved by disable those settings. Thank you very much for letting us know that information.

 

 

Any other inquiry, do not hesitate in contact us again.

 

 

Regards,

 

Alberto R