Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
840 Views

PCIE issue with Samsung 970 PRO 512 GB on NUC8i7BEH

I did userbenchmark test to find out how is my NUC8i7BEH standing. The results were great apart of ssd performance - I do have Samsung 970 PRO 512 GB connected via M.2 (NVMe) which is supposed to have reading speed around 3500 MB but tops around half of it. After reading through community forum I found one question with exactly same issue. In BIOS there is only PCIe 2 lanes (x2) used instead of x4.

https://forums.intel.com/s/question/0D50P0000490Y2ZSAU/pcie-issue-with-samsung-970-evo-250-g-on-nuc8...

 

I have installed Samsung NVMe controller, Samsung Magician Benchmark as suggested, restarted many times with checked/ unchecked M.2 but nothing gets me to x4 (PCIe 4 lanes) in BIOS, in benchmark still topping at around 1700 MB. I also do have all the latest drivers and latest BIOS update (becfl357.86a.0056.eb.msi) on up to date Windows 10 Pro 64bit. Any help welcome, thank you.

Tags (3)
0 Kudos
5 Replies
Highlighted
New Contributor II
49 Views

I ran into this same issue with a Samsung 970 PRO 512GB NVNe PCIe M.2 SSD installed into a different NUC: NUC7i5DNHE (Dawson Canyon). I used the following procedure to restore the PCIe link to 3.0 x4 for the 970 PRO SSD:

 

  1. Temporarily remove the NVMe SSD from the NUC.
  2. Temporarily remove a jumper from the BIOS Security Header on the motherboard.
  3. Prepare a USB flash drive (formatted to FAT32) and copy the latest BIOS file (BE0056.BIO) into it.
  4. Insert this USB flash drive into a USB slot (front or back) and power up the NUC.
  5. Select BIOS Recovery (F4) from the options screen and go through the recovery procedure to completion.
  6. When prompted, power down the NUC. Restore the jumper onto the BIOS Security Header on motherboard.
  7. Power up NUC, press F2 to enter Visual BIOS and confirm BIOS revision has successfully updated to 0056.
  8. Power down NUC. Re-install NVMe SSD.
  9. Power up NUC, press F2 to enter Visual BIOS. Check to see whether PCIe x4 is now displayed for the NVMe SSD.

 

Please note that if the NUC8i7BEH BIOS revision is already 0056, it may be necessary to go through the BIOS recovery procedure twice, first with an older BIOS revision, e.g. 0051, then repeat the recovery with 0056. I ran into this just the other day with my NUC8i7BEH (checking on a different issue), when a recovery to BIOS 0056 on top of existing 0056 just didn't work (nothing happened and a prompt to restore the jumper appeared immediately), so I did a jumper recovery to 0051, then again to get back to 0056.

 

Caveat: my NUC8i7BEH never had the reduced NVMe SSD throughput issue to begin with, so I cannot vouch for the effectiveness of this procedure, and I used it successfully on my NUC7i5DNHE and NUC6i5SYH only. In other words, YMMV.

 

0 Kudos
Highlighted
Beginner
49 Views

Thank you. I tried to follow the steps but whatever I do, I get stuck with step 5 - F4 to go through recovery. Immediately after I hit the F4, I get a message: "Please turn off power and reinstall the BIOS Security Jumper in Normal (1-2) or Lockdown (2-3) position." If I do that the standard BIOS loads. If I go with F2, I get to BIOS (with jumper off) and under BIOS update I can see my USB flash with BE0056.BIO (same with BE0051.BIO when downgraded). If I run update I get to the screen with F4 and after hitting F4 same message. In other words I am not able to update BIOS with jumper off.

0 Kudos
Highlighted
Beginner
49 Views

I give up for now. I have spent way too much time on something which should work out of the box. I unchecked M.2, checked, flashed BIOS from USB through BIOS update from 56 to 51 and back, all in many combinations, and with no success. Still getting PCIe x2 in BIOS and speed tops up around 1700 compared to around 3500 achieved by other users in tests with the same NVMe SSD. Hopefully Intel will eventually come up with BIOS update which will address this.

0 Kudos
Highlighted
New Contributor III
49 Views

Not sure if this is a PRO issue but I ran CrystalDiskMark on a 960 EVO 250GB NVME on BE:

 

Set to 1GB:

970 EVO 250GB nVME 1GB.png

Set to 4GB:

970 EVO 250GB nVME 4GB.png

Setting in BIOS 0051:

970EVO250GBNVME.png

Seems to be working fine on my BE NUC.

0 Kudos
Highlighted
Beginner
49 Views

Thank you. Yes, your Samsung SSD 960 EVO is listed in compatible (validated) devices for INtel NUC8i7beh (http://compatibleproducts.intel.com/ProductDetails?EPMID=126140). Unfortunately my Samsung 970 PRO is not listed there. I hoped it will work, as I believe it is just a newer bit more polished generation, but obviously there is some issue.

 

In the last few days this Intel forum was playing tricks on me and I was not able to sign in and post my CrystalDiskMark results. Now I am signed in from other computer and do not have screenshot with me but my results were a bit higher in all tests apart of Seq Q32T1 read which instead of being way above 3000 is around 1700 MB/s.

0 Kudos