Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
12540 Discussions

Passthrough freezes my 8i7HVK


I have a few Intel NUC 8i7HVK and had them running with both the iGPU and the Vega M passthrough to qemu/kvm.

They worked fine but I decided to reset them earlier this year.


I still have backups of my VMs.

To get this working I followed this tutorial which worked fine with the scripts attached to the creators website:

But now the website is offline and the only information left is the video on youtube (with missing steps).

I'm trying for quite some time now to get this working again but without success.



The VMs themself run fine, the passthrough also works fine,

but the initialization of the Vega M GPU completely freezes the Host! (Power Cycle is needed, no response at all).


  • When I start the VM without drivers, I can see the GPU in device manager.
  • When I start Win10 without drivers and install them while running, it freezes halfway thorugh the installation of the Adrenalin Drivers.
  • When I start the VM with installed drivers it freezes immediately at boot (spinning circle)


I asked the video creator for his kvm.conf and I got the following response (which is one of the missing parts in the video tutorial):

options kvm_amd avic=1 options kvm ignore_msrs=1 options kvm report_ignored_msrs=0


Same thing happens in Proxmox, Debian and Ubuntu.

I got the GPU passthrough working in ESXI though, but there I can't passthrough USB HID Devices (e.g keyboards, mouse) - which I apparently need in this case :P


I would really love to get this working again, does someone have suggestions?

Even MacOS ran beautiful via qemu and I also have the MacOS VM backed up - but same behaviour.

I also tried to start qemu with the extracted GPU Bios from windows, but still freezes.


THANK YOU for any suggestions, even small hints to how I can see some logs on whats going wrong because the system seems to not log at all at this point.

I'm quite sure I'm not the only one with this problem, am I?


0 Kudos
4 Replies

Hello MGott7


Thank you for posting on the Intel® communities.


It is worth mentioning that for this Intel® NUC Kit NUC8i7HVK at this point only Windows® 10 and Windows® Server 2016 have been validated as supported. Linux Operating systems have not been validated yet. NUCs reported as compatible by Linux users and additional details for Linux support can be found in the below link:

Linux* Support for Intel® NUC


However, we will do our best to check this inquiry. In order to understand better your environment, could you please provide the following information?


1- How many units are affected by this issue?

2- Host Operating system full version:

3- Guests Operating system full version:

4- Is the Linux Kernel up to date?

5- Have you tried reinstalling/updating the graphics drivers? Please provide details and links you tried:


6- Log file /var/log/dmesg


7- Intel® System Support Utility for the Linux* Operating System


Please refer to the Release Notes for details on how to run the tool:


Best regards,


Andrew G.

Intel Customer Support Technician


Hello MGott7


Thank you for your response and all the details provided.

We will review the information regarding this inquiry and as soon as we have more details we will be posting back in this thread.


Best regards,


Andrew G.

Intel Customer Support Technician

Community Manager

Hi MGott7,


I work for Intel Customer Support (Andrew's peer) and we both have been looking into this issue and I believe your request is more of a "how to question" on a particular configuration that goes beyond our scope of support.


If your system is exhibiting any sort of hardware problem or if you have any trouble configuring system devices, for example drivers please point that out but if the issue is with a particular set up, for example: implementation of PCI device passthrough in Linux I would recommend that you reach out to the Linux community.



Ronny G




Thank you Ronny,

yes that seems to be the case, I just thought maybe you have some suggestions on why this issue appears.