Intel® NUCs
Support for Intel® NUC products
11779 Discussions

Possible video card issues on my NUC

Anister
Novice
1,600 Views

Hello everyone. Had to join this community so that I could maybe solve my issues that I am having on my NUC8i7HVB.

I bought my NUC back in December 2019.No issues with it until recently.
I have a Wacom Cintiq that runs in 4k and a month ago I purchased a secondary 4k LG screen. Both are obviously connected to my NUC.
From the first week I started running dual 4k monitors, my NUC began to act out.
First issues were with not being able to run my Wacom in 4k, so randomly when I would turn my PC on, the Wacom would be 1024p instead of 4K. So after some tests, I found out that I can just turn on and off my Wacom for it to go back to 4K.
If this had been the only inconvenience, I wouldn't come here.
But unfortunately, my games (Blizzard OVERWATCH first then my steam games) would have issues finding my graphics card and wouldn't open up. So again, I went searching for solutions and tried to update my drivers, including the updates on the BIOS (Through the Intel updates app). Nothing really worked. So sometimes they would open up after a restart, other times no. 
To make things worst, now even my photoshop doesn't open up, so I have to restart my PC (which reverses my Wacom back to 1024p).
Now I don't have any solutions to these problems. Maybe my NUC cannot handle two 4k screens, which would be a pity as I spent around 1,7k euros on it.

Any idea would be very much welcomed.
Thank you in advance!

 

My specs:

PROCESSOR - 
Intel® Core™ i7-8809G CPU @ 3.10GHz

GRAPHICS

Intel® HD Graphics 630

Radeon RX Vega M GH Graphics


AUDIO

AMD High Definition Audio Device

Intel® Display Audio

USB Audio Device

Realtek High Definition Audio

 
NETWORKING AND I/O

Intel® Ethernet Connection (2) I219-LM

 

Intel® I210 Gigabit Network Connection

 

Intel® Dual Band Wireless-AC 8265

 

Intel® Wireless Bluetooth®

 
MEMORY

32 GB

STORAGE

Samsung SSD 860 EVO M.2 1TB

 

 

0 Kudos
23 Replies
LeonWaksman
Super User
1,477 Views

In order to get better information about your system, please download the Intel System Support Utility (SSU). Run the SSU scan and save the results. The .txt file with the results please attach to your post.

Leon

Anister
Novice
1,472 Views

Hey Leon,

Thank you for getting back to me!
Here attached is the text file you asked. 
Best,
Andrei

LeonWaksman
Super User
1,462 Views

Hi Andrei,

1. I can see that you have BIOS updated to the kast version, however I'm not sure if you have installed the Chipset Device Software. In case that you didn't yet, please download and install. Then reboot your NUC.

2. Next please reinstall the Intel Graphics Driver . The current installation has problem. So first download this driver Version: 27.20.100.8681 to your computer. Next disconnect the internet, open the Device Manager and in Display Adapters right click on Intel HD Graphics 630. Now click on Uninstall device (check "Delete the driver software..." option). Reboot the NUC. Finally install the previously downloaded driver, reconnect the internet and reboot your NUC.

3. Now the most important step. Your AMD Radeon Driver is outdated. Please download and install the last validated Radeon Driver version 20.2.2  Now check how your system works. 

4. FYI, the AMD driver version 20.2.2 is the last driver that can be installed on Hades Canyon. The last driver that is released by AMD is Adrenalin 2020 Edition 21.3.1

However, this driver can be installed only using this "crack procedure".  So, if version 20.2.2 is not working for you, you may use this procedure. More about this subject, please read in this thread.

Leon

 

Anister
Novice
1,447 Views

Hey Leon,
Thank you so much for your reply!
So I went over all the steps and I don't think the problem was solved unfortunately.
I opened the game, and as per usual sometimes the game does open. I played a quick match, then restarted to PC just to check that there is no issue, and the game again did not open. But this time gave me another error:

"Overwatch has crashed in the graphics driver. If your drivers are not up-to-date, please consider updating them. If the problem persists, please contact customer service."

Also, IDK if it's relevant but when I run "dxdiag" it crashes while accessing Direct3D.

Should I try and Install the latest AMD Radeon drive?

EDIT: Now not even the windows settings open up. It crashes.


 

LeonWaksman
Super User
1,439 Views

Hi Andrei,

Please run the SSU again and attach the report to your post.

Leon

 

Anister
Novice
1,436 Views

Here is the report.
I want also to add that after the driver error I restarted the PC and my Wacom screen went to 1024p (instead of 4k) like usual, and the game opened up and runs smoothly. I feel like when I put my both screens to 4k it's where the issues come. 

n_scott_pearson
Super User Retired Employee
1,405 Views

Which ports do you have the monitors plugged into?  Could you please generate a DXDIAG report as well?

...S

Anister
Novice
1,401 Views

Here it is, 

Also I want to mention that the DXDIAG crashes when it goes over Direct3D so I had to override it to have the report. 

Anister
Novice
1,396 Views

Both screens are connected through USB-C. But also I tried in the beginning to use a mini-HDMI instead for my wacom, and it didn't solve the problem.

LeonWaksman
Super User
1,387 Views

Hi Andrei,

From the last SSU report I can see that both Graphics Drivers (Intel and AMD) are correctly installed. From the DxDiag report It looks that the AMD Adrenaline driver is crashing. In my NUC me and some other users have installed the latest Adrenaline Driver 21.3.1 (see para. 4 in my post above). I don't see any problem with this driver, however, I have only one monitor connected with resolution 1920 x 1200 (lower than 4 K). If you want try this driver, use the hack linked in para.4 in my post. To be clear, you should start the installation with installing the latest driver 21.3.1 over currently installed 20.2.2. This installation will stop with an error and then you should continue with manual installation. Better, read the instruction before starting this procedure, to be sure that you understand.  Please read this post also.

Leon

 

Anister
Novice
1,362 Views

Hey Leon, 

So I went and installed the latest version of the AMD driver (21.3.1 WHQL) and It doesn't seem to have solved the problem.
I attached both the SSU and the DxDiag report. 

Do you have any other ideas what it might be?

LeonWaksman
Super User
1,352 Views

Hi Andrei,

Although the Intel Graphics Driver is not connected to video output is responsible to encoding/decoding process. In you last SSU report I can see that something happened with this driver installation, since I can see only one line for this driver:"Intel ® Graphics Driver Version:"27.20.100.8681". You may compare with your previous  SSU report and see that all lines for this driver are missing. So, I suggest to reinstall the Intel graphics Driver. 

In the AMD driver, the installation looks OK, except that you have chosen the  "AMD Radeon RX Vega 64" line of this driver during installation, except "Radeon RX Vega" line as described in the hack instruction para.7 (it is little further on the list). I don't know if this is important, but this is what I have.

I'm attaching the relevant part of SSU report from my NUC for your reference. In my NUC I've installed the latest version of Intel Driver  Version:"27.20.100.9316" (which wasn't validated for NUC yet), instead of the validated version "27.20.100.8681". I don't have any problems with version 9316, but as I've informed you, I'm not working with 4K monitor.

Under letter "A", in the start menu you will find "AMD Radeon Software" Click on it and AMD panel will open, giving you possibility to set Graphics mode (game, video,...) and different display settings. 

Leon

 

Anister
Novice
1,349 Views

Hey Leon, 

Thank you for answering and trying to help.
Here are the reports again. I tried to update the drivers like you suggested.
Unfortunately nothing seems to change my issue and that is most disheartening. 

Andrei

EDIT:
So the game wouldn't open up giving me a general error, so I jsut tried to turn off my Wacom screen without restarting my PC and the issue went away. So I suspect my double 4k screens are indeed the problem and not the drivers. I will test again maybe if I try other inputs, maybe it will work!

Anister
Novice
1,341 Views

So just tested with other cables and inputs.
The problem might be even more specific. Having two 4k screens both connected through USB-C.
I tried changing my Wacom to a Mini-HDMI and it worked (I restarted 3 times and the resolution stayed and the games opened no problem).

And then I changed my Wacom back to USB-C and my LG to a HDMI cable. And again it worked.
I will wait a while for a definitive verdict but it feels like the problem is solved.

Thank you Leon for assisting me!

And Scott, you did actually identify the problem in the beginning! 

LeonWaksman
Super User
1,333 Views

I'm glad that it is working for you. However, doesn't it not contradict the  Multiple Display Configuration Options for Intel® NUC Kits NUC8i7HNK and NUC8i7HVK document?

Leon

 

Anister
Novice
1,332 Views

In what sens does it contradict this document?
Because normally it should support two USB-C displays?
Well, maybe there are some underlying issues with my PC. Who knows. For now I will see if the problem comes back or not. Hopefully not. But who knows

Anister
Novice
1,324 Views

Spoke too soon.

The same issues came back. 
Yeah, I don't have any more ideas. I give up haha.

 

The funny thing is that my PC works properly whenever I :

1. Change the refresh rate (no system restart needed)

2. Turn off one screen (no system restart needed)

3. Restart one of the screens (Usually I restart the wacom).

4. When I change the cables, it works in the beginning.

5. Restarting the PC usually helps, but not all the time.


 

DeividA_Intel
Moderator
1,283 Views

Hello Anister,  

  


Thank you for posting on the Intel® communities.   

  


In order to better assist you, please try and provide the following:  


  

1. Have you updated Wacom drivers?

- https://www.wacom.com/en-us/support/product-support/drivers


2. Have deleted any other tablet software/driver? Ex: Huion


3. If possible, try to test the same setup, but replace the NUC for another computer (NUC, laptop, PC) and provide specifications of the device used (CPU, graphics, motherboard, laptop model, etc).


4. Have disabled the antivirus while you use the Wacom device?


5. If possible, try with a different resolution (you mentioned that you tried with a different refresh rate) for example 1920x1080 on each monitor.


6. Have you run all the Windows updates, including the optional?


7. Have you updated the firmware of your LG monitor?


8. Have you checked the resolution setting on your Wacom device? And if possible, disable the HDR options on the monitor and Windows.


9. Have you contacted Wacom support just to check that the device is working properly?



 


Regards,  


Deivid A. 

Intel Customer Support Technician 


Anister
Novice
1,201 Views

Hello!
Thank you for taking the time to reply on my post.
Here are my answers:

1. Yes

2. I didn't have any other prior tablets.

3. I don't have such possibility.

4. Don't use one (except the default windows firewall)

5. Using two USB-C cables often reverted my Wacom to 1024p instead of 4k. Since changing my LG to a HDMI and having my Wacom on a USB-C I didn't encounter a resolution change. I keep having the graphics card error when I turn on my computer but now I need just to change the refresh rate of one of my screens and the problem goes away. (I don't even have to keep the refresh rate changes, I directly revert them)

6. Yes!

7. No, but I will now.
8. Both screens have the HDR disabled. Why should I check the resolution settings on my wacom though?
9. My wacom is working properly, as I have been using it hooked up to my NUC since the beginning.
It's since I bought my 4k LG screen that I encountered the issues.

DeividA_Intel
Moderator
1,103 Views

Hello Anister, 


  


Thank you for the information provided 


  


I will proceed to check the issue internally and post back soon with more details. 


  

  

Best regards, 

 


Deivid A.  

Intel Customer Support Technician 


Reply