Intel® NUCs
Support for Intel® NUC products
12504 Discussions

Power down USB ports in sleep mode?

KEric
Beginner
18,778 Views

NUC6i3SYH and Win10

I am using my NUC as an HTPC and it is desirable that the outboard DAC, which is connected through and powered by a USB port power down when the computer goes into sleep mode. It appears that all the USB ports still provide power when the computer is powered down. Is that true, and if so, is there a way to power them down when in sleep mode.

0 Kudos
20 Replies
PPAVE7
New Contributor I
14,516 Views

As far as I remember, you can switch this feature off for any USB port via BIOS settings

n_scott_pearson
Super User Retired Employee
14,516 Views

Actually, that's not quite correct. In BIOS, you have the ability to configure whether or not the USB ports are powered while in S4 (Hibernate) and S5 (Powered Off). You do not have this ability for S3 (Sleep); the USB ports are always powered in S3 (Sleep).

...S

idata
Employee
14,516 Views

Hello KME,

Scott, is right. You can only configure these two options within the BIOS.

If you disable "Allow the computer to turn off this device to save power" from Device Manager should help, this will keep the USB ports inactive during sleep mode.

Regards,

Amy.

idata
Employee
14,516 Views

/thread/111539 KME if you still need assistance on this matter, please let me know.

Regards,

Amy.

KEric
Beginner
14,516 Views

I disabled the USB ports as suggested but it didn't seem to make any difference. Outboard device is still powered up when in sleep mode. Please advise

idata
Employee
14,517 Views

The yellow ports will always powered up when in sleep mode, the blue ones should be turned off.

I followed the instructions posted before, and it disabled the USB power when the unit was in sleep mode.

Regards,

Amy.

KEric
Beginner
14,516 Views

Amy, thanks but it's still not working

- Device was plugged in to the blue ports.

- Just to make sure that I am following the instructions:

Device Manager

Universal Serial Bus Controllers

Intel USB3.0 extensible Host Controller - 1.0 (Microsoft)

Properties

Power Management Tab

uncheck "Allow computer to turn off this device to save power"

OK

Are my actions correct?

Thanks again,

Kent

idata
Employee
14,516 Views

That is correct Kent, those were my specific steps.

Please, let me set my Intel® NUC Kit NUC6i3SYH one more time and check if I am able to get the same results. I will share them here.

Regards,

Amy.

idata
Employee
14,516 Views

Hi Kent,

I tried changing something else in the power Options, and I have some interesting results. These are my new steps;

  1. Go to Power Options.
  2. Click on change Advanced settings.
  3. Change plan settings for Balanced.
  4. Click on Change advanced power setting.
  5. Find USB settings, and click on USB selective suspend setting.
  6. Disable it.

Once I followed these steps each time I plugged a couple of USB devices to charge they did not get any power; however, this only happened with some devices. For example, I plugged an iPhone and a Sony device and these did not charge, but I tried with some Samsung phones and they were powered.

Regards,

Amy.

KEric
Beginner
14,516 Views

Amy, tried the above steps but the device is still powered up. Any further suggestions?

Thanks again

idata
Employee
14,516 Views

/thread/111539 KME, thank you for trying my suggestion.

Please let me review your thread one more time, I will update the thread as soon as I have more results.

May I know what is the device you are plugging into the USB?

Regards,

Amy.

KEric
Beginner
14,516 Views

Yes, it is a Meridian Explorer 2 DAC.

Thanks again

Ronny_G_Intel
Community Manager
14,516 Views

Hello /thread/111539 KME

In states (S1-S3), volatile memory is kept refreshed to maintain the system state. Some components also remain powered so the computer can wake from input from the keyboard, LAN, or a USB device, and here are my results from testing with "Portable Device Charging Mode" set to "OFF" under the USB Configuration in BIOS:

- Clicking "Sleep" on the Power Menu still provides power to the USB blue connectors

- Either selecting "Hibernate" on the Power Menu if available or pushing the power button on the unit to "Hibernate" the system doesn't provide power to the USB blue connector.

This is the expected behavior.

Thanks,

Ronny G

KEric
Beginner
14,516 Views

That seems to do the trick. I didn't change anything in the bios but when I add hibernate to the power options menu and select hibernate it seems to power down the USB ports and the device that is attached. It does create a minor inconvenience in that the computer can no longer be awakened using the keyboard because the keyboard dongle is plugged into one of the front (yellow) USB ports and they appear to be unpowered. So I will need to wake the computer with the power button but that is OK in my configuration and it is good to not have my DAC powered all the time.

Thanks

idata
Employee
14,515 Views

Kent, hope this solves your USB power issue.

If there is something else, we can help you with please let us know.

Regards,

Amy.

TStew1
Novice
7,174 Views

I found that disabling Hibernation which saves a file the size of your RAM on the HD also disables the USB power for waking up from sleep mode, but that works in hibernation mode. 

 Does disabling Hibernation disable USB power in sleep mode?  It certainly disables selective wakeup.

 

- check

  - Control Panel > USB HUBs> Power settings > choice, also HID devices> power>

  - Control Panel > Power > settings for Selective power shutdown

  -

n_scott_pearson
Super User Retired Employee
7,142 Views

There are BIOS parameters related to USB Power in S4 (hibernate) and S5 (shutdown) states.

...S

TStew1
Novice
7,117 Views

It worked ! kudos

 

 

I made other changes too in ASUS Haswell i7 tower bios;

CPU C states [Auto]> Enabled

C7 Latency [Long]>[Short]

Legacy USB Support [Enabled]>Auto]

Intel xHCI Mode [Auto]->[Smart Auto]

EHCI Hand-off [Enabled]->[Disabled]

Generuc-Multiple Reader [Auto]->[Hard Disk]

USB Support [Partial]->[Full Initialization] 

 

It seemed slower than it was in going to sleep and waking up, but this is a different installation of Win7 x64.  It sure works better than Win10, Win11 after a lot of tweaking and disabling stuff.

TStew1
Novice
7,114 Views

hmm.  I tried a reboot then sleep. and not working

Jaap7
New Contributor I
6,955 Views

I have a similar issue on my NUC 11 PAHi7. I have an external HDD in a hdd case attached to the USB connection at the back of the NUC.

Whenever I shutdown my NUC, the HDD stays on (I can feel the drive is still spinning). I tried several BIOS settings (like no power to USB while powered off) and a bunch of settings in Windows. None of it mattered.

 

I hope a BIOS update can fix this - i.e. when we select the option to not supply power to USB when it's powered off, really do that - i.e. not supply power.

Reply