Showing results for 
Search instead for 
Did you mean: 

Problem with centos 7 on NUC (NUC7i5bnh) - fixed

This forum really helped me out, so wanted to share my experience with CentOS7 install on a NUC7i5BNH using a USB Fob/key in case someone else can use it:

TL;DR: Switched from a junky USB 1.0 8GB fob to 'brand name' USB 3.0 32GB fob using same ISO CentOS7 image (installed with RUFUS), and it fixed my install problems and I was able to successfully run CentOS7 install from USB to my NUC (NUC7i5BNH).

Couple Key Points that really helped me:

1) I followed Intel instructions for updating my NUC BIOS using a USB fob. Pretty easy and the tool def works letting you download the BIOS file locally, then using F7 at boot on the NUC, starting the BIOS update, and having it look for the BIOS update file you downloaded to the USB.

2) If you are creating your USB CentOS installer on a Windows machine, use RUFUS to make it.

2) This was my biggest hurdle....some people may swear this isn't possible...but this made mine work: I tried repeatedly installing CentOS7 "minimum install" from a junky USB 1.0 stick I had made a month ago, and had SUCCESSFULLY used on a separate laptop CentOS7 install. I had used this CentOS7 minimum install USB probably 6-7 times in the past month with no problems. So...I used the same 8GB USB with the CentOS7 image already on there on my NUC. Installing on the NUC it would run the installer, but when it got to the GUI page of install where you choose your language, I would get random errors which would never let me continue the install. Running a media check would result in "failed" but I was still able to use the USB to install on a test laptop, no problem.

So...for a more thorough test, I used RUFUS and overwrote the old beater 8GB USB with an UBUNTU install image I'd also used recently. Using the same 8GB USB stick now imaged with an UBUNTU image using RUFUS I also get an error part way through the install (but it would start the install, just never would finish).

So...ultimately, for fun, I got a clean USB 3.0 32GB Fob, and installed the original CentOS7 ISO I already had, and after I did that, the install was flawless.

You can do checksum/tests to make sure your packages you downloaded are fine, and I did those sorts of I'm pretty sure my old junky USB1.0 was somehow the problem on the NUC (again, I used that USB on a crappy test laptop a lot recently and it worked fine instaalling CentOS7 minimum). ...and moving to a decent USB that was USB3.0 seemed to fix everything. Also (not that it matters) I tried this in front and rear ports of the NUC...and that had no effect (not that it would).

Happily humming along with CentOS7 on a NUC7i5BNH now.

Hope this helps someone avoid some wasted time.

Tags (1)
0 Kudos
1 Reply
Community Manager

Hello Customer,



Thank you for contacting Intel® Communities Support.



We appreciate the time you took to explain your experience.


I am pretty sure this will be useful to help other customers with the same issue.



Do not hesitate and contact us back if you need assistance.





Stephen C.