Showing results for 
Search instead for 
Did you mean: 

Problems with I219-V (on NUC6i3SYK) at 1 Gbps


I have a NUC6i3SYK which has I219-V NIC on board.

First of all, there are no problems with network connection when the card is connected to 100Mbps capable switch/router.

But there are problems when it is connected to 1 Gbps capable router. After switching NUC on, and booting into Windows, after some time (1-10 minutes) the connection quality decreases really bad, ping to the router raises to 500-1000 ms and some packets get lost.

Disabling/enabling the card fixes it for another 1-10 minutes.

Setting Link Speed to 100Mbps also fixes the problem.

I ruled out the router as the cause, because another PC connected to the same router works flawlessly on 1 Gbps - it also has I219-V but on another motherboard (ASUS Z270G).

Of course I tried switching router ports and cables between the two PCs but it didn't help.

Driver version: (Intel PROSet version:

0 Kudos
4 Replies
Community Manager

Hi KimC,



Thank you for posting in Wired Communities. Just to double check if the link speed of I219 and the switch are configured to the same setting, please ensure both are set to Gigabit speed or both at auto-negotiation mode.



You may also refer to this link to adjust the advance setting



Have you tried connecting the I219-V to another router to isolate the issue?





Sharon T



Hello Sharon,

Thank you for reply.

The setting is Auto-Negotiation on both sides. According to ProSet and to Status screen on router web page, the connection is 1000Mbps/Full Duplex.

I tried modifying some settings in ProSet. It seems that increasing Receive Buffers and Transmit Buffers helped a little (it takes longer for the connection to break).

After that I also realised that while downloading a lot of data at high speed everything seems OK and PING to gateway (router) is under 1ms all the time. But when I first try to upload a lot of data, the PING rises to 20-30ms during upload and after the upload finishes it starts jumping between 100 and 2000 ms and connection is unusable until I disable/enable the network card in Windows.

Unfortunately I don't have any other 1Gbps router to check.

With 100Mbps connection it works properly.

Community Manager

Hi Kmic,



Thank you for the update. I will transfer your post to our NUC support since this is onboard NIC on the system, they can better assist you to provide further suggestions.





Sharon T


An update: I just had a chance to try USB 3.0 to GIgabit Etherner Adapter with my NUC and it is working flawlessly - speeds around 800-900 MBit/s are achievable and the problems that I had with I219-V do not occur.

Therefore, it seems like it's not an OS issue. It looks like something's wrong with the I219-V driver or the hardware itself. I tried reinstalling the driver but it didn't help.

I would appreciate any help/directions on resolving the issue. I would really prefer to use integrated Ethernet interface to an adapter that occupies one of USB ports.