Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Semag
Beginner
188 Views

RTX 3060Ti not working with NUC and eGPU Razer Core X Chroma

Jump to solution

Hi 

I have a NUC10i7fnk2 and I'm trying to make it work with a eGPU Razer Core X Chroma and a RTX 3060 Ti inside connected through the Thunderbolt port in a Windows 10 64b. 

I've spent hours trying to make it work.. without success. 

The issue is the following: The NUC is able to recognize the eGPU through thunderbolt, and the display monitor is connected through HDMI only to the eGPU. NUC starts, and then windows starts and I can see it well for some seconds. But after some seconds in the login screen of windows, then suddently the screen goes black and the NUC restarts.

I've installed the latest driver of all components as you suggested in other posts, and BIOS is setup as default (I tried makeing some changes but now its as default) but I'm still having the issue. 

Could you please help me identify what could be wrong? Is there any BIOS setup to make or any Windows setup to fix the issue? 

Find attached the detailes summary of the System Support Utility so that you can see the details of the system I have. 

 

Thanks a lot for your help,

0 Kudos

Accepted Solutions
Semag
Beginner
141 Views

Hi

Thanks for your guidance. 

What you recommend did not solve the issue, some of the options you mention are not available in Windows 10 Pro 20H2 version I have (the PCI Extress settings are not available). But one of your colleagues from Support at Intel (I called Support directly) suggested something that worked. 

After some changes at the BIOS the solution was to enable a "High Performance" settings in the Power Plans. The High Performance Plan in Win 10 20H2 is not enabled. To enable it you have to open a PowerShell (Admin) and type:

powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c
powercfg -setactive 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c

Now, if you do a powercfg -list you will see the list of Power Plans enabled and the High Performance as selected (important to do the setactive first). You will also see the same in the Power Options (in Control Panel). 

With this I could turn off the NUC and then restart it with the Thunderbolt of the eGPU plugged to the NUC and the HDMI of the Display to the RTX 3060Ti in the eGPU. And it worked well!!

Thanks a lot Intel for your Support team! (and thanks Carlos from the Support team for your patience.. it was a long call to fix it!) 

 

Regards,

David

View solution in original post

0 Kudos
3 Replies
David_G_Intel
Moderator
151 Views

Hello Semag

  

Thank you for posting on the Intel communities. 

 

After taking a look at the information provided, please test the following:


  • Update the Thunderbolt™ 3 DCH Driver  to the latest version.
  • Uninstall the current GPU drivers in your system, and then perform a clean fresh driver install. Installing the latest driver for the NVIDIA GPU card.
  • On Windows:
    • In Windows Power & Sleep Settings, turn off PCI Link Power Management:
    • Go to Control Panel > Hardware and Sound > Power Options.
    • Select Change Plan Settings.
    • Select Change Advanced Power Settings.
    • Go to PCI Express > Link State Power Management.
    • Set On Battery and Plugged In to Off.
    • Click OK.
  • Did you already test the NUC without the enclosure? Does it work fine?
  • Does the eGPU work fine with other systems?


I will send you an e-mail to the e-mail address associated with your community profile requesting some reports that may contain sensitive information.

 

Regards, 

David G 

Intel Customer Support Technician 


0 Kudos
Semag
Beginner
142 Views

Hi

Thanks for your guidance. 

What you recommend did not solve the issue, some of the options you mention are not available in Windows 10 Pro 20H2 version I have (the PCI Extress settings are not available). But one of your colleagues from Support at Intel (I called Support directly) suggested something that worked. 

After some changes at the BIOS the solution was to enable a "High Performance" settings in the Power Plans. The High Performance Plan in Win 10 20H2 is not enabled. To enable it you have to open a PowerShell (Admin) and type:

powercfg -duplicatescheme 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c
powercfg -setactive 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c

Now, if you do a powercfg -list you will see the list of Power Plans enabled and the High Performance as selected (important to do the setactive first). You will also see the same in the Power Options (in Control Panel). 

With this I could turn off the NUC and then restart it with the Thunderbolt of the eGPU plugged to the NUC and the HDMI of the Display to the RTX 3060Ti in the eGPU. And it worked well!!

Thanks a lot Intel for your Support team! (and thanks Carlos from the Support team for your patience.. it was a long call to fix it!) 

 

Regards,

David

View solution in original post

0 Kudos
David_G_Intel
Moderator
118 Views

Hello Semag

  

Thank you for sharing with us. 

 

We are glad to hear that your products are working properly now. If you need any additional information, please submit a new question as this thread will no longer be monitored.

 

Regards, 

David G 

Intel Customer Support Technician 

 

0 Kudos