Community
cancel
Showing results for 
Search instead for 
Did you mean: 
RGunt
Beginner
1,270 Views

Remote desktop connects & instantly disconnects

I have an Intel NUC, which has Intel vPro (in fact I have several of these same machines).

One of them is acting up.

I can connect with Intel Manageability Commander (both v1 and v2 work).

I can view system status, hardware, event logs etc.

However, when I try Remote Desktop it will say:

Connecting...

Setup...

Disconnected

This specific machine has been working for 1+ year. It is at a remote site, so I don't have local access.

The audit log will log the following when I attempt to use the Remote Desktop option.

Redirection Manager, KVM Session Started

Redirection Manager, KVM Session Ended

There is only 1 second between the audit log entries.

Sometimes when I have issues with Remote Desktop, I would use the power actions and either reset to BIOS or power up to BIOS and that gets me back into the machine if the screen resolution was not compatible or something.

This time I'm stuck. I have tried everything I can think of but can't get Remote Desktop to maintain a connection.

How can I debug this thing as there seems to be no error occurring.

0 Kudos
8 Replies
idata
Community Manager
229 Views

Hello ik2,

Thank you for posting.

Please, let us know more information about your system.

  • Provide the Intel® NUC model.

I understand that you do not have local access, but we need to confirm more information about the Intel® NUC. Can you get this report https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows- Download Intel® System Support Utility for Windows* ?

Amy C

Intel Customer Support Technician

Under Contract to Intel Corporation

RGunt
Beginner
229 Views

I can't access the machine as something is wrong with it, thus the reason I am trying to access it remotely via remote desktop.

I can provide some details about the machine.

It is an Intel NUC5i5MYBE.

BIOS: MYBDWi5v.86A.0038.2017.0726.1622 (Release date: 7/26/2017)

Intel ME: v10.0.55 activated in Admin Control Mode (ACM)

idata
Community Manager
229 Views

Thank you for the information /thread/130342 ik2.

Do you know if anything changed? Is the system able to run updates(Windows updates)?

You might have to go onsite to restart/check the unit. If you do, so you might consider to update the BIOS since the latest version is 0048: https://downloadcenter.intel.com/download/28156/BIOS-Update-MYBDWi5v-86A-?product=84862 Download BIOS Update [MYBDWi5v.86A] .

I found this link: https://support.microsoft.com/en-us/help/2477176/troubleshoot-remote-desktop-disconnected-errors-in-... https://support.microsoft.com/en-us/help/2477176/troubleshoot-remote-desktop-disconnected-errors-in-..., there might be helpful information. In case you are using this.

Amy C

Intel Customer Support Technician

Under Contract to Intel Corporation

RGunt
Beginner
229 Views

I should also clarify that when I say 'Remove Desktop' I am talking about a connection through the Intel Manageability Command - not to be confused with Remote Desktop of Windows.

The machine was running Linux, not Windows. I don't know of any setting changes.

I was actually connected to the machine, using Remote Desktop (through Intel Manageability Commander). I used the power command to reset it and that was it.... I can't access it after that.

I have had the data center physically unplug the power from the unit twice but it does not result in any change.

Another thing I tried was to enable the 'Legacy KVM viewer' on port 5900 as it is disabled on that machine. I was hoping that would be another way to access it. However, when prompted to enable that option it asks for a password. Every password I try to enter will result in the following error 'Error 400, unable to set values'. So I have been unable to attempt access via port 5900 as well :-(

RGunt
Beginner
229 Views

So basically at this point, I would be happy if I could just access the BIOS again - regardless of the OS, but I can't even manage that.

idata
Community Manager
229 Views

Let me check this.

 

 

 

Amy C

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
idata
Community Manager
229 Views

Thank you for your patience.

When you enabled the port 5900, did you set the password?

Setup and Configuration of Intel AMT > Configuration Settings > KVM Configuration > Use Cases > Change the Default Port Setting

To enable: set IPS_KVMRedirectionSettingData.Is5900PortEnabled to true, and provide an IPS_KVMRedirectionSettingData.RFBPassword if there is no previous value.

*You enter the desired password where it shows the RFBPassword value, using the guide below.

Intel® AMT Implementation and Reference Guide

https://software.intel.com/sites/manageability/AMT_Implementation_and_Reference_Guide/default.htm?tu...

If this does work, please let me know so we can investigate this further.

Amy C

Intel Customer Support Technician

Under Contract to Intel Corporation

idata
Community Manager
229 Views

If you need further assistance let us know.

 

 

Amy C

 

 

Intel Customer Support Technician

 

Under Contract to Intel Corporation
Reply