Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Salil
Beginner
265 Views

Repeated problem - NUC8i7BEH does not wake up once the screen turns off / sleep

My Setup

I have an NUC8i7BEH with 32GB RAM, 1TB SSD. I have all the latest updates [via Intel® Driver & Support Assistant] of Graphics (26.20.100.8141) and BIOS ( BECFL357.86A.0083.2020.0730.1436). I have the latest HDMI Firmware too via Intel Support article 33202. I am running all the latest updates on Windows 10 Pro 2004. I re-installed Windows 10 Pro 2004 just to make sure it's not a windows issue.

My NUC is connected to my monitor [LG 32UD59-B 32" 4K] via an HDMI cable.

I have my Windows setup to put the screen to turn-off after 15 mins and I have disabled sleep (sleep set to NEVER).

Net-net - I have ALL the latest drivers and software updates as needed.

My Problem - repeated problem

Once the screen turns off after 15 mins (as per setting), my NUC does not wake up and stops responding. I have to unplug-re-plug the power for the NUC to start working.

This has been going on for a few months and I presumed a fresh Windows install will fix it - I did a fresh windows install and it did not work.

How do I fix this?

PowerSettings.png

DriverUpdateDetails.png

0 Kudos
6 Replies
n_scott_pearson
Super User Retired Employee
258 Views

This is a longstanding issue with the Intel graphics drivers. I saw it first way back on the 4th Gen NUCs (though it's not a NUC problem per se). It gets fixed, then comes back, gets fixed, then... Now, the system is actually still responding, but is essentially running headless at this point. Updating the graphics driver to a newer release will sometimes fix this issue, but it may come back with the next driver update they release. The simplest thing to do is to also set the Screen Timeout to Never. This is what I do.

Hope this helps,

...S

Salil
Beginner
243 Views

Thanks @n_scott_pearson for your quick response. I think this was working for me for a bit and it seems to be back for the last 4 months (which finally got me re-install windows).

The downside of setting the screen timeout to NEVER is that my screen never goes to sleep (duh :)).

Is there any hack or known workaround around this issue?

n_scott_pearson
Super User Retired Employee
229 Views

Sorry, none that I know of. It sucks and the Intel graphics team should be incredibly embarrassed about it.

...S

DHoga2
Valued Contributor II
218 Views

I agree.  However, I'm curious if you or the OP have tried something which has been mentioned by others - going into the "BIOS" Advanced > Devices > Video and change IGD Primary Video Port from Auto to a specific setting such as HDMI?

n_scott_pearson
Super User Retired Employee
215 Views

I don't know about the OP, but I certainly haven't tried this. As far as I know, these BIOS settings have nothing to do with this processor state or with any necessary restoration process (they are used in S4/S5, not S3 or Modern Standby; only the driver is involved in these states and it has no idea what these parameter(s) are set to). 

...S

DHoga2
Valued Contributor II
208 Views

Thanks for the info - the "BIOS" setting change didn't help me.  I could be mistaken but I seem to recall more difficulty when my output is from the HDMI port instead of from the USB-C Thunderbolt.  But perhaps that was just coincidence with something else like driver version(s) or various other things I've tried such as the timing of screen off vs PC sleep.

Reply