Intel® NUCs
Support for Intel® NUC products
12150 Discussions

Resizable BAR cause WHEA_UNCORRECTABLE_ERROR on NUC11BTMi9

Linking
Beginner
2,433 Views

Resizable BAR cause WHEA_UNCORRECTABLE_ERROR on NUC 11 Extreme Kit - NUC11BTMi9

Please take care of it, update the BIOS.

 

I kept getting BSoD WHEA_UNCORRECTABLE_ERROR on NUC 11 Extreme Kit - NUC11BTMi9.

I tried everything like reinstall drivers, reinstall win10 even win11, change RAM, limit the power through Geforce Experience. The problem is still there.

But after I change the RTX 3080Ti FE to a 2080Ti, everything is in peace.

And then disable the Resizable BAR in BIOS, put the 3080ti in, WOW, I got my peace again.

 

So, please please please update the BIOS to let us able to use the Resizable BAR for the best performance, like the name BEAST CANYON.

----------

I've seen same problem happened someone like me

https://www.reddit.com/r/intelnuc/comments/pwwr57/beast_canyon_whea_uncorrectable_error/

0 Kudos
1 Solution
Ronny_G_Intel
Community Manager
1,255 Views

Hi @Linking@Idahoryan, and everyone else,

 

We have been looking into this issue and found out that the cause of the BSOD/Reboots may be associated with the Intel Computing Improvement Program, which is typically installed with Intel® Driver & Support Assistant (IDSA).

Can you please check if Intel Computing Improvement Program is installed in your systems and if yes, can you remove it? The BSOD/reboots should stop immediately.

Please let me know if this resolves the issue. If it does work, then we'll work with the IDSA team to get a fix implemented in Intel® Driver & Support Assistant.

 

Regards,

Ronny G

 

 

View solution in original post

18 Replies
DeividA_Intel
Moderator
2,403 Views

Hello Linking,



Thank you for posting on the Intel communities. In order for us to understand better the issue, please share with us the following information: 


1. When did the issue start happening? Did it work before?


2. Run the Intel® System Support Utility (Intel® SSU) to gather more details about the system.  


· Download the Intel® SSU and save the application on your computer: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-   


· Open the application, check the "Everything" checkbox, and click "Scan" to see the system and device information. The Intel® SSU defaults to the "Summary View" on the output screen following the scan. Click the menu where it says "Summary" to change to "Detailed View".  


· To save your scan, click Next and click Save.  


3. Can you send a picture of the option (resizable bar) that you disabled at the BIOS?




Best regards, 


Deivid A.  

Intel Customer Support Technician 


Linking
Beginner
2,384 Views

Thx for reply!

 

This issue starts when I got this NUC, even I updated BIOS, The issue is still there. I've run SSU and the result should be in the attachment. And I've attached a picture of BIOS which is showing the resize bar option disabled.

 

Let me know if you need anything else.

DeividA_Intel
Moderator
2,347 Views

Hello Linking, 


  


Thank you for the information provided 


  


I will proceed to check the issue internally and post back soon with more details. 


  


Best regards, 


Deivid A.  

Intel Customer Support Technician 


Ronny_G_Intel
Community Manager
2,222 Views

Hi @Linking 

 

Have you checked on the following website: https://www.nvidia.com/en-us/geforce/news/geforce-rtx-30-series-resizable-bar-support/

After reading this article, can you please make sure that you have: 

  • Latest VBIOS for your Nvidia* card.
  • Latest GeForce* Game Ready Driver.
  • Resizable BAR enabled in the Nvidia* Control Panel.
  • I would also recommend that you test it under Windows* 10 as I believe this combination is still not fully validated under Windows* 11. 

If you have tried all this and still have the same issue, can you please check with Nvidia* support? We only provide support for this feature via the system BIOS and we have very few options to address any potential problem.

 

Regards,

Ronny G

DeividA_Intel
Moderator
2,178 Views

Hello Linking,  


  


Were you able to check the previous post? Please let me know if you need more assistance.   


  


Regards,  


Deivid A.  

Intel Customer Support Technician  


Linking
Beginner
2,156 Views

Hi Deivid,

 

I have carefully checked everything mentioned in the Nvidia article. And I am pretty sure that there is nothing wrong with Nvidia.

1. VBIOS for RTX 3080Ti FE is up to date and ready for resizable bar when it came out from factory. See the chat screenshot with nvidia support.

2. I have updated the Game Ready driver to 496.49

3. Resizable bar MUST enable in BIOS first, then you can see the resizable bar status in nvidia control panel, there is nothing you can enable for resizable bar in the control panel. (I can confirm this, even after update Game Ready driver to 496.49, when I try to enable resizable bar in BIOS, it will keep restart after getting into desktop. when I disable resizable bar in BIOS, all good. I tried both Win10 and Win11)

4. Win10 or Win11 doesn't matter, my another PC is currently under Win11 with RTX3090, it is very stable with resizable bar enabled.

 

If this problem happens only on me, then maybe the 3080ti is the problem. BUT, I'm not the only one who has this problem.

I don't know did you guys test it or not, if you didn't, please at least take a try.

I believe you guys can find some RTX30 cards to test.

 

Linking

DeividA_Intel
Moderator
2,139 Views

Hello Linking, 



Thanks for all the information provided. I will continue with the research and check for possible further steps, as soon as I have any details I will let you know.



Regards,  


Deivid A.  

Intel Customer Support Technician  


Ronny_G_Intel
Community Manager
2,115 Views

Hello Linking, 


We were able to replicate the issue that you reported and will be working on it, please keep in mind that this could take some additional time.


Regards,

Ronny G


Linking
Beginner
2,117 Views

That's fantastic. Looking for the update!

Ronny_G_Intel
Community Manager
1,985 Views


Hi Linking,


We were able to replicate this issue as mentioned before but only if the Operating System is installed with the Resizable BAR options disabled in the BIOS, then later enabled it. If the Operating System is installed with the BIOS set to defaults, we can't reproduce the issue. 


This is one option that you can try as a workaround until we get a definitive answer from the Engineering Team.


Please let me know your comments.


Regards,

Ronny G


Linking
Beginner
1,974 Views

Hmmm, that's interesting. But I'm pretty sure that I install the OS when the BIOS settings are all defaults. I literally didn't touch anything in BIOS when I install the OS. 

 

I set the Resizable BAR to Disable when I notice the problem and found the way to stable in the link I mentioned.

 

So I'll just wait till the Engineering team solve it.

 

Thank you very much for the update!!! I almost believe you guys are gonna forget it lol.

 

Well, it's almost Thanksgiving, no rush on this problem. Have a nice holiday!

 

Best,

Linking

Ronny_G_Intel
Community Manager
1,943 Views

Hi Linking,


Thanks for the feedback, we had slightly different results when duplicating this issue, mainly if this option was enabled or disabled in BIOS prior to the Operating System installation, we'll keep investigating and will get back to you as soon as possible.


Have a nice holiday as well!


Regards,

Ronny G


By the way, we try not to forget but if we do, don't hesitate to bring this issue up again!



Idahoryan
Beginner
1,897 Views
Hello, I am having the exact same issue as the OP. Bios was set to default with resizable bar set to true/enabled during OS install, and then with 3080ti installed it crashes unless I disable resizable bar in the nuc 11 beast canyon i9 bios.( GPU installed after windows 11 OS load if that helps) Looking forward to a bios update solution.
Ronny_G_Intel
Community Manager
1,256 Views

Hi @Linking@Idahoryan, and everyone else,

 

We have been looking into this issue and found out that the cause of the BSOD/Reboots may be associated with the Intel Computing Improvement Program, which is typically installed with Intel® Driver & Support Assistant (IDSA).

Can you please check if Intel Computing Improvement Program is installed in your systems and if yes, can you remove it? The BSOD/reboots should stop immediately.

Please let me know if this resolves the issue. If it does work, then we'll work with the IDSA team to get a fix implemented in Intel® Driver & Support Assistant.

 

Regards,

Ronny G

 

 

Linking
Beginner
1,241 Views

Hi Ronny,

 

Thank you so much for keep updating for us!

 

I've just tried uninstall the Intel Computing Improvement Program and IDSA. The problem seems gone. I can confirm that my NUC is now running under Resizable BAR and it's stable for 2 hours. Tried a lot of games, MSoffices and watching streaming, all normal till now.

 

If any problem jumps out again, I'll post here immediately. 

 

And also I'm so glad you guys found this issue and hope the IDSA will provide an update soon.

 

 

Best,

Linking

Ronny_G_Intel
Community Manager
1,224 Views

Hi Linking,


I am glad to hear that it worked, at least as a temporary workaround while the IDSA team looks into this issue.

I will report back your feedback and mark my post as solution for now.


Thank you very much for your patience and also for your help.


Regards,

Ronny G




GWN21
Beginner
1,203 Views

I had the same issue.  New NUC11BTMi9 with a Nvidia RTX 3070 Ti .

When I installed Windows 10, it would BSOD with the WHEA UNCORRECTABLE ERROR ever 3-4 minutes.

When I tried a fresh install of Windows 11, it would just Crash and reboot every 3-4 minutes.

 

I had the Intel® Driver & Support Assistant (IDSA) installed version: 21.7.50.3 in the Windows 11 build and once uninstalled, I was able to ENABLE the Resizable BAR in BIOS and have had no reboots since then.

 

Will be watching this thread to see when an update to this driver is made.

 

THANKS!
GWN21

 

Ronny_G_Intel
Community Manager
1,191 Views

Hi @Linking @GWN21 and everyone else,

 

Thanks for the feedback and patience with this issue.

I was told this morning that the IDSA team already pushed out a patch that should prevent the issue going forward.

We are also working on a new architecture that should be coming in the next full release that won't require the patch.

If you download IDSA/ICIP today, you should not see the issue.

 

Please try it if you have a chance and report back, I really appreciate your comments.

 

Regards,

Ronny G

 

By the way, I am going to be out of the office for a few days so my peers will be monitoring/answering this community.

 

 

Reply