Intel® NUCs
Assistance in Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12952 Discussions

Solution for Win10 1803 Upgrade failure with 0xC0000017


Hello there,

my NUC6i7KYK with Win10 pro tried to upgrade to 1803 yesterday and failed twice with error 0xC0000017 "There is not enough memory for ramdisk" when rebooting into WinPE. Searching the internet found the "bcdedit /enum {badmemory}" solution but this was empty and also does not make sense as the NUC has no ECC. Also trying other WinPE x64 boot images failed with the same error.

After examine of BIOS settings I found out that I had changed the 'grapics aperture size' to 1 GB. Reducing this to 256 MB made WinPE working again.

This could be an error in the BIOS (blocking all memory if apterture size is 1 GB) or an incompatibility of WinPE.

Best regards


0 Kudos
1 Reply
Super User Retired Employee

That setting change was ill-advised anyway. The Windows graphics driver will automatically allocate the (shared) memory necessary; there is absolutely no need (and zero performance advantage!) to doing this manually. All you have done is limited the memory available to other software. If you did this because you are running one of the games that has a bug causing it to refuse to run (because the minimum is set too low), making this kind of change isn't the right answer; get the fix from the game developer.

With regards to why you posted this info, yea, there are a number of issues (BIOS bugs), like this, that have been seen to occur if you change these numbers in the BIOS. Ironically, this may be because they are not testing the impact of changes to these parameters because you really shouldn't be making any. It's bad either way. Hopefully these will be fixed one day soon...