Community
cancel
Showing results for 
Search instead for 
Did you mean: 
EVals
Beginner
368 Views

Stutter every 5-10sec on Intel NUC8I7HVK

Hello, this is my second NUC8I7HVK (the first one did not have this problem) and I'm experiencing stutter every 5-10 seconds in Windows 10.

 

It does not do this while in BIOS and I managed to narrow it down to the AMD graphics card. When the Intel GFX is only enabled it does not behave like this.

 

I'm using the latest AMD graphics driver from Intel, downgrading to the version before the newest one seems to "fix" this problem.

 

Does Intel have any solution to this besides using very old drivers?

 

Thank you.

0 Kudos
6 Replies
LeonWaksman
Super User
84 Views

  1. Right click on desktop and then left click on AMD Readeon Settings.
  2. In the bottom left corner on AMD Readeon Settings panel, click on Updates. Next click on Check for Updates.
  3. If there is new driver for update do this. On my NUV8i7HVK , currently I have installed driver package 19.9.2 ( ver 26.20.13003.1007 in Device Manager, dated 10-Sep-19).

 

Leon

 

EVals
Beginner
84 Views

Did you install the AMD driver from the Intel website originally?

 

I dont see the "Check for updates" option in my AMD Radeon Settings application, only "Preferences" and there is no such option there.

 

Thanks for the help.

 

 

LeonWaksman
Super User
84 Views

  1. I was using the driver from intel's site at beginning. About half year ago I'v installed the first time driver downloaded from AMD. Since I don't see any anomalities, since then, I'm updating this driver using method described above.
  2. This is link to the link to the version 19.9.2 of the AMD Radeon Adrenalin Driver https://www.amd.com/en/support/kb/release-notes/rn-rad-win-19-9-2 .
  3. You may download and install the Windows 10 64bit version https://drivers.amd.com/drivers/win10-64bit-radeon-software-adrenalin-2019-edition-19.9.2-sep23.exe and see if this helps.
  4. Allways, you may uninstall this driver and reinstall the driver from Intel.

 

Leon

 

EVals
Beginner
84 Views

I installed the same driver as you have and so far so good. :)

 

Thank you.

LeonWaksman
Super User
84 Views

  1. I'm glad that your system is working now as expected.
  2. Idon't know what is the reason for Intel keepeng the old driver in the Donload Center. In the newer NUC8i7INH, Intel gives link to the AMD site instead to keepeing old driver in Intel site.
  3. I hope this will be updated and NUC8i7HVK will have updated driver for download.

 

Leon

 

Diver5050
Novice
84 Views

It sounds like you found a workable solution, but if for some reason this stops working for you, or you would like to get the version of the AMD driver package available from Intel working, properly, i.e. get rid of the periodic stuttering, follow these steps:

 

  • Open the Radeon Vega MX Settings (right click on your desktop and open)
  • In Radeon Settings, click on the 'Display' button
  • Click on 'Specs' in the upper-right corner
  • Check 'Current HDCP Status' - If it says 'Enabled', then click on the 'Override' button at the top
  • Toggle HDCP Support to 'DISABLED'
  • Reboot your PC

 

That should be it. I found this solution after banging my head against the wall for weeks and after a lot of Internet searching. Don't ask me why this setting is buried in its un-intuitive location, and certainly don't ask me why it works, but it does.

Reply