Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor III
929 Views

TB/HDMI CONNECTION Issues, Taskbar Icons Extended Display NUC7i5

Jump to solution

CONFIGURATION:

NUC7i5BNHX 8GBDDR4/250GB EVO970 System Drive/1TB internal HDD. Used to have OPTANE replaced with EVO(same issue using OPTANE)

Main Display AOC 1920 Connected to Thunderbolt via USBC to HDMI Cable (Samsung cable)

TV SHARP 1920 TV Connected to HDMI Port In Exteded Mode

Here is What I've found.

Main Display is connected to TB and TV Extended connected to HDMI.

__________________________________________________________________________________________________________________________

If TV is powered ON during Boot no problem it can be set on TV or HDMI Icons will be present when you you go to HDMI

BUT if you Turn off TV now it freezes up the main monitor after 20 seconds or so. Open Taskmanager and just click on cancel

and login screen appears again.Log in(I enter Pin) and all is well on my main screen.

Turn on TV and if its still on HDMI it will come up with main screen(as if in duplex mode)and all is frozen, open taskmanager

click cancel with the mouse and it resets. And I have Icons on the TV Taskbar.

_________________________________________________________________________________________________________________________

If TV is powered OFF during Boot then stuff start to happen.

Turn ON TV and I it's already set to HDMI it will show the Main display theme but everything will freeze. Taskmanager click cancel

it all works again BUT NO ICONS ON TV TASKBAR

IF the TV was set to TV Channels at power on the issue is the same switch to HDMI and the TV will show the Main screen but it's Frozen

Taskmanager will unfreeze but ICONS will go missing.

____________________________________________________________________________________________________________________________

Making TV The Main Display everything works fine I can power off/on my TB monitor do all of the above tests and all works great.

There seems to be some issue with TB having the main display

In Bios I have tested IGD settings Automatic and setting TB as primary, It makes no Difference.

Workaround would be to put my main display on HDMI port and attach the TV to the TB port but that's not a good option since it would

require me to buy a heap of stuff to set things up(TV is on a 15 meter HDMI Cable and Monitor is on a 60 cm USB C Cable)

Any suggestion how to fix this woul be Greatly appreciated.

I CAN REPRODUCE THE PROBLEM TILL THE COWS COME HOME :o)

And the same issues occur when the NUC wakes up from sleep
Tags (1)
0 Kudos

Accepted Solutions
Highlighted
New Contributor III
13 Views

"Workaround would be to put my main display on HDMI port and attach the TV to the TB port but that's not a good option since it would

require me to buy a heap of stuff to set things up(TV is on a 15 meter HDMI Cable and Monitor is on a 60 cm USB C Cable)"

Well being an impatient little bugger and wanting to Test my theory, I went out and spent a whopping 20$ on a USB3 to HDMI Connector and a one meter HDMI cable

(Fully expect Intel CEO to contact me and discuss how to arrange reimbursement ;o))

And Be and Behold

AS LONG AS MAIN DISPLAY IS ATTACHED TO HDMI PORT THERE IS ABSOLUTELY NO PROBLEMS WITH ICONS OR ANYTHING ELSE ON EXTENDED DISPLAYS ATTACHED TO THUNDERBOLT

I suspect that any weird audio issues you might have will be solved by this set up ( I currently have Realtek audio Removed and 2381 Intel Display audio Disabled and no issues) and will re-install and

test that later.

Talking about Audio Go to Microsoft Store and Download EarTrumpet App and you will finally get Volume control like it always should have been, just a great Improvement for free.

Summary.

BIOS 0065 (same issue on 0064) Default Settings.

The workaround is Bullet proof the problem is reproducible and Intel need to fix BIOS(I presume it's a BIOS thing) so that any display can be main display without issues.

View solution in original post

0 Kudos
1 Reply
Highlighted
New Contributor III
14 Views

"Workaround would be to put my main display on HDMI port and attach the TV to the TB port but that's not a good option since it would

require me to buy a heap of stuff to set things up(TV is on a 15 meter HDMI Cable and Monitor is on a 60 cm USB C Cable)"

Well being an impatient little bugger and wanting to Test my theory, I went out and spent a whopping 20$ on a USB3 to HDMI Connector and a one meter HDMI cable

(Fully expect Intel CEO to contact me and discuss how to arrange reimbursement ;o))

And Be and Behold

AS LONG AS MAIN DISPLAY IS ATTACHED TO HDMI PORT THERE IS ABSOLUTELY NO PROBLEMS WITH ICONS OR ANYTHING ELSE ON EXTENDED DISPLAYS ATTACHED TO THUNDERBOLT

I suspect that any weird audio issues you might have will be solved by this set up ( I currently have Realtek audio Removed and 2381 Intel Display audio Disabled and no issues) and will re-install and

test that later.

Talking about Audio Go to Microsoft Store and Download EarTrumpet App and you will finally get Volume control like it always should have been, just a great Improvement for free.

Summary.

BIOS 0065 (same issue on 0064) Default Settings.

The workaround is Bullet proof the problem is reproducible and Intel need to fix BIOS(I presume it's a BIOS thing) so that any display can be main display without issues.

View solution in original post

0 Kudos