Intel® NUCs
Support for Intel® NUC products
11772 Discussions

Thunderbolt™ 3 Driver Setup Failed 0x80070643

AntonioWhite
Novice
1,601 Views

Здравствуйте, соединение Thunderbolt 3 перестало работать последние две недели. При установке драйвера выдает ошибку 0x80070643. Полная переустановка Windows не помогла исправить ошибку, моя материнская плата Asus PRIME Z370-A II подключена к ней помимо ASUS ThunderboltEX 3, установлена ​​актуальная версия Биоса. В Bios включена поддержка Thunderbolt 3, и я использую Windows 10 с последними обновлениями. Помогите пожалуйста решить проблему.

0 Kudos
6 Replies
n_scott_pearson
Super User Retired Employee
1,516 Views

Where are you getting the installation package? You should not be getting the package from the Intel site. You should be getting it from Asus and you should be contacting Asus, not Intel, regarding this installation issue. Remember that there are differing Thunderbolt ICs and the driver has to be correct for the particular IC used on the motherboard. This makes it the board manufacturer's responsibility.

...S

AntonioWhite
Novice
1,481 Views

I can say that before this problem, Thunderbolt 3 worked absolutely with all the drivers, they installed and detected the device, and it doesn't matter who they are from Asus or Intel. But now not one of the drivers is working, the maximum I was able to achieve is to install the old version of Asus drivers, but they still do not work and do not detect connected devices.

AndrewG_Intel
Moderator
1,472 Views

Hello @AntonioWhite

Thank you for posting on the Intel® communities. Our support is only provided in English. We may not be able to translate screenshots attached to the thread. To better assist you, we use a translation tool.


We agree with @n_scott_pearson that the best channel of support for this inquiry is through Asus* Support since we understand this is regarding a Thunderbolt* issue with motherboard Asus* PRIME Z370-A II and Asus* ThunderboltEX 3 PCI-Express card.


It is worth mentioning that Thunderbolt is a technology that computer manufacturers customize for their platforms. Intel provides firmware and driver updates directly to OEMs (Asus*, HP*, Lenovo*, Dell*, and so on) and doesn't support their products. It's their responsibility to test and validate updates before posting them for customers on their support websites.


Intel does support Thunderbolt on Intel® NUC products. For more details, please review Support Options for Thunderbolt*.

Having said that, we will proceed to close this inquiry now from our end. We will leave the thread open in case other users want to participate; however, we encourage you to check this directly with ASUS* Support. Thank you for your understanding.


Best regards,

Andrew G.

Intel Customer Support Technician


AntonioWhite
Novice
1,459 Views

Tech support from Asus does not give a solution to the problem, it refers to incorrect Windows updates and asks to contact Microsoft. I will try to contact microsoft and ask for an explanation of how this problem can be solved, if they give a working solution, I will post it in this discussion.

AntonioWhite
Novice
1,442 Views

For some reason, I can no longer edit the description of the problem in the discussion header.
My question in English sounded like this.
Hello, Thunderbolt 3 connection has stopped working for the last two weeks. When installing the driver, it gives an error 0x80070643. A complete reinstallation of Windows did not help to fix the error, my Asus PRIME Z370-A II motherboard is connected to ASUS ThunderboltEX 3, the current BIOS version is installed. The Bios has Thunderbolt 3 support enabled and I am using Windows 10 with the latest updates. Please help me solve the problem.
I have attached a photo of the problem in English.

AntonioWhite
Novice
1,383 Views
I called Microsoft support, they were able to find a solution to the problem, the intel driver itself was not installed, but the computer was able to install its internal drivers and find my device connected using Thunderbolt 3. First, you need to install the latest Windows 10 updates, then go to the command line "cmd" as administrator and use these commands in the same order net stop wuauserv net stop cryptsvc net stop bits net stop msiserver net start wuauserv net start cryptsvc net start bits net start msiserver then try to turn on your device connected by Thunderbolt 3. It helped me and the computer installed the driver and detected my device. Hope it helps you.
Reply