Intel® NUCs
Support for Intel® NUC products
11792 Discussions

Thunderbolt driver installation error 0x80070643

luigi19
Beginner
6,546 Views

Hi,

I use 2 monitor with my NUK, one on hdmi one on thunderbolt. And sometime the one on thunderbold don't work. 

I'm tring to update the software to last one but I receive the error 0x80070643.  Logs in attachment.

So I tried to remove old driver but It seems it's not present.

Someone have a solution?

 

MOTHERBOARD: NUC8BEB Version J72693-308

 

Labels (1)
0 Kudos
6 Replies
Victor_G_Intel
Moderator
6,476 Views

Hello luigi19,

 

Thank you for posting on the Intel® communities.


We appreciate the log you provided, and in order to further assist you please provide the following report and information to continue with the support.


-Intel® System Support Utility (Intel® SSU)

 

Download link: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

•          Open the application and click on "Scan" to see the system and device information

•          By default, Intel® SSU will take you to the "Summary View".  

•          Click on the menu where it says "Summary" to change to "Detailed View".  

•          To save your scan, click on "Next", then "Save".

 

Use the option under the reply window to attach the report to the thread (Drag and drop here or browse files to attach).

 

- When did you buy the unit?


- Did this configuration (NUC+ one monitor on HDMI+one monitor on thunderbolt) work fine before? If yes, was there any recent change related to the point when the issue started?


- Could you please provide a video or some pictures showing this behavior?


- Did the error happened while using our Intel® Driver & Support Assistant to update the driver or did the pop-up error message appeared after you manually tried to install the driver?


- Have you tested your NUC with a different monitor and a different thunderbolt cable?


- Did you physically inspect the thunderbolt port to see if maybe has some dirt in it or if it’s maybe loose?

 

I look forward to hearing from you.

 

Regards,

 

Victor G.

Intel Technical Support Technician 

 


BrunoCosta
Novice
6,276 Views

Hello Victor!

I'll take it from here, as I'm experiencing the same problem. The USB-C connection not working is what motivated the manual installation of this driver. Note that it also happens when connecting to only one monitor via USB-C - USB-C, HDMI is working correctly. I have attached the report from the Intel SSU app.

- My unit was bought in May 2020 (Intel NUC Kit NUC8I5BEK2 | Core i5 8259U)

- Yes, it has worked in the past. I had the opportunity to try it during one day, several months ago, and it worked just fine. In the meantime I have just been updating the software when suggested by both Microsoft and Intel.

- A video of the behavior was attached. It usually blacks out for longer periods when connected just via USB-C, the HDMI connection somehow "strengthens" the connection. Note that when accessing the BIOS the issue does not occur.

- 2nd option.

- No, because it worked in the past I just tried with another cable, producing the same result. Also, to rule out the possibility of the monitor being broken, I connected it to a MacBook Pro via USB-C and it worked as expected.

- Yes, there is no visible debris nor apparent damage.

 

I hope that this is helpful.

Best,

Bruno

 

 

LeonWaksman
Super User
6,273 Views

Hi Bruno,

Please open a thread of yours and I'll give you advise what to do. Your problem may looks similar, but in my opinion is not caused by thunderbolt firmware.

Leon

 

Victor_G_Intel
Moderator
6,444 Views

Hello luigi19,


Were you able to check the previous post?  


Please let me know if you need further assistance.  


Best regards,


Victor G. 

Intel Technical Support Technician


Victor_G_Intel
Moderator
6,396 Views

Hello luigi19,


We have not heard back from you.


If you need any additional information, please submit a new question as this thread will no longer be monitored.


Victor G. 

Intel Technical Support Technician  


Reply