Intel® NUCs
Support for Intel® NUC products
11784 Discussions

Thunderbolt stopped working on NUC8i5 with Ubuntu 18.04


Has anyone else a problem using the Thunderbolt interface on NUC8i5? I have the NUC8i5BEH and was working with a dual monitor setup under Ubuntu 18.04.2. One connected via HDMI, the other one via Thunderbolt/USB-C. After having worked for weeks, for some days I have problems connecting the Thunderbolt monitor. Some days ago, the display was simply not found from Ubuntu. After having switched monitors and cables, it somehow worked again. But today, the same problem occurred, and until now I had no chance to reconnected the second display.


In the Ubuntu settings Devices > Thunderbolt, it simply says "No Thunderbolt support":

Screenshot from 2019-10-25 12-01-42.png

More importantly, lspci does not list the Thunderbolt device:

Screenshot from 2019-10-25 12-03-26.png

Has anyone else similar problems? Or should I be worried about a broken device? I am running Linux 5.0.0-32-generic #34~18.04.2-Ubuntu.

0 Kudos
3 Replies
Super User
  1. Since only Windows 10 64bit is supported by Intel on your NUC, I suggest that you should install Windows 10 on your NUC, togather with all the drivers downloaded from Intel . Douing so, you will be able to verify if this problem is caused by Linux or it is hardware releated.
  2. The Windows 10 installation media, you may create using Microsoft Media creation Tool:
  3. Before starting this test, you should update your Bios to the latest version 0074 (some Thunderbolt issue was fixed in Bios version 0073 "  Thunderbolt Hot-plugging doesn't work when you use Legacy in the BIOS ").





Thank you for your suggestions! I have the latest BIOS version running, so this shouldn't be a problem.


Funny thing: booting an Ubuntu 19.10 Live image re-enabled the Thunderbolt interface. In the live settings, I could activate the disabled monitor. Rebooted into the installed 18.04, and everything worked again. So if anyone else has the same problem, this might be a possible way out.

Super User Retired Employee

Also. make sure you have UEFI enabled and Ubuntu installed in UEFI mode (not Legacy).