Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
275 Views

Two problems with NUC10i7FNB

Hello

I purchased my NUC10i7FNB last may and I'm very satisfied but I have two main issues that I would like to solve to have a magnificent customer satisfaction.

My setup: I have one screen (Dell U3219Q) connected with USB-C cable (not thunderbolt 3) 

I also had an HP z32 and the problem was the same (this screen was thunderbolt 3)

First problem: Bluetooth and Display black screen

When I connect my Bluetooth headphones or when I have them connected already depending on the apps I open (for example I experienced it with Skype and Teams) the screen goes black for 3 seconds more or less

I see some other people also reported but the solution gave to them seems not working for me. I would like to add more information just in case it helps solve the problem. When I connect to display with HDMI the problem is not present. 

I attach the information you usually ask them to see if it helps.

 

Second problem: Computer Sleep

I have my computer setup on the BIOS with "Legacy S3" because I use Linux sometimes too and Modern Standby doesn't work with Linux.

My computer doesn't go to sleep neither Windows nor Linux. With some BIOS updates sometimes work but since 2 o 3 BIOS updates, sleeping doesn't work any more. I put my computer to sleep manually when I need it.

 

I hope we can find a solution to these issues to make this little NUC perfect

Thank you or your help

0 Kudos
11 Replies
Highlighted
249 Views

Hello joandomenech, 

 

Thank you for posting on the Intel® communities.   

 

Please include the following details: 

 

1. Brand and model number of the Bluetooth headphones that you are using. 

2. Were you able to use these headphones as expected before? If yes, do you remember making any changes before the issue started?  

3. From the NUC to the monitor, are you using any adapter or is it a straight connection?  

 

Just for testing purposes, please try the following and let us know about the outcome: 

 

1. Install the USB Type C Power Delivery Controller for Windows® 10 64-bit for Intel® NUC. If you need help installing this driver, see How to Install a Driver without a .exe File. 

2. Try a clean installation of the latest Bluetooth drivers validated for this NUC

3. Install the latest Thunderbolt™ 3 DCH Driver for Windows® 10 for Intel® NUC 

  1. Download this driver package and unzip it to a folder on the Intel NUC. Driver Version: 1.41.1015.0  
  2. Connect a Thunderbolt device to the Thunderbolt port. 
  3. Browse to and select the folder where you unzipped the driver package. 
  4. Right-click on each of the following .inf files and select Install
  • TbtHostController.inf 
  • TbtHostControllerHsaComponent.inf 
  • TbtHostControllerToastController.inf 
  • TbtP2pNdisDrv.inf 

 

4. You will also need the Thunderbolt Control Center software (available on the Microsoft Store) to approve and manage Thunderbolt devices. 

5. Change the Windows power management setting for the Thunderbolt controller: 

  1. Press the Windows key and X
  2. Select Device Manager
  3. Expand the System devices section. 
  4. Right-click the Thunderbolt(TM) Controller and select Properties
  5. On the Power Management tab, uncheck the box for Allow the computer to turn off this device to save power. 
  6. Click OK
  7. Close Device Manager. 

 

6. Install the latest HDMI Firmware Update Tool for NUC10i3FN, NUC10i5FN, NUC10i7FN. Follow the instructions of the User Guide 

7. Finally, for the sleep issues; try setting the BIOS settings to its defaults and then test if at least Windows is able to go to sleep as expected.  

 

Regards, 

 

Sebastian M  

Intel Customer Support Technician  


0 Kudos
Highlighted
Beginner
227 Views

Dear Sebastian for your answer

The screen effect with the Bluetooth I solved it deactivating from the device "Thunderbolt(TM) Controller" the option to "Allow the computer to turn off this device to save power"

The Sleep effect remains the same after resetting the BIOS to default values. Computer can't go to sleep in Windows or Linux

Tahnk you for your help

0 Kudos
Highlighted
189 Views

Hello joandomenech,  

 

Thank you for your reply. 

 

To better understand this problem, please provide the following: 

 

  • The issue that you are facing, is that the NUC will not go to sleep after being inactive for some time, and that you need to manually send it to sleep. Is that correct?  
  • From the NUC to the monitor, are you using any adapter or is it a straight connection? 
  • Does this happen connected either via HDMI and USB-C/Thunderbolt?  
  • Do you remember making any changes before this problem started?  

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician


0 Kudos
Highlighted
Beginner
174 Views

Hello Sebastian, thank you for your feedback. I'll answer all below.

Exactly this is what happens to me. After a long period of inactivity the computer won't go to sleep.

I have my display connect without any adaptor to the back USB-C/Thunderbolt port with the original cable that came with the monitor.

Not 100% sure it happens with HDMI too, I'll try and I'll let you know.

I'm not aware of making any changes. All I can say, if it helps, that all started with one BIOS upgrade (I'm sorry I can't remember which version was, but I can say it was around June/July) that it changes the "Legacy S3" option to "Modern Standby". When I saw that I thought to myself that this change maybe messed up something with Windows and I tried Linux different distributions installing always fresh with "Legacy S3" activated and always the same result.

After that there was some BIOS update that fixed it a little, with this I mean that sometimes go to sleep, sometimes don't, but now never goes to sleep.

I'll check if with HDMI happens the same and I'll let you know.

Thank you for your help

0 Kudos
Highlighted
162 Views

Hello joandomenech,   

  

Thanks for the information. 

 

Please let us review this behavior internally and kindly wait for an update. 

 

Once we have more details to share, we will post them on this thread.  

  

Regards,   

   

Sebastian M   

Intel Customer Support Technician 


0 Kudos
Highlighted
Beginner
134 Views

Hi again @Sebastian_M_Intel

Thank you for answering.

I can confirm you that with HDMI happens the same. Computer won't go to sleep with HDMI also

If I can help you with more information, let me know

0 Kudos
Highlighted
97 Views

Hello joandomenech,    

   

Thank you for patiently waiting.  

  

Please try the following recommendations: 

 

1. Make sure that there are not unnecessary devices attached to the system that could be preventing S3 from happening. Try with a regular USB mouse and keyboard. 

2. Run the command prompt and try the following: 

  • powercfg /a ---> will display available power states 
  • powercfg /getactivescheme --> will display the actual power mode that is running 
  • powercfg /devicequery --> shows devices that meet current criteria 
  • powercfg /setactive --> set power scheme to active 

  

3. You can additionally try a BIOS recovery to rule out any BIOS corruptions.  

 

4. If you do not want to try the BIOS recovery, set BIOS defaults and make sure that S3 is enabled.  

 

If after doing the above the unit still has problems, then you may want to contact us directly and claim a warranty for the unit as this can be a hardware issue. Here is our contact us info: https://www.intel.com/content/www/us/en/support/contact-support.html  

 

Regards,    

    

Sebastian M    

Intel Customer Support Technician  


0 Kudos
Highlighted
83 Views

Hello joandomenech,  

 

Were you able to follow the recommendations in the previous post? Please let me know if you need more assistance.   

 

Regards,  

  

Sebastian M  

Intel Customer Support Technician  

0 Kudos
Highlighted
Beginner
80 Views

Hello @Sebastian_M_Intel 

I've been busy working from home on lockdown during this week. I'll try this weekend and I'll let you know

Thank you for you help

0 Kudos
Highlighted
Beginner
45 Views

Dear @Sebastian_M_Intel 

The sleep problem is solved. I changed my keyboard and mouse and computer started to sleep. Some key or the mouse was faulty and send small signals and make the computer awake.

I'm sorry for all any inconvenience I caused, but I never thought about changing the keyboard.

If anyone has the same problem, now will know another thing to try.

Thank you for all you help and dedication. Very appreciated

Now I have the best computer

0 Kudos
Highlighted
18 Views

Hello joandomenech,  

 

Thank you very much for the update. 

 

I am glad to hear that your computer is now working as expected. We will proceed to close this inquiry; if you have any additional questions, please submit a new thread. 

 

Regards,   

   

Sebastian M  

Intel Customer Support Technician   


0 Kudos