Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Contributor I
1,274 Views

USB External and Flash Drive Boot Selection

I have the latest Visual Bios 050 and I had set USB Boot First and then I would insert a USB Flash drive and the system would boot from it. Now I also have an external USB SSD in an enclosure that has a bootable partition on it is Disk 1 Drive D:. Now when I boot, with USB Boot First ON it will boot from that EVEN IF I have selected the regular Bootmgr entry as the top/first selection entry. I have to turn off USB Boot First to get the system to boot up into the regular C: Drive. Also if I have the external USB disk drive connected and then insert a USB flash drive that I want to boot from, it auto boots from the external boot drive and completely ignores the usb flash drive. There is not selection entry in the bios to select the flash drive. Can somebody help me sort this out. I really don't want to have to go into the bios everytime to turn on/off USN Boot First and disconnect the external USN drive to get a usb flash drive to boot. Help. TIA

0 Kudos
4 Replies
Highlighted
Super User
25 Views

I assume that both, UEFI and Legacy boot are enabled and the boot priority you have set in the legacy boot. You have to know the following rules:

1. If both UEFI Boot and Legacy Boot are enabled, BIOS will attempt to boot via UEFI before using the legacy boot sequence.

2. You may change the boot priority in UEFI boot bios settings by dragging the relevant drive up or down (all bootable drive have to be inserted before entering bios).

3. The easiest way to choose drive for boot is from boot menu. Enter boot menu by pressing F10 during boot (when you see F2,F7,F10 menu).

Leon

0 Kudos
Highlighted
New Contributor I
25 Views

Leon: Thanks for your responses.

1. Yes Both UEFI Boot and Legacy Boot are enabled.

2. IF I have USB Device Boot First enabled it will ALWAYS boot from the External USB SDD....unless I press F10 and select the windows install on C:, even though I have the windows entry first in the UEFI boot

3. I can only boot to a flash drive, by shutting down the system or restarting it, disconnect the External USB Drive D: and then it will boot from the USB flash. If I press F10 there is no choice to boot the usb flash drive.

4. then I have to restart or shutdown reboot,after plugging back in the D; External USB ssd, and removing the usb flash drive, and un-selecting Boot USB Device first.

Why doesn't the bios see winpe bootable usb flash media and give me the choice to select it?

My only solution it seems is to remove the bootable partition on the D; external usb ssd and boot with usb flash.

TIA

0 Kudos
Highlighted
New Contributor I
25 Views

Here's what I decided to do. I removed/deleted the 2gb bootable partition on the D: External USB ssd. D: contains backups that are still accessible if i press F11 or use a bootable winpe flash drive. So I have 2 out of 3 ways to access my backups on D: for restore and recovery purposes. I still have the bios set Boot USB Devices First, USB Boot enabled and Legacy Boot enabled and they will boot my other winpe bootable flash drives if inserted.

0 Kudos
Highlighted
Super User
25 Views

Hello TerryDean ,

I don't know what software are you using for disk backup. I'm using AOMEI Backupper: https://www.backup-utility.com/download.html https://www.backup-utility.com/download.html . The bootable USB for emergency backup and restore is created with UEFI boot, therefore it is now problem to boot NUC (even if boot priority in bios is set to default). The USB is also detected in F10 boot menu.

Leon

0 Kudos