Intel® NUCs
Support for Intel® NUC products
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11994 Discussions

USB Problem with NUC7i5BNH after upgrade to BIOS-083

nuc-mize
Beginner
379 Views

 

Hello,

After using my NUC7i5BNH for four years stable and without problems,
I upgraded the Linux and the Windows to actual versions two month before.

I also upgraded from BIOS BNKBL.357.86A.0081 to BNKBL.357.86A.0083,
but it seems, that was an error ...

It seems, that the 0083 Linux has problems to control USB-Power.

The last weeks, both rear USB-3.0 Ports were always on (powered on), even
if the NUC was switched off and not working. Since last 1-2 days I now have
the problem, that both rear blue USB-3.0 Ports and the one blue in front are
alway´s powered off (no voltage, even if NUC is running). Despite if I connect
a USB-Bus tester or an USB-Stick with integrated Power-LED – no power. And 
so Windows or Linux cannot detect e.g. my USB stick. 

Yellow front USB is working (stick is detected properly, but is powered alway´s
on, but here that is o.k.). Rear USB-3.1 Type C connector is working correctly too.

   NUC has type:    G6BN7 1500E0D   SA J31169 – 303
   NUC has serial:  F44D306E05DE

What can I do, to make my USB 3.0 ports work again?

  • Is there an electronic fuse on NUC-Mainboard, that is shot, and
    prevent´s USB 3.0 to deliver power?

  • Would it be an idea to go back to BIOS-081, which seemed to
    work stable? But flashing old BIOS-081.bio from inside my 083
    BIOS stop´s update at management engine with error message
    FwUpdateFullBuffer, Flash update failed (0x8000000000000015, 0)

  • Would flashing BIOS 081 under Windows work better? But
    where to find this MSI-File (only 083 is downloadable)

Any help would be apreciated …
Michael

0 Kudos
3 Replies
n_scott_pearson
Super User Retired Employee
360 Views

Have you tried reinstalling this latest BIOS update using the BIOS Recovery process?

Have you tried resetting the BIOS configuration? If not, use F9 key in BIOS Setup (Visual BIOS) to do reset.

Hope this helps,

...S

nuc-mize
Beginner
340 Views

Hallo Scott,

a very good idea. but died not change the result ...

 

I tried to reinstall 083 BIOS with 083, and the BIOS update told at the end of
the installation was successful. But the behaviour is the same as before. No
Power at USB when switching NUC on (on my other NUC the USB-Power is
available immediately when switching NUC on, long before start of Linux or
Windows is taking place).

Then I tried to reset BIOS (F9 key in BIOS) the same behaviour - no power.

Today I got my USB-Switch for the rear USB-C connector: 5.09 Volt Power
on the switch, but the USB-Key on the switch is not detected. This drives
me crazy. What can go wrong with NUC, that USB-3.0 connectors have no
Power and USB-C connector has Power but refuses to accept USB-Switch
and does not detect USB-Stick connected to switch (USB-Stick LED off)?

Michael

 

n_scott_pearson
Super User Retired Employee
327 Views

Hhmmm, if anything like this had been detected, they wouldn't have shipped this BIOS release - presuming that their validation processes don't have a hole in them. I tried upgrading my BN NUC to this BIOS and did not encounter any problem (USB 3.0 and TBT3/USB-C ports are working fine).

Did you use BIOS Recovery process or just a regular (EBU/F7) update? If a regular update, you've wasted time; go back and try BIOS Recovery process. Even better, go back and try using the jumper-based BIOS Recovery process (this is a more-absolute update of everything) - oh, and once it completes, so the F9 again (IMHO, you should *always* do a F9 after a BIOS Recovery process).

...S

Reply