Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
166 Views

Unwanted resolution change on open windows when switching HDMI inputs on monitor.

I use an LG Ultra 27MU58P-B monitor. I have two NUC's connected to the monitor via their own HDMI cable to HDMI-1 and HDMI-2 inputs on the monitor.

 

The first NUC, an NUC8I7HVK unit, uses the latest Radeon graphics drivers. The second NUC, an NUC10i7FNH unit, uses the latest Intel graphics drivers.

 

When I switch the display from the first NUC to the second NUC, then back, any desktop windows (browser, mail, etc.) are exactly where they were prior to switch to the other NUC.

 

However, when I switch the display from the second NUC to the first NUC, then back, any desktop windows (browser, mail, etc.) are resized to about 1/4 of the correct display size and have relocated to the top left of the screen.

 

This happens with the NUC using the Intel graphics drive. I've switched HDMI ports on the monitor and tried other HDMI cables with no success.

 

Any idea on how to fix this? It's very annoying.

 

Thanks

 

0 Kudos
9 Replies
Highlighted
Moderator
48 Views

Hello MDeni4, 

 

Thank you for posting on the Intel® communities.   

 

To better assist you I would like to gather some additional information from you:

 

  • Were any changes in the system prior to this situation?
  • Please confirm the graphics driver for the Intel® NUC that is experiencing this behavior.
  • Please provide the operating system and it’s build.

 

If you are using Windows* 10 please try the following steps:

1.      Right-click the Desktop

2.      Place the cursor in the “view” tab

3.      Uncheck “Auto Arrange Icons” in case the option is checked.

4.      Check results.

  

Esteban D.  

Intel Technical Support Technician   

0 Kudos
Highlighted
Novice
48 Views

Hi Esteban,

 

There's not been any changes to my system since the initial install of Windows 10 save for the occasional Windows Updates. This behavior has been present since the installation. The Intel update tool indicates that all the NUC drivers are current as well as the NUC bios.

 

The NUC10i7FNH is the PC with this issue and the Intel update tool shows the graphics drive as :

 

Intel® UHD Graphics Driver Details Provider: Intel Corporation Version: 26.20.100.7755 Date: 1/9/2020

I'm running Windows 10 Pro, Build 18362.19h1_release.190318-1202

 

Icon Auto Arrange has always been off.

 

Thanks

 

0 Kudos
Highlighted
Moderator
48 Views

Hello MDeni14,

Thank you for your response and the information provided.

 

After checking the picture attached I noticed that there is an update available for the graphics adapter for your Intel® NUC10i7FNH.

Please check the following article with all the steps to update the driver

 

You can download the latest driver from the following link.

 

Please try the following steps and share results with me:

1.      Right-click on your desktop.

2.      Click on “Personalize”

3.      Go to the “Themes” tab and click “Desktop icon settings”

4.      Uncheck the “Allow themes to change desktop icons”

5.      Apply changes and check results.

 

You might want to disable the “Align Icons to grid” option.

 

Esteban D.  

Intel Technical Support Technician  

 

0 Kudos
Highlighted
Novice
48 Views

Hi Esteban,

 

I updated the graphics driver per your suggestion:

Intel® UHD Graphics Driver Details Provider: Intel Corporation Version: 26.20.100.8141 Date: 4/11/2020   Device Details Adapter Compatibility: Intel Corporation Video Processor: Intel® UHD Graphics Family Resolution: 2560 x 1440 Bits Per Pixel: 32 Number of Colors: 4294967296 Refresh Rate - Current: 60 Hz Refresh Rate - Maximum: 60 Hz Refresh Rate - Minimum: 23 Hz Adapter DAC Type: Internal Adapter RAM: 1.00 GB Availability: Running at full power Status: This device is working properly. Location: PCI bus 0, device 2, function 0 Device Id: PCI\VEN_8086&DEV_9BCA&SUBSYS_20818086&REV_04\3&11583659&0&10

Unfortunately, no change to my problem. Interestingly, the Intel DSA did not detect the new graphics driver when I ran it prior to the install from the download link you provided.

 

Under 'Themes', there is no 'Desktop icon settings' checkbox or link shown.

 

Align Icons to grid is off (No improvement).

 

I still think there is an ongoing issue with the graphics drive for this NUC.

 

Thanks,

 

0 Kudos
Highlighted
Moderator
48 Views

 

Hello MDeni14,

 

Thank you for the update.

 

  • Can you please confirm how are you switching the display between the units?
  • Are you using any kind KVM switch?

 

If possible please provide pictures/video of the behavior.

 

Esteban D.  

Intel Technical Support Technician  

0 Kudos
Highlighted
Novice
48 Views

The LG monitor has a button that shows an on-screen menu. I can toggle between HDMI-1 and HDMI-2.

 

I use no switches.

0 Kudos
Highlighted
Moderator
48 Views

Hello MDeni4, 

 

This seems like a common behavior of the operating system that is related to the change of resolutions, it’s likely occurring when you have a shared monitor with two different devices and also different graphics adapters and supported resolutions.

 

Also, In terms of software/firmware the units are up to date. 

There are some additional steps provided the Windows* that may work for you.

 

I would recommend checking with them for further recommendations, and changes in settings to avoid this situation.

 

In addition, please make sure that you are using the most current version of your operating system.

 

Esteban D.  

Intel Technical Support Technician  

 

0 Kudos
Highlighted
New Contributor I
48 Views

Install Persistent Windows - it should solve the problem. What you describe is an issue Windows has had for years. Persistent Windows runs in the background monitoring window position and size and restores them when the system wakes up from power save/sleep.

 

https://github.com/kangyu-california/PersistentWindows

0 Kudos
Highlighted
Novice
48 Views

Thanks so much. That solved my problem and I appreciate it!