Community
cancel
Showing results for 
Search instead for 
Did you mean: 
EBond1
Beginner
1,060 Views

*Updated: HOW DOES ONE DESELECT UEFI IN ORDER TO BE ABLE TO USE LEGACY BOOT TO INSTALL WIN10 ON AN OS-FREE NUC8I7HNK?

Hi,

 

I purchased a Hades Canyon 8I7HVK with Ubuntu installed. Rather inevitably, a moment came when I realized what a doofus I had been and had to rake the buck for a Windows 10 Home.

 

Made a bootable USB on another Windows-running PC (since the Gparted-made bootable USB that I had initially made on Ubuntu helped me run into Error Code #whateverthatwas during Win10 install) using Media Creation Tool. Things looked promising...

 

...till I started getting some Error Code #somethingelse again and again. Contacted Microsoft support, some dude notified me that I had to de-activate the infamous UEFI and Secure Boot and activate Legacy Boot in order to get rid of that pest.

 

After a few attempts and my realization that UEFI could not be de-activated, I got the suggestion to activate Secure Boot and then try to enter BIOS again and de-activate both Secure Boot and UEFI.

 

So now I am stuck in a point where I cannot access any BIOS to de-activate Secure Boot, while Secure Boot has been charring my eyeballs throwing the good old Windows install-and-fail loop every single time.

 

Please, let me know how I can access BIOS again and de-activate Secure Boot. No F2, F8 or F10 will work.

 

*I guess I should mention that I have erased the Ubuntu partition so my PC is now blissfully OS-free. Hooray.

0 Kudos
2 Replies
EBond1
Beginner
104 Views

Hi, Eugen! Oh, that's me.

Wanted to let you people know that I managed to regain BIOS access with the dedicated .bio file.

HOWEVER, the UEFI issue is here to stay. The bootable USB is FAT32 type, yet I get the razz every time.

And yes, I am fed up with powering on/off the NUC when I get another error code or absence of media device and turning it into a windmill.

n_scott_pearson
Super User Retired Employee
104 Views

In fact, that "dude" at Microsoft was a complete and utter idiot! You absolutely want to have (and, in fact, have to have) UEFI boot enabled and you want to ensure that the O/S is installed in UEFI mode. Important notes:

 

  1. Yes, you will need to disable Secure Boot. Using F2 to enter BIOS Setup (the Visual BIOS UEFI program), click on Advanced, then Boot and then on the Secure Boot tab. After disabling, make sure you save the BIOS configuration during exit from the program.
  2. Create your installation media one of two ways, (a) using the Microsoft Windows Media Creation tool or (b) using a tool like Rufus. I download the ISO file and then use Rufus. I can then specify that the media is to have GPT partitioning for UEFI.
  3. During the Windows installation process, when you get to the scene where you pick the partition to install Windows onto, delete *all* of the existing partitions on the destination drive and then tell the installer to install to the Unused Space on the driver (which should now encompass the whole drive). Deleting all of the exiting partitions will ensure that a GPT partition table will be written on to the drive.

 

Hope this helps,

...S

Reply