Intel® NUCs
Assistance in Intel® NUC products
13309 Discussions

Usb Mouse and Keyboard stop responding DG45ID and Q9400?


hi all,

I just bought a Pc with DG45ID with intel core 2 quad 94000 processor,and HIS ATI 4890 1GB graphic card. I am experiencing following problems

1) Usb Mouse and keyboard do not respond when window xp loads

2) In the bios setup even you dont press a button still the screen saying load some settings appears again and again and i have to cancel it each time.

3) i got 4 Gb RAM on this pc but it is only showing me 2.99 in system properties in windows?

please guys help me


0 Kudos
2 Replies

Hi there,

Could you try to clear the CMOS by removing the motherboard battery and power connector and put them back after about half and hour.

Then after clearing the CMOS, try updating the BIOS to the latest. You may have to use either the iFlash method or the recovery method. Download the latest bios from this link:

FYI: For recovery method you can also use a non-bootable usb containing only the .BIO file will also work. However for the iflash method you will need to have a bootable cd or usb to to it. Please refer to the manual for the full instructions:

However, it could also be an OS issue, if this is possible, can you try re-installing the Windows?

The Memory issue, if you are using Windows XP 32 bit, there is an OS limitation for the use of 4GB memory. You will not have all the 4GB available under 32bit operating system. You may get upto sometimes a bit more. In Windows XP 64 bit or any 64bit operating system, you may have access to your 4GB or more if you have more memory.

Hope this will be helpful,


0 Kudos

First of all thank you very much for your responce.I really appricate it.

Well i tried to clear CMOS as you told me to and got the latest version of BIOS by installing an easy to use utility from intel website.

Also reinstalled the OS i.e windows XP.

What i figured out now is when windows logins the mouse and keyboard are not working. I have multimedia keyboard and its multimedia related buttons do work but not others. and if i change the mouse from one usb port to the other it starts working and keyboard also starts to function. but it seems like the shift button of keyboard is pressed.

Initially i thought there was some prob with mouse and keyboard and i have changed 3 mouse and keybpords but problem is still the same.Do you think i should replace the mother board or you think there is some other prolem?

Thank you unplugged_24

0 Kudos