Intel® NUCs
Support for Intel® NUC products
The Intel sign-in experience has changed to support enhanced security controls. If you sign in, click here for more information.
12771 Discussions

Vlan support for i218-v on Windows 10 Pro


Hello all, 

I had a working setup on my NUC5i3RYK but at some point after an update I suppose it broke. I have installed Windows 10 Pro with HYPER-V enabled and was using Intel PROSet Adapter Configuration Utility to add more vlans. I have installed the latest updates as of today from Windows and Intel drivers but the configuration utility has greyed out the options to add vlans. I tried the powershell module but getting the below

Add-IntelNetVLAN : Failed to add one or more of the specified VLAN IDs.
At line:1 char:1
+ Add-IntelNetVLAN -ParentName "Intel(R) Ethernet Connection (3) I218-V ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : InvalidOperation: (IANet_PhysicalE...ame = "HYPERV"):CimInstance) [Add-IntelNetVLAN], Exception
    + FullyQualifiedErrorId : Error executing cmdlet.,Intel.Network.VLAN.AddIntelNetVlan

What am I doing wrong? 

0 Kudos
3 Replies

Hello Leijona,

Thank you for posting in Intel Ethernet Communities. 

Since your issue is regarding our I218-V embedded on NUC5i3RYK , we need to route this thread to the correct group so you will be better assisted by the proper team.

Please wait for their reply within 1 to 2 business days.

Thank you and stay safe.

Best regards,

Michael L.

Intel® Customer Support


Leijona, Thank you for posting in the Intel® Communities Support.

In reference to your inquiry, just to let you know, the Intel® NUC Kit NUC5i3RYK is under the status of End Of Interactive Support / Discontinued as you can verify in the link below:

So, Intel® technical support will no longer be provided for this kind of product, but perhaps fellow community members have the knowledge to jump in and help. You may also find the Discontinued Products Website helpful to address your request:


Albert R.

Intel Customer Support Technician


Hello all, 

since I didn't find any solution that would solve my problem I turned to the last resort. Re-install Windows!

I installed version 1909 and installed the PROset utility. I was able to add vlans and the applied all available Windows updates. After restarting I had to create the vlans again but at least I was given the option. I have installed the latest version of the Intel NIC drivers too BTW. 


The ethernet adapters created before the update are somewhere there because after upgrading to 20H2 the adapter were again named Ethernet 2, 3 etc and when I tried to rename them to what I wanted the system told me this name is already used.