Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
140 Views

Why won't my Samsung 860 evo 1TB SSD show up on the list of devices when installing windows 10 edu operating system on my 2016 Intel NUC 5CPYH kit?

Good afternoon all!

I was gifted a 2016 Intel NUC 5CPYH kit in December of 2018 and haven't tried to set it up until this week. I purchased and installed a PNY 8GB DDR3 RAM (Part # 64D0JKHNK) and a Samsung evo 860 1TB SATA 6Gb/s V-NAND SSD (Model MZ-76E1T0). I also obtained a product key for windows 10 education through my university. The RAM and SSD were easily connected to the NUC, but unfortunately when I try installing windows 10 edu through my created install USB the setup claims I do not have a storage device installed. I have followed the advice of previous forms and updated my BIOS to the most recent one I could find for my NUC kit (PYBSWCEL.86A), but the SSD still does not show up in devices when I access the BIOS.

 

I have tried finding solutions online, but none of them seem consistent (just started working randomly) or go completely unsolved. Is my SSD not compatible? I read online that some people have no problem with the 860 evo, but maybe I just have an older NUC model that doesn't recognize it? Any advice is appreciated as I have no idea where to go from here, and I really don't want to drop another 100$ on an inferior SSD.

0 Kudos
2 Replies
Highlighted
Super User
99 Views

  1. Well, although the SO DIMM and the SSD are not included on the list validated components for your NUC , it should be no compatibility problem.
  2. Since you updated BIOS and you ca enter BIOS, means that the RAM is working.
  3. Start with setting BIOS to default settings: enter BIOS (F2), press on F9, followed by "Y" and then F10 (Y), to save settings and exit BIOS.
  4. If still your SSD is not recognized, please reinstall the SSD in the Drive Bay and check if the Drive Data and Power connectors are firmly connected. Please see this video first.
  5. Could be that you got bad drive. If you can, connect it to other computer.

 

Leon

 

0 Kudos
Highlighted
Super User Retired Employee
99 Views

Just checking: you have PY BIOS 78 installed, right? That's PYBSWCEL.86A.0078.2019.0807.1133, right?

...S

0 Kudos