Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
481 Views

Windows 10 Hyper-V and AC-9560 160MHz very slow - take 2

Microsoft have investigated the problem described in https://forums.intel.com/s/feed/0D50P00004fusy1SAA and there seem to be a problem with either the driver, hardware or Lenovo's implementation of it.

The problem have been reproduced on a different Lenovo model (X390 Yoga) with the same AC-9560. Also using the latest available Intel drivers for the AC-9560. I do not have access to non-Lenovo hardware with the AC-9560 so I've not been able to test it on other vendors hardware. Are there any firmware updates for the AC-9560 (I've been unable to find any)?

I will open a support case with Lenovo on Monday to get them to investigate the problem.

0 Kudos
11 Replies
Highlighted
Moderator
449 Views

AGreg9, Thank you for posting in the Intel® Communities Support.

 

In order for us to provide the most accurate assistance, we just wanted to confirm a few details about your system:

What is the model of the motherboard?

If this is a laptop, what is the model of it?

What is the model of the Router or Access Point?

Is this a new computer?

Was it working fine before?

Did you make any recent hardware/software changes?

The wireless card, did you purchased it separately or did it came installed in the computer?

When did the issue start?

Which specific Windows* version are you using?

Did you check with your Internet service provider to make sure the Internet is working properly?

Does the problem happen at home or work environment?

 

In reference to your question, all the drivers for the Intel® Wireless-AC 9560 are located in our Intel® Download Center:

https://downloadcenter.intel.com/product/99446/Intel-Wireless-AC-9560

 

Any questions, please let me know.

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
Highlighted
Beginner
449 Views

Hi Albert,

 

It's not a privat computer, but a business computer and I'm working as a system and network engineer and it's the Microsoft Premier support now know as 360 that have been troubleshooting this from their end. We also have network traces done using netsh, that can be provided, but probably not for everyone to access.

 

I've tried it on a Lenovo T490s (20NX - 000EMX) and a Lenovo X390 Yoga (20NN -00FDMX). Also tried a Netgear USB adapter (unknown model) in the T490s which didn't cause any problems. Both computers are new. I have an older Lenovo T470s (20HF-004UMD) with a AC 8265 - which works flawless. It also works if I use a Lenovo USB-Ethernet adapter (no builtin ethernet port).

 

The APs tried upon was both Ubiquiti and Ruckus

 

It have never worked on the Lenovos with the AC-9560 and both computers arrived with the builtin AC-9560.

 

The problem only occurs when trying to use the AC-9560 in a Hyper-V virtual switch - no vm's need to be running (or exist) and it occurs both in the corporate office and in the home office (it's not related to location or what wifi network I'm on) and the Internet connect have been working fine during the issues.

 

The problem have been occuring on both Windows 10 Enterprise 1909 with latest patches and Windows 10 Enterprise 2004 with latest patches. And the following driver versions have been tried

Lenovo 21.80.2.1

Microsoft 21.50.1.1

Intel 21.80.2.1

Intel 21.90.3.2

 

How to reproduce:

  • Install Hyper-V (reboot)
  • Create a virtual switch using the wifi adapter as a network interface (including allow the operating system to share the adapter)
  • Try access a web site (I've been using portal.azure.com as a test) and watch it slowly trying to load the website and at some point time out.

 

Cheers,

Anders

0 Kudos
Highlighted
Moderator
449 Views

Hi AGreg9, Thank you very much for providing that information

 

You mentioned, the problem only occurs when trying to use the Intel® Wireless-AC 9560 card in a Hyper-V virtual switch, if you use the computer on a physical switch, router or access point is the problem the same?

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
Highlighted
Beginner
449 Views

Hi Albert,

 

If the computer is physically connected to say a switch and I use the AC 9560 in a virtual switch there is no problem. There is only a problem when the AC 9560 the only active network interface (which is the case 99% of the time - otherwise having a laptop didn't really make sense)

 

Cheers,

Anders

0 Kudos
Highlighted
Moderator
449 Views

AGreg9, Thank you very much for letting us know those details.

 

Please provide the SSU report for both computers so we can verify further details about the components in them, to attach the report, once you choose "reply" select the "clip" icon on the lower-left corner:

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...

 

In the following link you will find the Advanced Intel® Wireless Adapter Settings in order to try the following troubleshooting steps:

https://www.intel.com/content/www/us/en/support/articles/000005585/network-and-i-o/wireless-networki...

 

  • Change the Wireless Mode or HT Mode to "HT mode or 802.11n only, then "VHT mode or 802.11ac only" and after that to 802.11ax only to confirm if the behavior is the same with all 3 modes. 
  • Test different bands, only the 5Ghz band and then the 2.4GHZ band only 
  • Change the channel width from "Auto" to "20 MHz"
  • Disable Fast BSS Transition Roaming
  • Do you have the option to connect the computer to another network/Router/AP?
  • Are you using a VPN connection? Do you have the option to disable it and test if the behavior is the same?
  • For testing purposes, disconnect all other devices connected to the Router and test just your computer connected to it, to verify if the issue persists that way.
  • Sometimes there is a firmware update available for the Router, did you check with the manufacturer of it to verify if that is the case for this unit in order to install it?

 

Regards,

Albert R.

 

Intel Customer Support Technician

A Contingent Worker at Intel

0 Kudos
Highlighted
Community Manager
446 Views

Hello AGreg9, I just wanted to check if you saw the information posted previously and if you need further assistance on this matter?


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


0 Kudos
Highlighted
430 Views

Hello AGreg9, Since I have not heard back from you, we are closing the case, but if you have any additional questions, just reply back or post a new question.


Regards,

Albert R.


Intel Customer Support Technician

A Contingent Worker at Intel


0 Kudos
Highlighted
Beginner
422 Views

Hi Albert,

Sorry for the delayed response - Intel decided to make the forums readony for at few days - so I couldn't respond.

In reponse to your questions and the result surprised me.

======================

Change the Wireless Mode or HT Mode to "HT mode or 802.11n only, then "VHT mode or 802.11ac only" and after that to 802.11ax only to confirm if the behavior is the same with all 3 modes.

5GHz Ubiquti (latest firmware)

Wireless Mode: 802.11n only - same problem

Wireless Mode: 802.11ac only - same problem

Wireless Mode: 802.11ax only - not an option in device settings

Wireless Mode: Disabled - problem gone (I assume it reverts to 802.11a/b/g)

 

Change the channel width from "Auto" to "20 MHz"

Wireless Mode: 802.11ac only - same problem

Wireless Mode: 802.11n only - a bit slower than normal - but works

 

 

2.4GHz Ubiquti (latest firmware)

Wireless Mode: 802.11n only - same problem

Wireless Mode: 802.11ac only - same problem

Wireless Mode: 802.11ax only - not an option in device settings

Wireless Mode: Disabled - problem gone

 

Disable Fast BSS Transition Roaming

Can't find that option in the device properties

 

Do you have the option to connect the computer to another network/Router/AP?

Yes, I'll test that tomorrow in the office.

 

Are you using a VPN connection? Do you have the option to disable it and test if the behavior is the same?

I'm not using a VPN

 

For comparison:

Intel AC-8265 using Wireless Mode: 802.11ac and channel width = Auto works fine on the same wifi network (Ubiquiti) at the same time that the AC-9560 doesn't work.

 

I've attached the sso for my laptop. Did you want a ssu report from the older machine that worked or the other model with ac9560 that didn't work?

0 Kudos
Highlighted
Beginner
409 Views

I've tested it as well at the company office. And it's the same result (although the AP's are locked to 20MHz channel width).

Cheers,

 Anders

0 Kudos
Highlighted
Beginner
398 Views

Hi AGreg9

I encountered the same problem.

Please try to change the following parameters.

 MIMO Power Save Mode : Auto SMPS -> Static SMPS

Highlighted
Beginner
393 Views

Hi Zaqw,

Changing MIMO Power Save Mode from "Auto SMPS" to "Static SMPS" does indeed make it work as some of the other tests above. But with this setting the connection is a bit unrealiable - RDP sessions are disconnected.

I tried the other settings as well and only "Static SMPS" works.

But to me it seems there is something wrong with either Intels driver or Lenovos implementation of the AC-9560 since other Intel wifi adapters/chips works fine in the same environment with the default setting. So for me it's both getting my machine working as intended and get Intel/Lenovo to fix the root cause.

Cheers,

 Anders

0 Kudos