Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FK000
Novice
3,191 Views

Wireless AC 8265 & AX 200 sets the incorrect regulatory domain

Jump to solution

First off, this issue is the same as

https://forums.intel.com/s/question/0D50P00004VggYA/wireless-ac-9260-regulatory-lardrs-breaks-5ghz-f...

 

as reported by @User15740198994512119537

 

Issue occurs in Windows 10 (Latest) and Linux but can be rectified in Linux.

 

The issue is that the Intel Wi-Fi drivers incorrectly set the regulatory domain to ID (Indonesia) while I am currently in Pakistan. This results in only the following channels being allowed:

iw reg get global country US: DFS-FCC (2402 - 2472 @ 40), (N/A, 30), (N/A) (5170 - 5250 @ 80), (N/A, 23), (N/A), AUTO-BW (5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW (5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS (5735 - 5835 @ 80), (N/A, 30), (N/A) (57240 - 71000 @ 2160), (N/A, 40), (N/A) phy#0 (self-managed) country ID: DFS-UNSET (2402 - 2437 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-80MHZ, NO-160MHZ (2422 - 2462 @ 40), (6, 22), (N/A), AUTO-BW, NO-80MHZ, NO-160MHZ (2447 - 2482 @ 40), (6, 22), (N/A), AUTO-BW, NO-HT40PLUS, NO-80MHZ, NO-160MHZ (5735 - 5815 @ 20), (6, 22), (N/A), AUTO-BW, NO-HT40MINUS, NO-HT40PLUS, NO-80MHZ, NO-160MHZ

 

 

My country allows channels 149-161 @ 80 Mhz.

This can easily be fixed by disabling "LAR" aka Location Aware Regulatory in Linux using `iwlwifi.lar_disable=Y`

 

There is no such option in Windows. Because of this, while all my devices connect to 5Ghz channel 149 @ 80MHz (867 Mbps, MIMO 2x2), this Laptop connects at a 20 Mhz resulting in extremely slow speeds (173.3Mbps negotiated instead of 867Mbps).

 

I would like to request that either LAR be disabled or be allowed to be disabled for users. I'm sure that there are a lot of other people facing the same problem but it is neither easy to diagnose nor is it easy to notice.

1 Solution
Wanner_G_Intel
Moderator
2,365 Views

Hello FK000,

 

Thank you for your response.

 

It seems that there is not a method we can recommend to disable Location Aware Regulatory in Windows* 10. However, based on the information provided and your original request, we are going to document your feedback and send it over to the appropriate team for review. It is worth mentioning that we cannot guarantee that this request is going to be implemented.

 

In this scenario, our recommendation is that you check the Region and Home location options in Windows* and modify them if applicable.

 

Now, performing wireless integrations is subject to country-specific legal regulations and it may impact your system's performance. Before and after installing or changing the Intel® Wireless Adapter, Intel recommends contacting the system manufacturer to obtain approval, step-by-step instructions, and support. Some countries require the Intel® Wireless Adapters to be certified with the antenna that is intended to be used together in the system, while some countries require the Intel® Wireless Adapter to be certified at the full system level.

 

For more information, please refer to the Regulatory Information Regarding Wireless Hardware Installation or Upgrade

 

Having said that, we also recommend that you contact your Original Equipment Manufacturer (OEM) to make sure the wireless upgrade is not impacting the performance of the system and check if the Intel® Wireless Adapter is in your OEM's hardware compatibility list for this computer.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

View solution in original post

14 Replies
2,365 Views

I hope your able to make more progress than I did, dont be surprised though if you get a blanket response like I got "contact your laptop manufacturer" :man_facepalming:

 

[quote]" I'm sure that there are a lot of other people facing the same problem but it is neither easy to diagnose nor is it easy to notice."[/quote]

right, it's not something the average user would notice or even find any info on whatsoever. I get the purpose of why LAR exists but not having a way to disable it on windows when it causes problems is not so great. currently i'm left with using a spare router I had laying around setup as a wireless bridge and run a short lan cable from whenever I use windows, it goes without saying that I should not need to do this.

 

intel please add a way of disabling LAR or forcing the correct regulatory domain to the windows driver.

FK000
Novice
2,365 Views

What I don't understand is that how is the driver detecting both of us to be in Indonesia when we are so far apart.

 

PS, which laptop are you using and where did you buy your Intel Wi-Fi chip from?

2,365 Views

im using a dell inspiron 15-7559 and a 9260 dual band ac adapter. i've also confirmed this behavior happens with intel 8265 (8265NGW) and also happens with the original dell OEM intel wireless ac dual-band 3165 (3165NGW) adapter. this problem i've also seen from many users regardless of location, even when im able to get the card to detect "country US: DFS-FCC" it will also show "country ID: DFS-UNSET" just below it on `iw reg get` output and it disables all the channels i should available to me here in the US. i dont live near any radar stations and every non-intel device i own does not have this problem.

 

i noticed this problem began after i installed win10 for a few apps/games that are windows only, after a major windows update i was no longer able to see any 5ghz channel below 149 and the channel width needs to be locked to 20mhz at the router otherwise it will not see/recognize any 5ghz access point. i've spent months on this trying every single thing i could possibly think of including removing both SSD's, installing the original ssd and the original 3165 wireless adapter and doing a fresh install of win10 after resetting bios and still this happens. im using linux 90% of the time and im able to easily get a full 1733Mbit/s link speed rx/tx at 160mhz (80+80) width. on windows im stuck with 2.4ghz thus leaving me having to setup a second router wireless bridge so i can run a lan cable from that bridged router and i should not have to.

 

what puzzles me more is how a windows installation effects a linux installation, so far not a single person has been able to answer that and trying to find competent windows users to help with this is damn near impossible (i've tried). i'll leave this links here for you to check out seeing as now since every 5.4 kernel i've tested iwlwifi will not work if `lar_disable=Y` is used. same for 5.5 kernel

 

recent bug report where talks of removing `lar_disable` from the iwlwifi driver that i think you should comment about and try to stop this from happening.

https://bugzilla.kernel.org/show_bug.cgi?id=205695

 

related microsoft tech net thread/s (no help provided)

https://social.technet.microsoft.com/Forums/en-US/d8d8a480-7cce-42ee-bca6-538736efaa75/regulatory-do...

https://social.technet.microsoft.com/Forums/en-US/80957105-23b2-40d0-af52-c9b03df3e237/windows-10-an...

 

for years i've always recommend intel adapters for the reason they were well supported on both windows and linux but lately i cant do that and as much as i dont want to it's looking like going elsewhere for wireless adapters is becoming more and more of a necessity. in a perfect world LAR is a great feature especially for travelers but when it fails to work properly there is nothing the end user can do about it, especially if they remove `lar_disable` functionality. come on intel, you can do better than this.😒

 

2,365 Views

additional logs and info to show whats going on with LAR

additional supporting logs.

 

##

with no option other than enabling debug (lar_disable=0)

`dmesg|grep -i iwl`

https://pastebin.com/uZdptEHb

 

`iwlist chan`

https://pastebin.com/8wQZZp1L

 

`iw reg get`

 https://pastebin.com/FuziP013

 

 lar detects US like it should and then goes on to detect "ID" indonesia which

 disables all 5ghz channels except 149-161 and only at 20mhz width.

 

 

##

with debug and lar_disable=1 

 

`dmesg|grep -i iwl`

https://pastebin.com/PMcHrxMP

 

`iwlist chan`

https://pastebin.com/W4HKKwYE

 

`iw reg get`

https://pastebin.com/8wQZZp1L

 

with lar_disable, everything works as it should. only US is detected and my channels 

dont get crippled.

FK000
Novice
2,365 Views

Thanks. Hopefully we can get an Intel engineer to look​ at it. I'm not adept at linux so you'll have to take over the technical side :)

Wanner_G_Intel
Moderator
2,365 Views

Hello FK000,

 

Thank you for submitting your question on this Intel® Community.

 

To better assist you, we would like to have more information about your system configuration.

 

  • When did you start experiencing this problem? Was it after a Windows* or driver update?
  • If you roll back to a specific driver version, does the issue persist?
  • Please let us know if the computers came with the Intel® Wireless Adapter preinstalled.
  • Generate a system report with the Intel® System Support Utility (Intel® SSU) on one of your systems and attach it to this thread.

 

  1. Intel® SSU Download link
  2. Open the application and click on "Scan" to see the system and device information. By default, Intel® SSU will take you to the "Summary View".
  3. Click on the menu where it says "Summary" to change to "Detailed View".
  4. To save your scan, click on "Next", then "Save".

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

FK000
Novice
2,365 Views
  • When did you start experiencing this problem? Was it after a Windows* or driver update?

It was probably after a Windows update as it was working fine one day at 867 Mbps and after a restart it got stuck at 173Mbps (20Mhz). This happened some time in Early december.

  • If you roll back to a specific driver version, does the issue persist?

It persists after a driver roll back. I've tried 1-2-3 year old drivers but it doesn't fix it. It persists after a Windows reinstall but I haven't tried an older version of Windows 10. I'm on the latest updated installation of windows.

  • Please let us know if the computers came with the Intel® Wireless Adapter preinstalled.

It comes with the Intel AC8265 preinstalled. That is the adapter that first got stuck at 173Mbps max. As a last resort I decided to swap it with an AX200 which I currently have. The problem persists.

  • Generate a system report with the Intel® System Support Utility (Intel® SSU) on one of your systems and attach it to this thread.

SSU attached.

 

 

I would just like to say that this is a major bug in the drivers/ and or a combination of windows and drivers which is causing the LAR (Location aware regulatory) to set the incorrect domain/ locale. It detects me to be in Indonesia while I am currently in Pakistan. This probably affects a LOT of users but it just hasn't blown up yet. Please fix it before it does.

 

As a test case, I set up another router (NETGEAR R6700) to broadcast 5Ghz at channel 44.   This channel is not allowed in Indonesia.   What happens is that after windows boots up, it shows the NETGEAR 5G SSID for a few seconds. If I try connecting to it, it says that it cannot be connected to. The SSID then disappears and doesn't reappear.   So, apparently, LAR is inactive while Windows is starting but is enabled automatically after a short window.

 

 

Wanner_G_Intel
Moderator
2,366 Views

Hello FK000,

 

Thank you for your response.

 

It seems that there is not a method we can recommend to disable Location Aware Regulatory in Windows* 10. However, based on the information provided and your original request, we are going to document your feedback and send it over to the appropriate team for review. It is worth mentioning that we cannot guarantee that this request is going to be implemented.

 

In this scenario, our recommendation is that you check the Region and Home location options in Windows* and modify them if applicable.

 

Now, performing wireless integrations is subject to country-specific legal regulations and it may impact your system's performance. Before and after installing or changing the Intel® Wireless Adapter, Intel recommends contacting the system manufacturer to obtain approval, step-by-step instructions, and support. Some countries require the Intel® Wireless Adapters to be certified with the antenna that is intended to be used together in the system, while some countries require the Intel® Wireless Adapter to be certified at the full system level.

 

For more information, please refer to the Regulatory Information Regarding Wireless Hardware Installation or Upgrade

 

Having said that, we also recommend that you contact your Original Equipment Manufacturer (OEM) to make sure the wireless upgrade is not impacting the performance of the system and check if the Intel® Wireless Adapter is in your OEM's hardware compatibility list for this computer.

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

View solution in original post

FK000
Novice
2,365 Views

As i said, I was using the pre installed AC 8265 for over 3 years​ before this started happening.

This is clearly a windows or driver issue.

If you can't even acknowledge that an issue exists, i will just have to stop using the product in question and recommend the same to future buyers.

FK000
Novice
2,365 Views
2,365 Views

even on linux most users are unaware of what LAR even is, myself included until i wasted months trying everything under the sun to fix it. what i've noticed is that every person i've come across with this issue was dual booting windows/linux when it started. it seems like once the driver disables the channels in windows it carries over into linux installs and as much as that sounds like nonsense it's exactly what happened. i flashed 3 different bios versions, removed windows and linux drives each time and ran a clean install of windows 10 on an extra ssd i had right after and still the problem persists.

 

have a look at this bug report on kernel.org, talk of removing the `lar_disable` functionality from `iwlwifi` linux driver.

https://bugzilla.kernel.org/show_bug.cgi?id=205695

Luca Coelho 2019-12-16 19:38:52 UTC Why are you normally disabling LAR? This is an old parameter that was used only when LAR was still under development. I'll actually remove it from the driver now, since the end-users are not supposed to disable it.   This bug may not be directly related to LAR, though, but related to something in the number of channels or something like, so I won't close this bug yet.

 

and to make things worse if not bad enough already, i went looking for a non-intel wireless adapter and apparently intel is the only m.2 pcie adapter that would fit in my laptop. this problem may not be 100% intel's fault but whatever is causing the issue is doing so because of an intel technology.

 

Location Aware Regulatory in theory is a great idea if it worked properly, but when it fails to do what it's suppose to do as it so clearly has, Intel not having any way of fixing the issue or simply refusing to help long time intel customers disable this failed technology is negligence. every mention of this issue is met with the same ineffective procedure of rolling back windows, clean install of drivers, etc... and i've done this and so much more for many hours, weeks, months without a solution.

 

Intel could easily fix this issue, if LAR can be disabled via a iwlwifi module option in linux then there is a way of disabling it via firmware/drivers in windows. some other wifi adapters allow you to select what region your in right from advanced settings so the excuse of legality concerns from intel about giving users the ability to disable LAR so that intel customers are not forced to avoid intel adapters and/or need to spend additional money on devices from another manufacturer.

 

up until this issue began i was very happy with intel everything but the nature of this issue and the way it's been handled is unacceptable. this forum may not be filled with "LAR is broken" threads but how many of those unresolved "5ghz wifi wont work", or "cant see/connect to 5ghz ap's", etc... that could be attributed to LAR disabling every channel except for world wide (global) acceptable channels and all of which are limited to 20mhz ?? the problem is already bigger than just a few regulatory domain related threads but most users dont even know what regdom even is let alone determine it's a possible cause.

 

intel can do better than this.

Wanner_G_Intel
Moderator
2,365 Views

Hello all, 

 

We have documented your feedback. It is highly appreciated. However, we cannot guarantee that this request is going to be implemented.

 

Our recommendation is that you also report this issue to your system manufacturer to obtain additional information about the system configuration you are currently using.

 

Regards,

 

Wanner G.

Intel Customer Support Technician

A Contingent Worker at Intel

FK000
Novice
2,365 Views

Please stop treating this like a feature request.

This is a bug that needs urgent fixing as it breaks functionality.​

FK000
Novice
2,365 Views

Bought a new Lenovo L340 laptop and the problem persists on it as well. Can't get over 173Mbps on 5Ghz AC. Any update on this  @WannerG_Intel​ 

Reply