Intel® NUCs
Assistance in Intel® NUC products
13309 Discussions

XMP RAM Not Running Full Speed on NUC12DCMv9




I have a new Dragon Canyon i9 that doesn't run Intel validated RAM at full advertised XMP speeds.

I originally bought 2x16GB stick of the CL18 F4-3200C18D-32GRS set, specifically because Intel lists this ram as "validated" with XMP listed. When booted, the RAM always has a CL of 24 if you can manage to get it to run at full speed. This is with the XMP profile selected. Manually bumping up voltage from 1.2 for this set does nothing.

I figured the RAM just didn't work and ordered Mushkin Redline 1.35V CL 16 RAM. MRA4S320GJJM32GX2 to try.

Exact same issue -- lowest I can get is CL20 with the XMP profile. One JEDEC profile works at CL 18 (again, not the true CL16) but downclocks the ram to something like 1300mhz.

I tried all four options in the BIOS for RAM settings (auto, spd, xmp 1/2), as well as manually changing the RAM voltage to 1.35V. For some reason you can't manually select RAM timings in the BIOS even though they show up in the UI. I tried the second set of entirely different ram. Second set isn't validated by Intel, but as previously proven the validation doesn't seem to mean anything. Latest drivers, latest windows 11 updates. Reset bios to defaults, etc. Nothing left to toggle.

Latest BIOS EDADL579, latest Windows 11 updates, latest Intel drivers.


Anything else to do before returning this? Seems like the firmware was released not quite ready...

0 Kudos
1 Reply

Also, when calling 916-377-7000 for support, I get "the number is not in service". Only message board and chat support is available.

0 Kudos