Intel® NUCs
Support for Intel® NUC products
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11981 Discussions

nuc8i5- Bluetooth keyboard issue- enumerator code 39.

mjons
New Contributor I
495 Views

So, im using logitech dinovo edge\k810 on a nuc 8 with Intel® Wireless-AC 9560.
after a restart the bluetooth enumerator gets the code 39 and cannot load the driver.
Then have to run the bluetooth troubleshooter to fix it.

The keyboard vanishes from latest bt connected devices. So also have to repair it.

Anyone can point me to a solution to this issue? its either come frome win 10 updates or bt drivers updates. I tried rolling back some drivers, but issue is persistent.

win 10 21h1 19043.1110

 

Input

 


Keyboard HID Keyboard Device
Keyboard Logitech HID-Compliant Keyboard
Keyboard Logitech HID-compliant Unifying keyboard
Keyboard Logitech HID-compliant Unifying keyboard
Keyboard Microsoft eHome MCIR 109 Keyboard
Keyboard Microsoft eHome MCIR Keyboard
Keyboard Microsoft eHome Remote Control Keyboard keys
Mouse HID-compliant mouse
Mouse HID-compliant mouse
Mouse Logitech HID-compliant Bluetooth Touchpad
Mouse Logitech HID-compliant Unifying Mouse
Mouse Logitech HID-compliant Unifying Mouse

 

image (1).jpg

 

 

0 Kudos
4 Replies
n_scott_pearson
Super User Retired Employee
483 Views

I had this problem, though not on a one of the NUCs. I had a AX200 module in a PCIe card carrier. I had to run the Bluetooth Troubleshooter every time I rebooted. I finally fixed this problem by doing a clean install of the WLAN packages. Here is the process that I used:

  1. If you haven't already, download - but do not install just yet - the latest Bluetooth and WiFi drivers for your adapter. Here are links to these drivers: https://downloadcenter.intel.com/download/30542  and https://downloadcenter.intel.com/download/30584
  2. Disable Internet access. Unplug Ethernet cable and/or disable wireless. Keep disabled until told to re-enable.
  3. From the Apps & Features applet, check for instances of Intel PROSet/Wireless Software and Intel Wireless Bluetooth. If none, skip to Step 6.
  4. Uninstall each instance of Intel PROSet/Wireless Software and Intel Wireless Bluetooth that is present. When prompted, choose to "Discard Settings".
  5. Manually reboot your computer, keeping Internet access disabled throughout.
  6. From the Device Manager applet, check the Network Adapters section for an entry for Intel Wi-Fi 6 AX200 and check the Bluetooth section for an entry for Intel Wireless Bluetooth that has an intel driver associated with it. If neither is the case, go to Step 10.
  7. Right click on the entry for Intel Wi-Fi 6 AX200 and uninstall it, choosing to (checkmark) Delete the driver software for this device.
  8. Right click on the entry for Intel Wireless Bluetooth and open its properties. If it has an Intel driver associated with it, then uninstall it, choosing to (checkmark) Delete the driver software for this device.
  9. Go to Step 5.
  10. (Optional but recommended) Clean out all temporary files using the Windows Clean Disk tool. I recommend that you checkmark all categories offered, even if no files currently (so it leaves it set up for next invocation).
  11. (Optional but recommended) Clear each of your browsers' cache.
  12. Install the Bluetooth driver package (my rule: always do Bluetooth first).
  13. Install the Wireless driver package.
  14. Manually shutdown and reboot your computer.
  15. Enable Internet access.
  16. Test.

Hope this helps,

...S

mjons
New Contributor I
432 Views

Thanks for the reply. But the bt driver seems to install with this issue. 

I turned off the router so I was offline.

Followed these steps until only an old driver was on the WiFi card, could not remove it completely.

But bt was under other devices and no driver. Installed the bt package from Intel for nuc 8. I watched it install in device manager with code 39.

So, still stuck it seems

 

really dont want to reinstall win for this

 

attached ssu

n_scott_pearson
Super User Retired Employee
400 Views
Keep looping until the driver is completely gone. I have seen this take as many at 10 cycles to clear it out.
...S
mjons
New Contributor I
391 Views

tried another thing.

Deleted the LowerFilters registry  for the bluetooth enumerator, and now survived two reboots without error. But have my doubts

 

I did delete the wifi driver 10 times, but it always came back with and old driver. No problem with the bluetooth.

Reply