Community
cancel
Showing results for 
Search instead for 
Did you mean: 
filt3rek
New Contributor I
209 Views

nuc8i5bek LEDs

Hej !

I've a nuc8i5bek and I want to manage the LEDs but the only way I found is in the BIOS and there is no way to turn them off.
I want to turn off all LEDs when I put the nec on stand by, because it's like christmas tree the power led blinks and the network LEDs also blink it drives me crazy... 
Who is the super engineer that decided that it's cool to have these LEDs blink when the nuc is off please ?!
I'll stop here my message because I don't want to be too rude.

Thanks in advance for your answer.

0 Kudos
8 Replies
n_scott_pearson
Super User Retired Employee
200 Views

This is occurring because of the use of Modern Standby instead of Sleep. If you switch to the use of S3 in BIOS, I believe that the LEDs will be off while Sleeping. Note that, AFAIK, changing from Modern Standby to S3 Sleep unfortunately requires the reinstall of Windows 10 (Leon may know a way around this).
...S
filt3rek
New Contributor I
191 Views

Hi,

Thanks for your fast answer !
In fact I have a Dual Boot with Win 10 and Debian 10.
But it's strange why changing something like that in BIOS would impact on the OS please ?

LeonWaksman
Super User
186 Views

I don't know about Linux, however if you change from Modern Standby to Legacy S3 Standby the Windows will be probably corrupted. The way to overcome this problem is to set Windows to SAFE mode boot, before changing the sleep mode in BIOS. I did this few times in both directions.

 

Leon

 

filt3rek
New Contributor I
179 Views

Hi Leon,

Thanks for your answer.

I've been in the BIOS and I already was on Legacy S3 Stand By and when I put the NUC on Stand By by pressing the On/Off button, It blinks and network LEDs blink also...
I really don't know what to do.

Another thing is that I have 2 screens, one HDMI and another VGA through USB-C and even if I tell the 1st GPU adapter to be HDMI and second thunderbolt, in Win 10, the 1st screen is the USB-C and 2nd HDMI... Why there is options in the BIOS to set it when it is not taken in account ?!
That's could be all, but no, sometimes my 1st screen doesn't run, sometimes it does, and even when booting sometimes the 1st screen resolution is dirty, sometimes no...
But I'll create another thread for this question...

I'm very disappointed with this NUC, it's a crap...

LeonWaksman
Super User
170 Views

Hi,

I don't have NUC BE to test this but reading Visual BIOS Glossary brings me to the conclusion, that you  should be able to switch OFF the Power LED during sleep (S3) state:

In BIOS Advanced > Power > Secondary Power Settings set the Button LED to Power State Indicator and set the S3 Indicator Brightness to "0

In order to disable the network LED, disable the Wake on LAN from S4/S5 also in Advanced > Power > Secondary Power Settings

Hope this works

Leon

 

filt3rek
New Contributor I
165 Views

Thanks again Leon,

Putting brightness to 0% works fine but that's pitty because when the NUC is on the LED is off.
It would be good to have an option only when the NUC is in Stand By...


I can't understand why manufacturers think for years (because I had the same with a Tower before) that it is a good idea to have all lights on even when the computer is in Stand By... They bring a super option so you can set up a % of brightness because it's really important to switch between 21% or 14% light, but you cannot simply switch it off while Stand By.................
Anyway, I'll do like that...in 2021, with IA, flying cars soon and so on we still must do tricks like that because of some shiny ideas of high engineers... If some of them could stuck their head in a wall...


And for the network LEDs, I already had disabled Wake Up LAN before thinking like you that it would work but it doesn't. Here the same, what a shiny idea to have LAN LEDs on when the computer is in Stand By... I'm missing words about all that and I'll stop here, my english is too poor to play with sarcasm...

But I really apreciate your attention Leon and Scott.
Regards,
Michal

LeonWaksman
Super User
153 Views

Hi Michal,

I think I have solution for you how to switch OFF the Network LED:

In the Network Adapter Configuration >Advanced set the Wake on Magic Packet to Disabled and in the Power Management tab, uncheck the Allow this device to wake the computer. See the attached video clip. It worked in my NUC8i7HVK.

Leon

 

filt3rek
New Contributor I
147 Views

Leon,

Many thanks again for your attention.

Yes, you're right, I haven't though about this possibility, especially because I'm on Linux and there are not this kind of user-firendly interface like on Windows.

And yes your solution works fine for Windows.

I share here the solution for Linux users, maybe it can help some people (so I'll not be seen as the guy that only know how criticize XD...)


Here's for Debian 10 but it should work also for others distrib :

-This command will display the status on Wake On Lan in your Linux distrib : 

ethtool eth0 | grep Wake

(if eth0 is the network device on the computer)


-If ethtool doesn't exists, you can, of course, install it with

sudo apt-get install ethtool


-If you don't know the real name of the network device (or if eth0 is renamed by the system and it can't find eth0), you can get the real name with this command : 

dmesg | grep eth0

(again, if eth0 is the network device on the computer)


-Then to disable the WOL use this command : 

ethtool -s eth0 wol d


Hope it helps Linux users.

Thanks again Leon,
Regards

Tags (1)
Reply