Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,565 Views

unable to install UHD graphics driver for nuc7pjyh2

Hi,

I just bought the latest nuc7pjyh ( which is marked as a nuc7pjyh2) for my daughter and I am struggling with the installment of the graphics drivers.

I downloaded the following driverset:

For https://downloadcenter.intel.com/product/126137/Intel-NUC-Kit-NUC7PJYH Intel® NUC Kit NUC7PJYH

Intel® UHD Graphics Driver for Windows® 10 for Intel® NUC Kit NUC7CJY, NUC7PJY

Version: 24.20.100.6025 (Latest) Date: 5/7/2018

When I try to install this driver it gives me an error telling me that the chipset is not supported.

I tried another version on the same driver page version: https://downloadcenter.intel.com/download/27593/NUCs-Intel-UHD-Graphics-Driver-for-Windows-10-for-In... 15.65.4.4944 but this also gives me the same error message.

So far I am unable to install the driver which prevents my daughter to use her computer.

Also the tool that automatically updates the drivers doensn't recognize the chipset.

Is this because of the version 2 NUC (european version?)

Please help.....

Tags (1)
0 Kudos
9 Replies
Highlighted
Super User Retired Employee
98 Views

No, it isn't because of the European product code. This product code is used for ordering this NUC, not for system identification. For system-level software, the name for the board is used to identify the product (in your case, it is NUC7PJYB; in my case, it is NUC7CJYB). For graphics driver installation, the system-level and board-level information is actually not pertinent; it is the processor and chipset device identification that is important.

Ok, how to move forward? First of all, you should have already,

  1. Upgraded to the latest BIOS (v42, available here: https://downloadcenter.intel.com/download/28014/BIOS-Update-JYGLKCPX-86A-?product=126136 Download BIOS Update [JYGLKCPX.86A]).
  2. Installed these processor and chipset (SoC) related software/driver packages:
    1. https://downloadcenter.intel.com/download/27464/Intel-Chipset-Device-Software-for-Intel-NUC-Kit-NUC7... Intel® Chipset Device Software for Intel® NUC Kit NUC7CJY, NUC7PJY.
    2. https://downloadcenter.intel.com/download/27502/Intel-Trusted-Execution-Engine-Intel-TXE-Driver-for-... Intel® Trusted Execution Engine (Intel® TXE) Driver for Intel® NUC Kit NUC7CJY, NUC7PJY.
    3. https://downloadcenter.intel.com/download/27501/NUCs-Intel-Serial-IO-Driver-for-Intel-NUC-Kit-NUC7CJ... Intel® Serial IO Driver for Intel® NUC Kit NUC7CJY, NUC7PJY.
    4. (Optional but recommended) https://downloadcenter.intel.com/download/27118/NUCs-Intel-Software-Guard-Extensions-Intel-SGX-for-I... Intel® Software Guard Extensions (Intel® SGX) for Intel® NUC

       

  3. Have rebooted at least once since doing so.

I recommend you try installing using the latest version (24.20.100.6194) of the Intel HD Graphics driver package: https://downloadcenter.intel.com/download/27892/Intel-Graphics-Driver-for-Windows-10 Download Intel® Graphics Driver for Windows® 10 (this is what I am running on my NUC7CJY).

Hope this helps,

...S

Highlighted
Beginner
98 Views

Hi Scott,

Thank you for helping me.

I upgraded to bios version 42 and re-installed (with the opted reboots) the mentioned drivers.

After that I tried the graphics driver you suggested, but unfortuntely this one also tells me that the chipset is not supported.

After that I contacted the chat and was helped by Luis from the support department.

He took over my computer and tried everything I allready tried and came to the conclusion that it had to be because I updated my bios version straight to the latest version and not by stepping each version.

So I had to downgrade to the lowest version and upgrade set by step and reinstall the drivers.

This is what I did next and I'm about 1.5 hours further into the night now and still have the same problem.

Anyone have any other options?

0 Kudos
Highlighted
Super User Retired Employee
98 Views

I suggest that, once you have BIOS 42 installed, you install it again using the BIOS Recovery Method.

My additional input on this process is as follows:

  1. Use a small USB 2.0 flash disk if at all possible. Some issues exist with the BIOS Recovery engine recognizing some USB 3.0 flash disks.
  2. On a Windows-based PC (i.e. NOT Linux and NOT MacOS), reformat your USB flash drive with the FAT32 file system, with the Quick option disabled.
  3. Place file JY0042.BIO - and only file JY0042.BIO - onto this USB flash disk.
  4. If doing this on a separate PC, make sure you properly eject the USB flash disk (i.e. do not just yank it out). If you are doing on the NUC itself, on the other hand, a simple shutdown will suffice.
  5. Follow the BIOS Recovery process documented here: http://www.intel.com/content/www/us/en/support/boards-and-kits/000005532.html?wapkw=bios+recovery Intel NUC BIOS Recovery Update Instructions.
  6. After this completes and you power back on, press the F2 key, over and over, until the Visual BIOS display is presented.
  7. Press F9 (followed by Y) to reset the BIOS configuration.
  8. Press F10 (followed by Y) to save this configuration and reboot.

If the BIOS Recovery operation fails (i.e. you do not see screen displaying progress and message saying completed) or the driver will not install after you boot into Windows, do the following:

  1. Shutdown the NUC.
  2. Make sure the USB flash disk is inserted into one of the USB ports.
  3. Power on and immediately start hitting the F2 key, over and over, until the Visual BIOS display is presented.
  4. Click on the right arrow at the right-hand edge of the screen. This should get you to the BIOS string display.
  5. Click on the Camera icon.
  6. Select the entire screen.
  7. Save to the USB flash disk using file name like "Capture.bmp".
  8. Include this picture in your response (use the Insert Image button).

...S

0 Kudos
Highlighted
Beginner
98 Views

ok, I used the recovery bios upgrade to version 42 again.

Everything is working, except it still displays the error chipset is not supported when I try to install the graphics driver.

I'm thinking about reinstalling the OS from scratch to see if that helps.

edit: completely reinstalled the windows10 and installed the neccessary drivers one by one rebooting in between like suggested.

No other programs installed except for the drivers.

It still tells me that the chipset is not suported.

I'm wondering if it is possible that they upgraded or changed the chipset and the drivers are not updated yet?

This is nuts......

edit 2:

I think I found why it is not working.

according to a hardware info site my nuc has a UHD605 graphics onboard.

In the release notes of the graphics driver DRIVER VERSION: 24.20.100.6025 this chipset in not listed and thus not supported?

So basically I need a graphics driver that supports UHD605 chipset, right?

0 Kudos
Highlighted
Super User Retired Employee
98 Views

You already installed the chipset software package before you tried the graphics driver? You are remembering to install it As-Administrator?

No, this is the right driver package. I have already installed it (and its successors) without issue.

The "chipset" (such as it is) is actually built into the processor. This is an integrated, system on a chip (SOC) package, so there is (supposedly) no chance of a mismatch.

Please get the capture of the BIOS setting I requested. As well, a summary report from a tool like HWiNFO64 would be beneficial.

...S

0 Kudos
Highlighted
Beginner
98 Views

Hi Scott,

thank you for the help.

I did not read I had to install it as-Administrator, so far it worked for the other drivers, but I can always try.

When I get home from work tonight I will capture the bios settings and create a summary report with the tool you suggested.

edit:

bios image

edit2 :

hwinfo64 report

edit3:

running the graphics driver installer as administrator also gives the same error.

0 Kudos
Highlighted
Beginner
98 Views

The problem is solved. The root cause was the version and build of the operating system. My daughter's school provided me with a win10 education version which was too old for the driver. At the advice of intel support I tried installing the oldest graphic driver but that one was also too new to install correctly. I replaced the OS by the latest build and all drivers are installed without any problem. Thank you Scott and Luis for the help.

0 Kudos
Highlighted
Super User Retired Employee
98 Views

Roy,

Before anything else, please provide updates in separate posts. When you edit in updates like this, we do not get any notice of this change and could miss it completely.

Ok, I looked at the BIOS output and at the HWiNFO64 report, but do not see anything that would highlight an issue.

You mentioned earlier that you reinstalled Windows 10. Did you do this before or after you reinstalled the BIOS using the Recovery Method? If this was after, you can skip the remainder of this paragraph. If this was before - and I hate to have to ask this, but - could you reinstall the O/S again? As you are doing so, when you get to the scene where you pick the drive and partition on which to install Windows, please delete all existing partitions on the drive and then tell windows to install to the unpartitioned space.

If you get to here and the driver will still not install, I am out of ideas. If you cannot return the unit to your place of purchase and get a replacement, you may need to contact Intel Customer Support directly and ask them to replace the unit. Here is contact information, by geography:

http://www.intel.com/content/www/us/en/support/contact-support.html# @11 Intel Customer Support Contact Information for US and Canada

http://www.intel.com/content/www/us/en/support/contact-support/emea-contact.html Intel Customer Support Contact Information for Europe, Middle East and Africa

http://www.intel.com/content/www/us/en/support/contact-support/apac-contact.html Intel Customer Support Contact Information for Asia-Pacific

http://www.intel.la/content/www/xl/es/support/contact-support/lar-contact.html Intel Customer Support Contact Information for Latin America

You can also use the http://intelsupportchat.force.com/icslivechat/ics_tech_desktop_ww_english_Chat Intel Customer Support Chat Service, but it is offered in English only and is subject to office hours (9-5 M-F) in the Pacific time zone.

...S

0 Kudos
Highlighted
Beginner
98 Views

Hi Scott,

I did the reinstallment of the OS after the reinstallment of the BIOS recovery method.The way you describe to install on an unpartitioned disk is my way to perform a clean install.

It turned out that the OS build version was too old for the driver.

The oldest driver was still giving me problems.

I replaced the OS ( in that case win10 education), by a newer win 10 version.

Everything works like a charm now.

Thanks for helping me a lot !

0 Kudos