Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MNeug
Novice
2,947 Views

very poor graphics performance; Ubuntu 16.04 LTS

Hi,

I have a problem with playing videos. I'm not sure if this is related to hardware, drivers, the OS (Ubuntu 16.04 LTS) or a combination of those. The videos are stuttering and when the "camera" is moving vertically or horizontally (but not in and out, i. e. zoom) I get vertical breaks or glitches in the video's frames, as if the image was put together in parts of three or four, seperately. So, videos are unwatchable. So far I've tried Netflix and Youtube. Video quality doesn't matter, the glitches and the stuttering are present in 360p videos, too. Neither does the browser (used Firefox and Chromium). I also tried a YT video offline via VLC -> same thing. I'm not really sure but it feels like I can see these glitches in other non video apps, too. For example, whenn I scroll through a list of installed apps in Ubuntu Software.

Also, Firefox is extremely slow in general. Scrolling through pages is a pain in the ***. Less on pages like search results (I use DuckDuckGo) and very bad when there are lots of video thumbnails like Youtube or Netflix.

I use a LG27UD58 4K UHD monitor, connected via HDMI. I have 8 GB of RAM installed, could this be the cause? More memory needed?

0 Kudos
11 Replies
MNeug
Novice
650 Views

I wrote vertical glitches. I meant horizontal, sorry.

idata
Community Manager
650 Views

Hello mngb72,

 

 

Thank you for contacting Intel Support,

 

 

I understand that you are having video issues in your system, I apologize for any inconveniences this may be causing.

 

 

Regarding this problem, in order to be able to find the best solution for the problem we actually require the model of the unit that is causing the problem. This way we can attempt to find a solution.

 

 

 

Regards,

 

David V
DPurv
Beginner
650 Views

I don't have a solution but I do have some data points.

I'm running OpenSUSE 42.3 on a 4k TV (via HDMI) on a NUC7i5BNH.

(I previously had a NUC7i3BNH with roughly similar results.)

I'm running the latest BIOS, have 4GB of memory and a 1TB

hard disk (non-SSD). I normally run at 4k 60Hz.

I don't have the tearing problems that you are having. I get fine

video playing performance for low resolution, either over 'net or

off hard disk, even up to 1080p. At 1080p there might be

an occasional glitch, but I certainly wouldn't call it unwatchable.

However, playing 4k videos (off disk, or from a RAM buffer)

exhibits poor video playback.

To my eye, it looks like it's putting out maybe 4 frames per second.

The CPU monitor says the CPU is pegged. The disk is NOT the

bottleneck, as I can set up an A-B loop over a small section of

video and run out of RAM with the same poor frame rate.

Sorry I can't be of much help, but hopefully this will

give you a jumping off point. Run a memory usage monitor

while you are running the videos to tell you whether you need

more memory or not. I strongly doubt it is the problem.

MNeug
Novice
650 Views

The model is a NUC6i7KYK. RAM is Crucial 8GB DDR3 2133 MHz SO-DIMM. SSD is Crucial MX300 275GB M.2.

@david675

Thanks for your response. You have already helped me put a name to the issue I struggled to describe (at least one of the two), since english is only my second language: screen tearing.

From my own research I now think it is related to the nomodeset boot option of my Ubuntu. This may prevent the OS from loading the proper graphics driver. I've read on other forums about people with nVidia cards having this problem. Booting without nomodeset results in not getting to the system because the monitor disconnects from the NUC (see this thread: ). So I cannot test this hypothesis.

Other things I noticed from my system's display settings:

- Built-In-Display instead of my LG monitor

- display resolution not changeable

- changing the "scale for menu and title bars" has no effect.

idata
Community Manager
650 Views

Hello mngb72,

 

 

Thank you for your response,

 

 

Upon review and research I was able to find a few things. First off, the NUC6i7KYK actually has not been tested by Intel® with Ubuntu so there are no updates for that Operating System as you can see here:

 

 

https://www.intel.com/content/www/us/en/support/articles/000005628/mini-pcs.html

 

 

The device was tested and reported to work with Ubuntu by other customers, If you need assistance with Linux* on Intel NUC, check your distributor's website and forums for peer assistance.

 

 

Also, I was able to find a forum that should be able to assist you with your problems which is the following:

 

 

https://01.org/

 

 

In this community you will receive any possible solution when it comes to Intel®-related products and Linux distributions.

 

 

 

I hope you find this information helpful.

 

 

 

Regards,

 

David V
MNeug
Novice
650 Views

Hello DavidV,

unfortunately this doesn't help much.I already knew the validation status of my NUC. I already asked in Ubuntu forums but as of now haven't gotten any helpful responses.

As to your 01.org link: I only see mailing lists and IRCs, no actual forum. And everything seems to be project specific. How do I choose the correct project for my issue? Nothing there means anything to me.

DPurv
Beginner
650 Views

Hi mngb72,

It would be a useful data point if you could install the latest version of Ubuntu,

which I think is 17.10. I know 16.04 is the newest LTS, but maybe (just maybe)

the newer version will help. Or are you wed to Ubuntu? Maybe another distro

has better performance? OpenSUSE is not working perfectly for me, but it's a heck

of a lot better than Ubuntu is working for you. You wouldn't even necessarily have

to install it, just get a bootable image, put it on a flash drive, and boot it. Your

symptoms should be visible in the installer or just booted off the flash drive, I would think.

I know what you mean about 01.org that Intel support is pushing. Here is another

link from Intel support that was more useful to me...

https://01.org/linuxgraphics/downloads https://01.org/linuxgraphics/downloads

still no forum, but it seems like this is a repository of latest and greatest drivers,

and they're working on (and beyond) the problems you are having, so possibly

there is a useful fix in there. But you have to know how to pick the right driver

and how to bind it into your kernel, issues I'm working on (slowly) at my end for

my own purposes.

One final thought...before I bought my NUC I was googling around and found a

company that sold turnkey NUCs with Linux pre-installed. I can't seem to find them

now, but if you stumble across it, they *might* offer non-customers support, or perhaps

a bootable CD image. Good luck.

MNeug
Novice
650 Views

I am certainly going to try 17.10 again this weekend. But I started with 17.10 and had the same problem (disconnected monitor without nomodeset boot option). Using nomodeset in 17.10 will prevent the intel drivers from loading there, too.

Tied to Ubuntu? No, certainly not. I'd only like to stay with the NUC (coming from an iMac I didn't want a tower again.) and some form of Linux - preferably suitable for some multimedia and used by a large enough number of people to get answers in a reasonable timeframe.

>But you have to know how to pick the right driver and how to bind it into your kernel

Yeah, well ... not me.

I found ZaReason and System76 as companies that sell NUCs with preinstalled Linux. Was it one of them?

edit

I found this thread on askubuntu.com: https://askubuntu.com/questions/913201/ubuntu-not-installing-on-intel-nuc-6i7kyk boot - Ubuntu not installing on intel NUC 6i7KYK - Ask Ubuntu . That's exactly my problem, with the exception that he is able to use his Ubuntu without the intel drivers (he obviously has nomodeset permanently active), while I'm not.

However, I can't comment to ask (not enough reputation on askubuntu.com). Answering is not an option either, because not actually providing a solution to the original question is considered spam and will be deleted. They are very restrictive.

edit2

I looked into the downloads on 01.org and the latest stack recipe is actually validated on the 6i7KYK (https://01.org/linuxgraphics/downloads/2017q3-intel-graphics-stack-recipe https://01.org/linuxgraphics/downloads/2017q3-intel-graphics-stack-recipe ). Unfortunately I have no idea how to install this.

edit3

I just ran the Intel Graphics Update Tool for Linux OS and there were even some updates to be done ... but to no avail. Still disconnecting monitor when I remove the nomodeset option.

DPurv
Beginner
650 Views

I hadn't stumbled across ZaReason or System76, but if their support answers

email or the phone, you're one step forward.

Tthe company I had previously found: https://www.simplynuc.com/core-i7-gen-7-tall-h-nuc-system-nuc7i7bnh/ simplynuc.com/

I don't see how it could hurt to try contacting any of them.

Two additional thoughts: any chance you can try another monitor?

I have two 4k TV's, and one is a lot better at sync'ing with sources than

the other. The other thought was: how long did you wait for the monitor

after it "disconnected"? My poorly-syncing TV can take minutes to get out

of its blue-screen loop, but will (sometimes) finally sync up. Pressing relevant

buttons on the remote (Input, Source, Status, Display, Menu, etc) sometimes

snaps it out of its re-sync cycle. Or power-cycle it. Or boot past the point

that it disconnects with the monitor off or unplugged, then hot plug it in.

I'm guessing you've already tried most of that. Other choice is to get

an active displayport to hdmi (or something else) converter. what other

inputs does the monitor have? Do you have access to a store that permits

30-day returns or somesuch, so you could try without being out money if

it doesn't work?

I'm about out of ideas. I will be looking at the graphics-stack installation over

the next days or weeks (it's not my top priority) because I'd love to see really

good video performance on my box, and that's my best hope at the present.

Just another learning opportunity!

Edit: Having studied the 01.org stuff more, I now understand from your "edit3"

that you used the 01.org "Update Tool for Linux" which should have upgraded

all of your graphics drivers to the latest and greatest ones, which eliminates your

need to figure out how to install the stuff you talk about in your "edit2". So...

mission accomplished. Unfortunately, not "problem solved". Sorry to hear it.

Edit2: The more I'm learning about this the more it looks like a hardware incompatibility.

All of the performance problems can be explained by nomodeset, I think, which turns

off all hardware support for graphics by forcing the driver to run in "stupid" mode.

So why do you need nomodeset? Some incompatbility with that particular monitor,

or possibly just a broken NUC or broken TV or broken or insufficient cable.

That said, I stumbled across possible replacement for nomodeset: fastboot

Basically it reduces the number of modeset operations during booting. Sounds

promising for you, eh? You have to know how to add/change kernel parameters

on the boot command line, but if you're playing with nomodeset, you probably already

know that. So give "i915.fastboot=1" a try. Also see...

https://www.phoronix.com/scan.php?page=news_item&px=Intel-Fastboot-Hopefully-Final https://www.phoronix.com/scan.php?page=news_item&px=Intel-Fastboot-Hopefully-Final

https://help.ubuntu.com/community/BootOptions BootOptions - Community Help Wiki

MNeug
Novice
650 Views

Yes, I was aware that the nomodeset option causes all this. And no, the monitor does not miraculously wake up after a longer period. I tried that already (one of the first things, actually). The monitor being the culprit is implausible because it works just fine when I use nomodeset. And it is not just the sync, the temperature/fan goes up even wehen changing tabs in Firefox or opening a new app. The NUC does not have DP, HDMI only.

Unfortunately no, I do not know how to add the fastboot option.

Thank you for your efforts, but I think I'm going to replace the NUC. I even found something similar from a company in my country. The graphics chip doesn't compare that well, but it is completely silent due to passive cooling. And it is shipped with tested hardware and with preinstalled and tested Ubuntu 17.10. Too bad I hadn't found it earlier, even without my troubles it seems like the better option to me. http://www.cirrus7.com/mini-desktop/cirrus7-nimbus-v2.html cirrus7 nimbus v2 - mini-pc

DPurv
Beginner
650 Views

Ok, good luck with your new product.

And by the way, your English is very good. You have no need

to apologize for it!

Reply