Community
cancel
Showing results for 
Search instead for 
Did you mean: 
AChan73
Beginner
2,103 Views

Intel optane no longer detected by BIOs when RST Pcie Storage Remapping is enabled

Several months ago I built a new PC using optane to accelerate my hard drive. It was a massive headache to get it to work, but I finally managed it.

Recently I had to reinstall windows because of software issues. The new windows install works completely fine but when I tried to reinstall the optane software it said my BIOs didn't support optane. I checked my BIOs settings and saw that the SATA mode was somehow switched back to AHCI.

I switched the SATA mode to RST and rebooted, however my system would no longer detect the optane M.2 module (the M.2 slot is listed as empty in BIOs). I found that disabling M2_1 - RST Pcie Storage Remapping allows my BIOs to detect the optane module in my M.2 slot, however as I understand it I need to enable remapping to use optane.

So basically, in RST mode my BIOs will not detect the optane module in my M.2 slot unless RST Pcie Storage Remapping is disabled. optane module also properly shows up in the M.2 slot if the SATA mode is AHCI, but optane will only work when windows is installed with the SATA mode set as RST.

Anyway, I re-installed windows a second time, this time with RST as the SATA mode. However, I can't install optane because it's not detected unless I disable storage remapping, which is required for optane to work.

Bear in mind the motherboard is using the latest version of its BIOs, and optane WAS working properly on it before I reinstalled windows. It's an AsRock z270 ITX/ac board.

Does anyone know what the solution for this problem is? Thank you.

0 Kudos
4 Replies
idata
Community Manager
221 Views

Hello WaffleKing,

 

 

Thanks for posting.

 

 

Based on the description of the issue, it seems like the Intel® Optane™ memory wasn't disabled before reinstalling the operating system. The memory might still be associated with the previous installation, which explains why it's not showing up.

 

 

In order to fix it, please disable Intel® Optane™ from the UEFI BIOS. This is done from the Intel® RST (Rapid Storage Technology) menu, usually located at the advanced tab.

 

 

Please bear in mind that BIOS menus vary depending on the motherboard model. You may want to engage the motherboard manufacturer for guidance.

 

 

Once disabled, you should be able to enable it again from the setup application.

 

 

Please let us know the results.

 

 

Best regards,

 

Eugenio F.
idata
Community Manager
221 Views

Hello WaffleKing,

 

 

We're just checking on this thread.

 

 

Did you have the chance to disable Intel® Optane™ from BIOS?

 

 

Best regards,

 

Eugenio F.
AChan73
Beginner
221 Views

Hi, it took me a few days to get it working; apparently if I use the "Intel Rapid Storage Technology" software suite instead of just the Optane software, it will detect the optane module in windows even though it doesn't show up in the BIOS. This seems to get optane to work, as confirmed by diskmark.

Thank you for your assistance.

idata
Community Manager
221 Views

Hello WaffleKing,

 

 

Thanks for sharing the solution. It is good to know you successfully enabled Intel® Optane™ on your system.

 

 

Please let us know if anything else is required.

 

 

Best regards,

 

Eugenio F.
Reply