Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LSoko1
Beginner
3,366 Views

System bios configuration is not compatible with intel optane. But I have a motherboard with built in Optane.

I have the gigabyte z370 aorus ultra gaming wifi-op motherboard that came with optane.

I installed every driver that came with the motherboard from the CD disk and still I'm unable to run the setup. I have the newest windows updates and all up to date drivers everywhere (It's a new PC).

So how to install & enable Optane memory?

0 Kudos
7 Replies
idata
Community Manager
577 Views

Hi SunLe,

 

 

Thank you for posting in the Intel® communities.

 

 

I understand that you are having issues setting up the Intel® Optane™ Memory, but in order to help you with the setup process I need additional information.

 

 

Could you please download the Intel® System Support Utility (SSU) from the following link and run the full report? Please save the report in a file and attach it in your next response: https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-

 

 

Additionally, please take a screenshot of the Disk Management window. To open Disk Management, press the Windows* key + x and select the Disk Management option from the menu that will appear.

 

 

Still in Disk Management, please right click on each disk and select Properties. Then, go to the Volumes tab and take a screenshot of the information there. Please do this for each disk you have in your system.

 

 

Finally, it'd be useful if you can take screenshots from the BIOS settings that you have changed so that I can have a better understanding. You can take screenshots of the BIOS by pressing F12 or the Print Screen button. You will require a USB Flash memory connected because the images are saved there automatically. Please refer to this site for additional details about this: http://www.unboxingtreatment.com/2018/04/howto-take-screenshot-motherboard-bios.html

 

 

I'll be waiting for your response.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
LSoko1
Beginner
577 Views

Hello Diego V.

Thanks for helping. I have done what you asked for and will replay in two messages because I have more than five attachments.I hope I took the pictures and if not, please reply I'll provide a new ones. Again thanks for helping!

LSoko1
Beginner
577 Views

Bios pictures:

idata
Community Manager
577 Views

Hi SunLe,

 

 

Thank you for the information.

 

 

There are several things that must be properly configured in your system in order to use the Intel® Optane™ Memory.

 

 

The first thing is that your system must be set to UEFI mode. It's currently set to Legacy mode which will make impossible to set the module up. The reason why your system is in Legacy mode is because the BIOS is set to Legacy, but also because of the partition style used in your drives which is MBR.

 

 

All your drives must be set to GPT instead of MBR in order to use the module, so this may be the first step we can do. You will have to change the partition style from MBR to GPT in all your drives. Before doing this, please remove the Intel® Optane™ Memory. Once everything is properly configured you can add it again.

 

 

My recommendation for proper configuration would be to re-install Windows*, however there is another way to convert the drives from MBR to GPT. Windows* includes a tool called MBR2GPT.EXE that can be used for the conversion.

 

 

The process of using MBR2GPT.EXE is described in the following Microsoft* article: https://docs.microsoft.com/en-us/windows/deployment/mbr-to-gpt

 

 

There are some examples at the end of the article, but basically, the command that you have to run from the Command Prompt as Administrator is the following:

 

 

mbr2gpt.exe /convert /disk:1 /allowfullOS

 

 

The command above should be applied to each drive because all of them should be set to GPT. To apply the command to the other drives, just change the disk index accordingly, for example and based on the screenshots provided, your Samsung* drive is the disk 1, your Games drive is the disk 3 and so on. This will change if you remove the Intel® Optane™ Memory so check again which index is assigned to each drive after removing the Intel® Optane™ Memory.

 

 

Once you convert the drives, you will have to change some settings in BIOS, otherwise the system may not boot properly because the BIOS will remain configured to Legacy mode.

 

 

To change the BIOS to UEFI and also to properly configure it for the Intel® Optane™ usage, please follow the information from your motherboard's manufacturer: https://www.gigabyte.com/MicroSite/454/intel-optane-ready.html

 

 

In summary, the BIOS settings that you have to configure are the following:

 

  1. CSM Support: Disabled
  2. SATA Mode Selection: Intel RST Premium with Intel Optane System Acceleration
  3. Use RST Legacy OROM: Disabled
  4. PCIe Storage Dev On Port # : RST Controlled

 

Once this BIOS settings have been configured, boot your system and confirm if your drives are in GPT and the system is in UEFI mode This can be checked by running again the Intel® SSU report and by checking the Volumes tab from Disk Management.

 

 

Note: If you have not updated the BIOS firmware yet, I recommend you to do so following the instructions from your motherboard's manufacturer.

 

 

Additionally, and this is why my recommendation is to re-install Windows* OS, you need to reserve some space at the end of the booting drive for the module to work properly. This space should be at least 5MB of unallocated space just as it's described in the following guide (page 5). If this space is not available in your drive, the module won't work: https://www.intel.com/content/dam/support/us/en/documents/memory-and-storage/optane-memory/intel-opt...

 

 

My recommendation is to re-install Windows* from scratch because you can reserve that unallocated space at the end of the drive during the installation process, and install the OS in the drive using GPT instead of MBR, so everything would be set at once as long as you have configured the BIOS first as mentioned above. If you would like to follow this way, make sure to back up your data before as this will delete the information in your booting drive.

 

 

Finally, another observation is that in order to accelerate a secondary drive, the drive should be a data drive only, the drive must not have any OS installed. If I'm not mistaken, your Data drive has an OS installed. Please check the requirements for secondary drive acceleration in this article: https://www.intel.com/content/www/us/en/support/articles/000027987/memory-and-storage.html

 

 

There are many settings you have to configure to have the module up and running. Please check and understand all this information and let me know if you have any doubts.

 

 

If you have any issues, please take screenshots as it would be easier for me to understand you and therefore to properly setup the module.

 

 

Have a nice day.

 

 

Regards,

 

Diego V.
LSoko1
Beginner
577 Views

Hello Diego V.

So in conclusion

I need to change the system to UEFI mode.

Unplug the Optane module Before changing my drives from MBR to GPT.

Plug in the Optane module

Reinstall windows.

Change the following bios settings :

CSM Support: Disabled

SATA Mode Selection: Intel RST Premium with Intel Optane System Acceleration

Use RST Legacy OROM: Disabled

PCIe Storage Dev On Port # : RST Controlled

idata
Community Manager
577 Views

Hi SunLe,

 

 

That's correct, but I recommend you to plug in the Intel® Optane™ Memory again after the Windows* re-installation.

 

 

Remember to reserve the unallocated space at the end of the drive during the installation.

 

 

I'll be waiting for your results.

 

 

Regards,

 

Diego V.
LSoko1
Beginner
577 Views

Hello Diego V.

Everything is now working thanks for helping!