Intel® Optimized AI Frameworks
Get community support for questions related to PyTorch* and TensorFlow* frameworks.
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
54 Discussions

Errors when installing Tensoflow with base kit (and solution)

AdamMiltonBarker
1,035 Views

Hi everyone.

I have recently been working on a new version of one of our projects using the oneAPI basekit.  I installed the base kit fine, however when I came to install Tensorflow I was met with the following. (I was expecting Tensorflow to already be installed with the basekit.

Basekit was installed with apt.

WARNING: The scripts pyrsa-decrypt, pyrsa-encrypt, pyrsa-keygen, pyrsa-priv2pub, pyrsa-sign and pyrsa-verify are installed in '/home/nuci71/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The scripts f2py, f2py3 and f2py3.7 are installed in '/home/nuci71/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The script markdown_py is installed in '/home/nuci71/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The script google-oauthlib-tool is installed in '/home/nuci71/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The script tensorboard is installed in '/home/nuci71/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
WARNING: The scripts estimator_ckpt_converter, import_pb_to_tensorboard, saved_model_cli, tensorboard, tf_upgrade_v2, tflite_convert, toco and toco_from_protos are installed in '/home/nuci71/.local/bin' which is not on PATH.
Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts.
scikit-ipp 1.2.0 requires intel-openmp, which is not installed.
scikit-ipp 1.2.0 requires ipp, which is not installed.

 

The fix was easy obviously, ipp needs installing prior to intel-openmp and adding the paths is easy but to avoid extra steps for end users maybe you could take care of this during installation of basekit, or would you say that this is tensorflow specific, I would expect it to be handled during installation.

 

This has been tested with the same result on multiple machines. 

0 Kudos
7 Replies
AdamMiltonBarker
1,031 Views

From the output when initializing oneAPI it seems that IPP is installed with the basekit however I had to install it after installing oneAPI.

nuc.JPG

AbhishekD_Intel
Moderator
998 Views

Hi,


Thanks for reaching out to us. 

The Intel oneAPI Basetoolkit doesn't come with pre-installed TensorFlow.

You could use Intel AI Analytics toolkit if you need pre-installed TensorFlow.

Please refer to the below article for more details.

https://software.intel.com/content/www/us/en/develop/articles/intel-optimization-for-tensorflow-inst...


Also please share with us the exact command that you have used while installing the TensorFlow so as to get more insight into your issue.



Warm Regards,

Abhishek


AdamMiltonBarker
992 Views

Hi thanks for the reply, AI Analytics pre installed Tensorflow does not work without installing manually either, I raised an additional bug about it here: https://community.intel.com/t5/Intel-DevCloud/Environment-initialized-no-module-named-torch-or-tenso... 

 

I installed Tensorflow with pip install tensorflow==2.5.0 The article you linked to does not include the latest version of Tensorflow I have tested multiple times and it always installs Tensorflow MKL which has TF version 2.3.0, I have that installation on a different machine using conda and it does work. This issue is related to installing the latest version of Tensorflow with oneAPI basekit installed. 

 

Best.

AlekhyaV_Intel
Moderator
951 Views

Hi Adam,

 

The pip install issue which you're observing are due to package conflicts of tensorflow and the pre-installed packages in oneAPI base toolkit environment. The workaround for this error would be to create a new conda environment and to install tensorflow and all the required packages in that particular environment. 

 

conda create -n tf python=3.6 {tf -> <env_name>}

conda activate tf

pip install intel-tensorflow==2.5.0

To check the version of tensorflow that you've installed, open a python shell

import tensorflow as tf

tf.__version__

 

An alternative option would be installing oneAPI AI toolkit which comes pre package with multiple environments with tensorflow environment. We could see one of your queries in Intel Optimized AI frameworks forum where you've already installed AI toolkit. Please refer this documentation for installation: https://software.intel.com/content/www/us/en/develop/tools/oneapi/ai-analytics-toolkit/download.html...

 

Regards,

Alekhya

 

AlekhyaV_Intel
Moderator
883 Views

Hi,


Is your issue resolved? Can we discontinue monitoring this thread?


Regards,

Alekhya


AdamMiltonBarker
862 Views

Hi I think the thread has been misunderstood, each of the bugs I raised recently in the forums were to point out issues not get help. Thanks to everyone that did offer help but the point was to notify you of these issues. From my side sure you can stop monitoring.  

AlekhyaV_Intel
Moderator
842 Views

Hi Adam,


Thank you for sharing all your observations with us. We have shared all your suggestions with the admin team. And we will discontinue monitoring this thread now. If you need further assistance, please submit a new question.


Regards,

Alekhya


Reply