Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
15549 Discussions

ASE Simulation Syntax Error(?)

KAkyo
Beginner
1,314 Views

Hello,

 

I am trying to run ASE simulation for AAL application (which is an on-going project, cannot switch to OPAE right now). When I "make" the simulation side, once it worked and started to wait for the software part. However when I tried to run it again, entered the command "make", it gave strange errors that I cannot understand. I am pretty sure that I used the same environment variables.

 

---------------------------------------------

-- Compiling module twentynm_iopll_ip

-- Compiling module altera_iopll_rotation_lcells

-- Compiling module altera_pll_dps_lcell_comb

-- Compiling module iopll_bootstrap

-- Compiling package ccis_if_pkg

-- Compiling package ccis_if_funcs_pkg

-- Importing package ccis_if_pkg

-- Compiling package ccip_if_funcs_pkg

-- Importing package ccip_if_pkg

** Error: (vlog-13069) ** while parsing file included at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-mpf-if/cci_mpf_if_pkg.sv(21)

** at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-mpf-if/cci_mpf_platform.vh(139): near "**": syntax error, unexpected **, expecting class.

** Error: ** while parsing file included at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-mpf-if/cci_mpf_if_pkg.sv(21)

** at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-if/cci_csr_if_pkg.sv(6): (vlog-13006) Could not find the package (cci_mpf_if_pkg). Design read will continue, but expect a cascade of errors after this failure. Furthermore if you experience a vopt-7 error immediately before this error then please check the package names or the library search paths on the command line.

** Error: (vlog-13069) ** while parsing file included at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-mpf-if/cci_mpf_if_pkg.sv(21)

** at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-if/cci_csr_if_pkg.sv(12): near "r": syntax error, unexpected IDENTIFIER, expecting ')'.

** Error: (vlog-13069) ** while parsing file included at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-mpf-if/cci_mpf_if_pkg.sv(21)

** at /export/fpga/bbb/src/intel-fpga-bbb-20181101/BBB_cci_mpf/hw/sim/../rtl/cci-if/cci_csr_if_pkg.sv(23): near "r": syntax error, unexpected IDENTIFIER, expecting ')'.

-----------------------------------------------

There are 193 errors and they are all similar. I tried to access another node, however it still remains in the same node which is "vsl003".

 

Can you please help me with this problem.

Thank you in advance.

Kaan Akyol

0 Kudos
2 Replies
Nooraini_Y_Intel
Employee
158 Views

​​Hi,

 

Currently I am reviewing the forum for any open questions and found this thread. I apologize that no one seems to answer this question that you posted. Since it has been a while you posted this question, I'm wondering if you have found the answer? If not, please let me know, I will try to assign/find someone to assist you. Please do expect some delay in response as most of our agents are out of office due to the year-end holidays. Thank you.

 

Regards,

Nooraini

MuhammadAr_U_Intel
158 Views

Hi,

 

This Error seems like Modelsim can't recognize the syntax did you tried to look at the codes pointed in Error message ?

How is the simulation scripts generated, is the correct command used for compilation like "-sv" switch for system verilog code.

 

You may refer to my reply in another thread related to AAL.

https://forums.intel.com/s/question/0D70P000006AK9NSAW

 

Reply