Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
149 Views

Adding Support for DE5-Net

Jump to solution

Hello,

 

I got a DE5-Net gifted from Intel and want to start using it. Unfortunately my Quartus 18.1 doesn't support it. I've tried installing several versions of Quartus and the installation goes fine. However, in the end it always turns out that my device (Stratix V GX 5SGXEA7N2F45C2) isn't valid.

I don't use the Quartus IDE because I compile/synthesise from the command line and do same for blasting, so I don't need much support. I'd be delighted if these was a way to add my Stratix V GX 5SGXEA7N2F45C2 to the list of supported devices of my Quartus 18.1 installation. Is there a way to do this?

If not, I'd appreciate if you could let me know which Quartus version to install and how to add Stratix V GX 5SGXEA7N2F45C2 to the list of supported devices.

FWIW I have a set of DVDs but I haven't been able to install them because of problems with libraries.

Thanks in advance for your help.

Regards,

 

PdP

0 Kudos

Accepted Solutions
Highlighted
Novice
64 Views

Problem solved. I had selected the wrong Family...

View solution in original post

0 Kudos
9 Replies
Highlighted
Valued Contributor I
136 Views

Well, if Intel 'gifted' the DE5-Net to you I would go back to them and ask for the version of Quartus that supports that Stratix device. Probably need a licensed Quartus version as that is a high-end FPGA.

0 Kudos
Highlighted
Novice
131 Views

Thanks. There aren't any instructions with the box I got. To the best of my knowledge I installed things properly and installed a proper licence. Then again, I may have made a mistake. I just want to make sure I'm doing things right.

 

Regards,

 

PdP

0 Kudos
Highlighted
Novice
122 Views

FYI I also installed Quartus Lite 20.1.00 as this is supposed to support my device.

Quartus Prime Design Software
Version 20.1.0 Build 711 06/05/2020 SJ Lite Edition
Copyright (C) 2020 Intel Corporation. All rights reserved.

When I ran it I told it where to find the licence file and I noticed the following error: 14565 Can't connect to the Intel FPGA website to check for updates. (Not sure if the error is related.)

Regards,

 

PdP

0 Kudos
Highlighted
110 Views

You can go to this link and Select by Device to check the latest Quartus version supported. 
Download Center for FPGAs 

As you can see, the latest Quartus version supported for Stratix V (GS/GT/GX/E) is Quartus Standard version 20.1. Hope it helps. 

Highlighted
Novice
109 Views

Yesterday I reinstalled quartus 20.1 and regenerated the licence file on the Intel website. I saved the new license file, which was sent to me by emai and I reconfigured the LM_LICENSE_FILE environment variable.The environment variable was exported (export LM_LICENSE_FILE) in my .bashrc file and I logged out and in again. I then started quartus, making sure the license file details were correct. 

When I created a new (empty) project with the New Project Wizard, the device I needed (5SGXEA7N2F45C2) was not among the list of devices for the Stratix V family. In fact, the list of available devices became empty after I typed 5S.

 

PdP

0 Kudos
Highlighted
Novice
108 Views

Thanks but the DE5-Net brochure tells me the device number is 5SGXEA7N2F45C2 and that's not on the list of supported devices. Which device shuold I select?

0 Kudos
Highlighted
Novice
87 Views

I've just wasted another day (downloading alone took a solid 8 hours) installing the 20.1 standard edition. When I created an empty project with the New Project Wizard, the device I've mentioned in most of my previous posts was not on the list.

Please, please. please tell me what I'm doing wrong.

0 Kudos
Highlighted
Novice
84 Views

FWIW I' have the beginner tag but I've been using the software for 5 years plus. I've installed it on several machines. I think I know what I'm doing.

The only problem I can see is the name of the device I am supposed to pick. My brochure tells me it is supposed to be Stratix V GX 5SGXEA7N2F45C2 but that's not on the list. Quartus shows me several members of the Stratix V family (e.g.  5CGXFC7C7F23C8) but I can't see the name that's on my brochure...

0 Kudos
Highlighted
Novice
65 Views

Problem solved. I had selected the wrong Family...

View solution in original post

0 Kudos