Intel® Quartus® Prime Software
Intel® Quartus® Prime Design Software, Design Entry, Synthesis, Simulation, Verification, Timing Analysis, System Design (Platform Designer, formerly Qsys)
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
14943 Discussions

Altera Pll error message. (Error: WTH!!!/n while executing "parse_tcl_data)

Altera_Forum
Honored Contributor I
1,091 Views

https://alteraforum.com/forum/attachment.php?attachmentid=14980&stc=1 I am trying to create a 1kHz output using cascaded clocks.  

 

I however get this error message in both 17.0 and 17.1. 

 

Error: WTH!!!/n while executing "parse_tcl_data $rule_name $reference_list" (procedure "my_set_rbc_check" line 21) invoked from within "my_set_rbc_check OUTPUT_CLOCK_FREQUENCY $param_args" (procedure "get_advanced_pll_legality_solved_legal_pll_values" line 21) invoked from within "get_advanced_pll_legality_solved_legal_pll_values $device_part $ref_clk [get_parameter_value output_clock_frequency$val] $fractional_vco_multiplier $c..." (procedure "validation_callback" line 264) invoked from within "validation_callback" 

 

Here is what I have setup.  

Any advice appreciated! 

https://alteraforum.com/forum/attachment.php?attachmentid=14980&stc=1  

Thankshttps://alteraforum.com/forum/attachment.php?attachmentid=14980&stc=1
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
84 Views

It's impossible to read the screenshots you've taken, but my guess would be that you've selected incompatible parameter settings.

Altera_Forum
Honored Contributor I
84 Views

Yeah.  

I chose to actually use 100Mhz and play with settings till I got errors to go away.  

 

I ended up having to multiply and divide off 100Mhz clock and string out 5 divide by 10's to actually get it to compile.  

 

Divide by M with a Multiply N of 1 didn't seem to ever want to work.  

 

I just played with M/N and multiple C's to get something to not error.  

 

N of 1 didn't want to ever work. 

Top frequency of 50Mhz didn't really want to work either.  

 

Thanks for the reply.
Reply