Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
3,748 Views

Block Diagram Display Issue

Hi, I am an engineering student running the Quartus Prime Lite edition for work in my digital logic design class. I'm enjoying the program on my desktop but I'm having some display issues on my laptop that I haven't been able to resolve. For some reason when I'm working on block diagrams the images and fonts are not scaling properly, leaving everything an unreadable mess. I've attached a picture for reference. I've spent a great deal of time searching online and through settings menus and changing font sizes to no avail. Any advice at this point would be greatly appreciated! 

 

System details: 

 

Windows 10 

Quartus Prime 17.0 lite edition 

Intel Integrated Graphics (no separate card) 

Screen Resolution 2560 X 1440 

14" Screen
0 Kudos
12 Replies
Altera_Forum
Honored Contributor I
1,180 Views

Hi, 

 

You can go to tools -> options -> block/symbols editor -> fonts -> reset all fonts. If still not working, you can attached your design.qar here for us to have a look? 

 

Thanks, 

best regards, 

kentan 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
1,180 Views

Thank you for your helpful response! I did as you suggested and reset all fonts under the block/symbols heading and didn't see any change. I also right clicked on a random symbol from the library (they are all affected) and found a way to edit the symbol itself and resize, however even editing the font size in this mode wouldn't fix the problem and I couldn't go below font size 6. Also, for some reason the editor won't let me resize the text fields despite having little handles that look like they want to allow for that. It seems like almost as big an issue as the font size would be that the text fields aren't auto resizing.  

 

I would like to upload a design.qar as you suggested, but I have to apologize for my lack of experience. I'm not exactly sure where that would be or how to create one. I didn't see it in any of my project files unless I overlooked it. Is it one of the installed files in the quartus directory? Any help would be appreciate, thanks!  

 

As a side note, every one of these projects when opened from a desktop computer with a larger screen size but similar or less resolution displays the symbols properly.
Altera_Forum
Honored Contributor I
1,180 Views

Hi, 

 

If you open your design in Quartus II , on the Menu there is a Project submenu. On this submenu is an Archive Project. If you run this a <project>.qar file will be created which you can send.
Altera_Forum
Honored Contributor I
1,180 Views

Thank you so much for your continued help. I created a generic sample project with a few megafunctions on a block diagram to demonstrate the display issue and archived it. Attached is the QAR file along with a screen shot of what the project looks like on my display for comparison. Please let me know what you think when you have a chance.

Altera_Forum
Honored Contributor I
1,180 Views

I try to check on my side I did not see the problem that you were seeing. Attached screenshot, may be you can try on different machine?  

 

One things to note that this might be most probably due you rendering pb on your machine, you can check this forum out https://alteraforum.com/forum/showthread.php?t=47447 

 

Thanks, 

Best regards, 

kentan 

(This message was posted on behalf of Intel Corporation)
Altera_Forum
Honored Contributor I
1,180 Views

Thank you for that information, it has given me a new line of approach to try and solve this problem. I agree that it's definitely my machine, because I've been able to open these same files on my desktop with no problem. I read through the forum and did try a few of the proposed solutions, including creating the environmental variable, but nothing has worked yet. I'm going to keep researching this and I'll post here if I finally reach a solution. I feel fairly confident it has something to do with the way Java is rendering the text windows.

Altera_Forum
Honored Contributor I
1,180 Views

Hello, I'm experiencing something similar since I updates to Quartus Prime. 

Did you finally found a solution?
Altera_Forum
Honored Contributor I
1,180 Views

Finally, I created the environmental variable like explained in the link kentan sent and it worked for me: 

  1. control panel 

  2. system and security 

  3. system 

  4. Remote settings 

  5. Advanced tab 

  6. click Environment variables 

  7. create a J2D_D3D variable 

  8. and set the value to false. 

CHan0
Beginner
1,180 Views

I followed every step but still can't make the block diagram look normal (or readable). Please see the attached pic.

Can any one help me to solve this issue?

(Hello Intel, 4k monitor is not a new technology, not like 10nm/7nm chip, so please try to update and solve this mess....)Annotation 2019-05-20 021029.png

Mafate
Novice
1,180 Views

Hello

I have the same issue with Quartus 18.1 lite and Windows 10.

Please, any solution for this issue ?

AIzar
Beginner
1,180 Views

That worked beautifully. Thanks!

Reply