Community
cancel
Showing results for 
Search instead for 
Did you mean: 
SYosh17
Beginner
364 Views

Board Test System error "FPGA is not detected in the Jtag Chain"

Hi,

I have Cyclone 10 GX FPGA Development Kit and want to use Board Test System according to the Intel Cyclone 10 GX FPGA Development Kit User Guide.

However, they did not work with error “FPGA is not detected in the Jtag Chain.”.

The result of jtagconfig is below.

C:\Users\user>jtagconfig 1) USB-BlasterII [USB-1] 031820DD 10M08SA(.|ES)/10M08SC 02E120DD !   Captured DR after reset = (0063041BB02E120DD) [65] Captured IR after reset = (0AAD55) [21] Captured Bypass after reset = (2) [3] Captured Bypass chain = (2) [3] JTAG clock speed 24 MHz

Could you tell me how to avoid this error?

0 Kudos
11 Replies
165 Views

Hello,

 

Welcome to INTEL forum. Could you try reduce the JTAG clock speed to 6 MHz and try it back.

SYosh17
Beginner
165 Views

Thank you for your reply.

I changed the JTAG clock, however it did not work.

The result of jtagconfig is below.

C:\Users\user>jtagconfig --setparam 1 JtagClock 6M   C:\Users\user>jtagconfig 1) USB-BlasterII [USB-1] 031820DD 10M08SA(.|ES)/10M08SC 02E120DD !   Captured DR after reset = (0063041BB02E120DD) [65] Captured IR after reset = (0AAD55) [21] Captured Bypass after reset = (2) [3] Captured Bypass chain = (2) [3] JTAG clock speed 6 MHz

Would you mind helping me?

 

165 Views

If you see the similar issue ! warning as above [open Nios II prompt Command, and execute command "jtagconfig".], it probably the windows issue.

Solution:

Open Quartus / Quartus Programmer as Run as Administrator. This should help you to detect the device.

Thanks

SYosh17
Beginner
165 Views

Thank you for your reply.

 

Before performing the following, I opened quartus prime pro as administrator.

I tried running the Cyclone X Board Test System as administrator, but it still did not work. The error is also still “FPGA is not detected in the Jtag Chain.”.

I also tried running jtagconfig command as administrator, the result is same as the one I posted last time.

 

Could you tell me how to solve this error?

165 Views

Could you try this sequence:

1. restart PC, 2.run Programmer as administrator, 3. open nios II command prompt (not admistrator). 4. jtagconfig

SYosh17
Beginner
165 Views

Thank you for your replay.

 

I tried suggested sequence and it works!

I also tried to run Board Test System as administrator after lunch Programmer.

The board test system started successfully.

However, executing "Compose with GPIO / FLASH design" failed.

exeption.png

I found some error in the “bts_log.txt”. I attached the file.

1 21, 2020 10:05:08 AM com.intel.bts.VersionSelector readInifile Error: java.io.FileNotFoundException: bts.ini 1 21, 2020 10:05:21 AM com.intel.bts.SysConService <init> Error: java.io.IOException: Get master service paths failed! Device: "/devices/10CX220Y@2#USB-1" Type:

Could you please tell me how to configure using board test system.

165 Views

Hi Sir

 

May i know which Quartus version you use?

SYosh17
Beginner
165 Views

I use Quartus Prime pro 19.3.

 

165 Views

May I know, have you tried BTS test with Quartus Prime Pro 17.1. The manufactured board’s BTS was built with Quartus Prime Pro 17.1. Possibly the error it is caused by the difference in system console of different Quartus revisions. It is suggested to use the right Quartus version with the right dev.kit version.

Refer to link: https://www.intel.com/content/www/us/en/programmable/products/boards_and_kits/dev-kits/altera/cyclon...

SYosh17
Beginner
165 Views

I cleanly installed Windows 10 and Quartus Prime Pro 17.1

Then, I was able to configure with Board Test System.

Thank you very much!

165 Views

Thanks for your feedback and glad we could help.

Reply